[1/2] camel git commit: Removing netty from managed dependencies and fix spring-boot tests

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[1/2] camel git commit: Removing netty from managed dependencies and fix spring-boot tests

nferraro
Repository: camel
Updated Branches:
  refs/heads/master 8519bb3ea -> 0229cbcfb


Removing netty from managed dependencies and fix spring-boot tests


Project: http://git-wip-us.apache.org/repos/asf/camel/repo
Commit: http://git-wip-us.apache.org/repos/asf/camel/commit/0229cbcf
Tree: http://git-wip-us.apache.org/repos/asf/camel/tree/0229cbcf
Diff: http://git-wip-us.apache.org/repos/asf/camel/diff/0229cbcf

Branch: refs/heads/master
Commit: 0229cbcfbe54bd84a45becc0c408346264f768ad
Parents: 371a4ea
Author: Nicola Ferraro <[hidden email]>
Authored: Fri Sep 22 14:45:21 2017 +0200
Committer: Nicola Ferraro <[hidden email]>
Committed: Fri Sep 22 17:15:19 2017 +0200

----------------------------------------------------------------------
 components/camel-netty4/pom.xml                                | 1 +
 parent/pom.xml                                                 | 6 ------
 .../spring-boot/components-starter/camel-ahc-starter/pom.xml   | 5 -----
 .../components-starter/camel-ahc-ws-starter/pom.xml            | 5 -----
 platforms/spring-boot/spring-boot-dm/pom.xml                   | 1 -
 .../apache/camel/itest/springboot/util/ArquillianPackager.java | 2 ++
 .../org/apache/camel/itest/springboot/util/JarExporter.java    | 3 +--
 .../src/main/resources/spring-boot-fix-dependencies.properties | 3 ---
 8 files changed, 4 insertions(+), 22 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/camel/blob/0229cbcf/components/camel-netty4/pom.xml
----------------------------------------------------------------------
diff --git a/components/camel-netty4/pom.xml b/components/camel-netty4/pom.xml
index 60fcd9b..d4aa394 100644
--- a/components/camel-netty4/pom.xml
+++ b/components/camel-netty4/pom.xml
@@ -46,6 +46,7 @@
     <dependency>
       <groupId>io.netty</groupId>
       <artifactId>netty-all</artifactId>
+      <version>${netty-version}</version>
     </dependency>
     <dependency>
       <groupId>commons-pool</groupId>

http://git-wip-us.apache.org/repos/asf/camel/blob/0229cbcf/parent/pom.xml
----------------------------------------------------------------------
diff --git a/parent/pom.xml b/parent/pom.xml
index 1ba4c4e..0034bf9 100644
--- a/parent/pom.xml
+++ b/parent/pom.xml
@@ -3627,12 +3627,6 @@
         <version>${fastjson-version}</version>
       </dependency>
 
-      <dependency>
-        <groupId>io.netty</groupId>
-        <artifactId>netty-all</artifactId>
-        <version>${netty-version}</version>
-      </dependency>
-
       <!-- abdera dependencies-->
       <dependency>
         <groupId>org.apache.abdera</groupId>

http://git-wip-us.apache.org/repos/asf/camel/blob/0229cbcf/platforms/spring-boot/components-starter/camel-ahc-starter/pom.xml
----------------------------------------------------------------------
diff --git a/platforms/spring-boot/components-starter/camel-ahc-starter/pom.xml b/platforms/spring-boot/components-starter/camel-ahc-starter/pom.xml
index db544a7..353747c 100644
--- a/platforms/spring-boot/components-starter/camel-ahc-starter/pom.xml
+++ b/platforms/spring-boot/components-starter/camel-ahc-starter/pom.xml
@@ -41,11 +41,6 @@
     </dependency>
     <!--START OF GENERATED CODE-->
     <dependency>
-      <groupId>io.netty</groupId>
-      <artifactId>netty-all</artifactId>
-      <version>${ahc-netty-version}</version>
-    </dependency>
-    <dependency>
       <groupId>org.apache.camel</groupId>
       <artifactId>camel-core-starter</artifactId>
     </dependency>

http://git-wip-us.apache.org/repos/asf/camel/blob/0229cbcf/platforms/spring-boot/components-starter/camel-ahc-ws-starter/pom.xml
----------------------------------------------------------------------
diff --git a/platforms/spring-boot/components-starter/camel-ahc-ws-starter/pom.xml b/platforms/spring-boot/components-starter/camel-ahc-ws-starter/pom.xml
index 8fdb350..99cf0be 100644
--- a/platforms/spring-boot/components-starter/camel-ahc-ws-starter/pom.xml
+++ b/platforms/spring-boot/components-starter/camel-ahc-ws-starter/pom.xml
@@ -41,11 +41,6 @@
     </dependency>
     <!--START OF GENERATED CODE-->
     <dependency>
-      <groupId>io.netty</groupId>
-      <artifactId>netty-all</artifactId>
-      <version>${ahc-netty-version}</version>
-    </dependency>
-    <dependency>
       <groupId>org.apache.camel</groupId>
       <artifactId>camel-core-starter</artifactId>
     </dependency>

http://git-wip-us.apache.org/repos/asf/camel/blob/0229cbcf/platforms/spring-boot/spring-boot-dm/pom.xml
----------------------------------------------------------------------
diff --git a/platforms/spring-boot/spring-boot-dm/pom.xml b/platforms/spring-boot/spring-boot-dm/pom.xml
index 9fb7c6c..6b0dff6 100644
--- a/platforms/spring-boot/spring-boot-dm/pom.xml
+++ b/platforms/spring-boot/spring-boot-dm/pom.xml
@@ -63,7 +63,6 @@
     <hadoop2-version>2.7.2</hadoop2-version>
 
     <!-- Custom dependency required by some modules -->
-    <ahc-netty-version>4.0.46.Final</ahc-netty-version>
     <cassandra-netty-version-testing>4.0.44.Final</cassandra-netty-version-testing>
     <infinispan-spring-boot-version>1.0.0.Final</infinispan-spring-boot-version>
     <groovy-version>2.4.12</groovy-version>

http://git-wip-us.apache.org/repos/asf/camel/blob/0229cbcf/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/util/ArquillianPackager.java
----------------------------------------------------------------------
diff --git a/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/util/ArquillianPackager.java b/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/util/ArquillianPackager.java
index 0ef066c..d3a577d 100644
--- a/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/util/ArquillianPackager.java
+++ b/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/util/ArquillianPackager.java
@@ -302,6 +302,7 @@ public final class ArquillianPackager {
         ignore.add("commons-beanutils:commons-beanutils");
         ignore.add("io.fabric8:kubernetes-");
         ignore.add("io.netty:netty:jar"); // an old version
+        ignore.add("io.netty:netty-tcnative-boringssl-static");
         ignore.add("io.swagger:swagger-parser");
         ignore.add("org.apache.commons");
         ignore.add("org.apache.curator");
@@ -322,6 +323,7 @@ public final class ArquillianPackager {
         ignore.add("org.easytesting");
         ignore.add("net.openhft");
         ignore.add("net.sourceforge.htmlunit:htmlunit-core-js"); // v 2.21 does not exist
+        ignore.add("org.springframework.cloud"); // too many different versions
         ignore.add("org.springframework.data");
         ignore.add("org.springframework.security:spring-security-jwt");
         ignore.add("org.springframework.security:spring-security-rsa");

http://git-wip-us.apache.org/repos/asf/camel/blob/0229cbcf/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/util/JarExporter.java
----------------------------------------------------------------------
diff --git a/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/util/JarExporter.java b/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/util/JarExporter.java
index 4f0de2e..84dde29 100644
--- a/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/util/JarExporter.java
+++ b/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/util/JarExporter.java
@@ -32,8 +32,7 @@ public class JarExporter {
     public void exportJar() throws Exception {
 
         Archive<?> archive = ArquillianPackager.springBootPackage(new ITestConfigBuilder()
-                .module("camel-cache")
-                .resource("components/cache-ehcache.xml", "ehcache.xml")
+                .module("camel-ahc")
                 .build());
 
         new ZipExporterImpl(archive).exportTo(new File("target/export.zip"), true);

http://git-wip-us.apache.org/repos/asf/camel/blob/0229cbcf/tooling/maven/camel-package-maven-plugin/src/main/resources/spring-boot-fix-dependencies.properties
----------------------------------------------------------------------
diff --git a/tooling/maven/camel-package-maven-plugin/src/main/resources/spring-boot-fix-dependencies.properties b/tooling/maven/camel-package-maven-plugin/src/main/resources/spring-boot-fix-dependencies.properties
index fa1dc10..b1ad02f 100644
--- a/tooling/maven/camel-package-maven-plugin/src/main/resources/spring-boot-fix-dependencies.properties
+++ b/tooling/maven/camel-package-maven-plugin/src/main/resources/spring-boot-fix-dependencies.properties
@@ -21,9 +21,6 @@
 # Global dependencies included in all modules (except the ones in the list)
 global=org.apache.camel:camel-core-starter,org.apache.camel:camel-spring-boot-starter
 
-camel-ahc=io.netty:netty-all:${ahc-netty-version}
-camel-ahc-ws=io.netty:netty-all:${ahc-netty-version}
-
 camel-bam=org.hibernate:hibernate-entitymanager,org.apache.geronimo.specs:geronimo-jta_1.1_spec
 
 # we need spring-boot in camel-core-starter

Reply | Threaded
Open this post in threaded view
|

[2/2] camel git commit: Align spring-boot libraries to 1.5.7

nferraro
Align spring-boot libraries to 1.5.7


Project: http://git-wip-us.apache.org/repos/asf/camel/repo
Commit: http://git-wip-us.apache.org/repos/asf/camel/commit/371a4ea3
Tree: http://git-wip-us.apache.org/repos/asf/camel/tree/371a4ea3
Diff: http://git-wip-us.apache.org/repos/asf/camel/diff/371a4ea3

Branch: refs/heads/master
Commit: 371a4ea373bf75a378d0a0bbc42cdddbc2bde4f8
Parents: 8519bb3
Author: Nicola Ferraro <[hidden email]>
Authored: Fri Sep 22 11:52:01 2017 +0200
Committer: Nicola Ferraro <[hidden email]>
Committed: Fri Sep 22 17:15:19 2017 +0200

----------------------------------------------------------------------
 .../camel-spring-boot-dependencies/pom.xml         |  4 ++--
 platforms/spring-boot/spring-boot-dm/pom.xml       | 17 ++++++++---------
 2 files changed, 10 insertions(+), 11 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/camel/blob/371a4ea3/platforms/spring-boot/spring-boot-dm/camel-spring-boot-dependencies/pom.xml
----------------------------------------------------------------------
diff --git a/platforms/spring-boot/spring-boot-dm/camel-spring-boot-dependencies/pom.xml b/platforms/spring-boot/spring-boot-dm/camel-spring-boot-dependencies/pom.xml
index 4fa23d0..b1f3f5e 100644
--- a/platforms/spring-boot/spring-boot-dm/camel-spring-boot-dependencies/pom.xml
+++ b/platforms/spring-boot/spring-boot-dm/camel-spring-boot-dependencies/pom.xml
@@ -189,12 +189,12 @@
       <dependency>
         <groupId>org.apache.avro</groupId>
         <artifactId>avro-mapred</artifactId>
-        <version>1.8.1</version>
+        <version>1.8.2</version>
       </dependency>
       <dependency>
         <groupId>org.apache.avro</groupId>
         <artifactId>avro-mapred</artifactId>
-        <version>1.8.1</version>
+        <version>1.8.2</version>
         <classifier>hadoop2</classifier>
       </dependency>
       <dependency>

http://git-wip-us.apache.org/repos/asf/camel/blob/371a4ea3/platforms/spring-boot/spring-boot-dm/pom.xml
----------------------------------------------------------------------
diff --git a/platforms/spring-boot/spring-boot-dm/pom.xml b/platforms/spring-boot/spring-boot-dm/pom.xml
index 67ade89..9fb7c6c 100644
--- a/platforms/spring-boot/spring-boot-dm/pom.xml
+++ b/platforms/spring-boot/spring-boot-dm/pom.xml
@@ -46,7 +46,7 @@
     <spring-boot-version>1.5.7.RELEASE</spring-boot-version>
 
     <!-- The following dependencies should be aligned with the ones in standard camel parent -->
-    <avro-version>1.8.1</avro-version>
+    <avro-version>1.8.2</avro-version>
     <cassandra-driver-guava-version>18.0</cassandra-driver-guava-version>
     <jackson-version>1.9.12</jackson-version>
 
@@ -54,7 +54,7 @@
     <google-guava-version>19.0</google-guava-version>
     <lucene3-version>3.6.0</lucene3-version>
     <scala-version>2.11.7</scala-version>
-    <scalaxml-version>1.0.4</scalaxml-version>
+    <scalaxml-version>1.0.6</scalaxml-version>
 
     <maven-checkstyle-plugin-version>2.17</maven-checkstyle-plugin-version>
     <maven-checkstyle-version>7.6.1</maven-checkstyle-version>
@@ -66,12 +66,11 @@
     <ahc-netty-version>4.0.46.Final</ahc-netty-version>
     <cassandra-netty-version-testing>4.0.44.Final</cassandra-netty-version-testing>
     <infinispan-spring-boot-version>1.0.0.Final</infinispan-spring-boot-version>
-    <groovy-version>2.4.10</groovy-version>
+    <groovy-version>2.4.12</groovy-version>
 
     <!-- The following versions should be aligned with the ones in spring-boot-repo/spring-boot-dependencies/pom.xml (for the targeted version of spring-boot) -->
-    <!-- for example: https://github.com/spring-projects/spring-boot/blob/v1.5.6.RELEASE/spring-boot-dependencies/pom.xml -->
-    <jackson2-version>2.8.8</jackson2-version>
-    <scala-jackson2-version>2.8.9</scala-jackson2-version>
+    <!-- for example: https://github.com/spring-projects/spring-boot/blob/v1.5.7.RELEASE/spring-boot-dependencies/pom.xml -->
+    <jackson2-version>2.8.10</jackson2-version>
     <jetty9-version>9.4.6.v20170531</jetty9-version>
     <jetty-version>${jetty9-version}</jetty-version>
     <jna-version>4.2.2</jna-version>
@@ -79,9 +78,9 @@
     <htmlunit-version>2.21</htmlunit-version>
     <log4j2-version>2.7</log4j2-version>
     <slf4j-version>1.7.25</slf4j-version>
-    <spring-version>4.3.10.RELEASE</spring-version>
-    <spring-data-releasetrain-version>Ingalls-SR6</spring-data-releasetrain-version>
-    <spring-integration-version>4.3.11.RELEASE</spring-integration-version>
+    <spring-version>4.3.11.RELEASE</spring-version>
+    <spring-data-releasetrain-version>Ingalls-SR7</spring-data-releasetrain-version>
+    <spring-integration-version>4.3.12.RELEASE</spring-integration-version>
     <spring-security-version>4.2.3.RELEASE</spring-security-version>
   </properties>