[1/3] camel git commit: moving properties to main camel pom and rebuild

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[1/3] camel git commit: moving properties to main camel pom and rebuild

nferraro
Repository: camel
Updated Branches:
  refs/heads/boot2 e7de255f9 -> 8033b30c9


http://git-wip-us.apache.org/repos/asf/camel/blob/45d81300/pom.xml
----------------------------------------------------------------------
diff --git a/pom.xml b/pom.xml
index b608f9d..0abd51a 100755
--- a/pom.xml
+++ b/pom.xml
@@ -61,6 +61,717 @@
     <mycila-license-version>3.0</mycila-license-version>
     <gmavenplus-plugin-version>1.5</gmavenplus-plugin-version>
     <groovy-version>2.4.12</groovy-version>
+
+    <!-- dependency versions -->
+    <abdera-version>1.1.3</abdera-version>
+    <!-- Note that activemq dependency is only used for testing! -->
+    <activemq-version>5.15.0</activemq-version>
+    <activemq-artemis-version>2.2.0</activemq-artemis-version>
+    <aether-version>1.0.2.v20150114</aether-version>
+    <ahc-version>2.0.35</ahc-version>
+    <ant-bundle-version>1.7.0_6</ant-bundle-version>
+    <antlr-bundle-version>3.5.2_1</antlr-bundle-version>
+    <antlr-runtime-bundle-version>3.5.2_1</antlr-runtime-bundle-version>
+    <aopalliance-bundle-version>1.0_6</aopalliance-bundle-version>
+    <apacheds-version>2.0.0-M24</apacheds-version>
+    <apache-drill-version>1.11.0</apache-drill-version>
+    <apache-gora-version>0.7</apache-gora-version>
+    <apache-mime4j-version>0.7.2</apache-mime4j-version>
+    <aries-blueprint-api-version>1.0.1</aries-blueprint-api-version>
+    <aries-blueprint-cm-version>1.0.6</aries-blueprint-cm-version>
+    <aries-blueprint-core-version>1.4.4</aries-blueprint-core-version>
+    <aries-blueprint-proxy-version>1.0.1</aries-blueprint-proxy-version>
+    <aries-blueprint-proxy-impl-version>1.0.4</aries-blueprint-proxy-impl-version>
+    <aries-spifly-version>1.0.8</aries-spifly-version>
+    <aries-util-version>1.1.3</aries-util-version>
+    <arquillian-container-se-managed-version>1.0.0.Final</arquillian-container-se-managed-version>
+    <arquillian-version>1.1.13.Final</arquillian-version>
+    <arquillian-weld-embedded-version>2.0.0.Beta4</arquillian-weld-embedded-version>
+    <asciidoctorj-version>1.5.6</asciidoctorj-version>
+    <asm-version>5.0.4</asm-version>
+    <aspectj-version>1.8.10</aspectj-version>
+    <assertj-version>3.8.0</assertj-version>
+    <asterisk-java-version>1.0.0-final</asterisk-java-version>
+    <asterisk-java-bundle-version>1.0.0-final_1</asterisk-java-bundle-version>
+    <atmos-client-version>2.2.2</atmos-client-version>
+    <atmosphere-version>2.4.10</atmosphere-version>
+    <atmosphere-version-range>[2.4,3.0)</atmosphere-version-range>
+    <atomix-version>1.0.8</atomix-version>
+    <atomix-catalyst-version>1.2.1</atomix-catalyst-version>
+    <atomix-copycat-version>1.2.8</atomix-copycat-version>
+    <automaton-bundle-version>1.11-8_1</automaton-bundle-version>
+    <avalon-bundle-version>4.3.1_1</avalon-bundle-version>
+    <avalon-version>4.3.1</avalon-version>
+    <avro-version>1.8.2</avro-version>
+    <avro-bundle-version>1.8.2_1</avro-bundle-version>
+    <avro-ipc-bundle-version>1.8.2_1</avro-ipc-bundle-version>
+    <awaitility-version>3.0.0</awaitility-version>
+    <aws-java-sdk-bundle-version>1.11.186_1</aws-java-sdk-bundle-version>
+    <aws-java-sdk-version>1.11.186</aws-java-sdk-version>
+    <axiom-version>1.2.14</axiom-version>
+    <azure-storage-java-sdk-version>5.5.0</azure-storage-java-sdk-version>
+    <azure-storage-java-sdk-bundle-version>5.5.0_1</azure-storage-java-sdk-bundle-version>
+    <azure-keyvault-core-bundle-version>1.0.0_1</azure-keyvault-core-bundle-version>
+    <backport-util-concurrent-version>3.1</backport-util-concurrent-version>
+    <bcel-bundle-version>5.2_4</bcel-bundle-version>
+    <beanio-version>2.1.0</beanio-version>
+    <beanstalkd-client-version>1.4.6</beanstalkd-client-version>
+    <bndlib-version>2.4.0</bndlib-version>
+    <bsh-version>2.0b6</bsh-version>
+    <boon-version>0.34</boon-version>
+    <bouncycastle-version>1.57</bouncycastle-version>
+    <boxjavalibv2.version>3.2.1</boxjavalibv2.version>
+    <box-java-sdk-version>2.1.1</box-java-sdk-version>
+    <braintree-gateway-version>2.63.0</braintree-gateway-version>
+    <brave-zipkin-version>4.5.2</brave-zipkin-version>
+    <build-helper-maven-plugin-version>1.10</build-helper-maven-plugin-version>
+    <c3p0-version>0.9.5.2</c3p0-version>
+    <c3p0-bundle-version>0.9.5.2_1</c3p0-bundle-version>
+    <caffeine-version>2.5.5</caffeine-version>
+    <californium-version>1.0.6</californium-version>
+    <camel-test-spring-artifactId>camel-test-spring</camel-test-spring-artifactId>
+    <cassandra-driver-version>3.3.0</cassandra-driver-version>
+    <cassandra-metrics-version>3.2.2</cassandra-metrics-version>
+    <cassandra-driver-guava-version>18.0</cassandra-driver-guava-version>
+    <cassandra-version>3.7</cassandra-version>
+    <cassandra-unit-version>3.1.3.2</cassandra-unit-version>
+    <castor-version>1.3.3</castor-version>
+    <castor-bundle-version>1.3.3_1</castor-bundle-version>
+    <cdi-api-1.0-version>1.0-SP4</cdi-api-1.0-version>
+    <cdi-api-1.1-version>1.1</cdi-api-1.1-version>
+    <cdi-api-1.2-version>1.2</cdi-api-1.2-version>
+    <cdi-api-2.0-version>2.0</cdi-api-2.0-version>
+    <jta-api-1.2-version>1.2</jta-api-1.2-version>
+    <cglib-bundle-version>3.2.5_1</cglib-bundle-version>
+    <cglib-version>3.2.5</cglib-version>
+    <chronicle-bytes-version>1.9.7</chronicle-bytes-version>
+    <chronicle-core-version>1.9.9</chronicle-core-version>
+    <chronicle-engine-version>1.13.27</chronicle-engine-version>
+    <chronicle-map-version>2.4.17</chronicle-map-version>
+    <chronicle-network-version>1.9.4</chronicle-network-version>
+    <chronicle-queue-version>4.5.27</chronicle-queue-version>
+    <chronicle-threads-version>1.8.2</chronicle-threads-version>
+    <chronicle-wire-version>1.9.13</chronicle-wire-version>
+    <chunk-templates-version>3.2.4</chunk-templates-version>
+    <chunk-templates-bundle-version>3.2.4_1</chunk-templates-bundle-version>
+    <classmate-version>1.3.3</classmate-version>
+    <cmis-version>0.13.0</cmis-version>
+    <cometd-bayeux-version>6.1.11</cometd-bayeux-version>
+    <cometd-java-client-version>3.1.2</cometd-java-client-version>
+    <cometd-java-server-bundle-version>2.3.1_2</cometd-java-server-bundle-version>
+    <cometd-java-server>3.1.2</cometd-java-server>
+    <commons-beanutils-version>1.9.3</commons-beanutils-version>
+    <commons-beanutils-bundle-version>1.8.3_1</commons-beanutils-bundle-version>
+    <commons-codec-version>1.10</commons-codec-version>
+    <commons-collections-version>3.2.2</commons-collections-version>
+    <commons-compress-version>1.14</commons-compress-version>
+    <commons-configuration-version>1.9</commons-configuration-version>
+    <commons-configuration-bundle-version>1.9_1</commons-configuration-bundle-version>
+    <commons-csv-version>1.4</commons-csv-version>
+    <commons-cli-version>1.3.1</commons-cli-version>
+    <commons-daemon-version>1.0.15</commons-daemon-version>
+    <commons-dbcp-version>1.4</commons-dbcp-version>
+    <commons-dbcp2-version>2.1.1</commons-dbcp2-version>
+    <commons-digester-1x-version>1.8.1</commons-digester-1x-version>
+    <commons-digester-version>2.1</commons-digester-version>
+    <commons-exec-version>1.3</commons-exec-version>
+    <commons-httpclient-bundle-version>3.1_7</commons-httpclient-bundle-version>
+    <commons-io-version>2.4</commons-io-version>
+    <commons-jexl2-version>2.1.1</commons-jexl2-version>
+    <commons-jxpath-version>1.3</commons-jxpath-version>
+    <commons-lang-version>2.6</commons-lang-version>
+    <commons-lang3-version>3.6</commons-lang3-version>
+    <commons-logging-version>1.2</commons-logging-version>
+    <commons-math-version>2.2</commons-math-version>
+    <commons-math3-version>3.6.1</commons-math3-version>
+    <commons-net-version>3.6</commons-net-version>
+    <commons-pool-version>1.6</commons-pool-version>
+    <commons-pool2-version>2.4.2</commons-pool2-version>
+    <commons-text-version>1.1</commons-text-version>
+    <commons-vfs2-version>2.0</commons-vfs2-version>
+    <compress-lzf-version>1.0.4</compress-lzf-version>
+    <consul-client-version>0.16.2</consul-client-version>
+    <consul-client-bundle-version>0.16.2_1</consul-client-bundle-version>
+    <cobertura-maven-plugin-version>2.7</cobertura-maven-plugin-version>
+    <couchbase-client-version>1.4.13</couchbase-client-version>
+    <couchbase-client-bundle-version>1.4.13_1</couchbase-client-bundle-version>
+    <curator-version>2.12.0</curator-version>
+    <cxf-version>3.1.12</cxf-version>
+    <cxf-version-range>[3.0,4.0)</cxf-version-range>
+    <cxf-xjc-plugin-version>3.0.5</cxf-xjc-plugin-version>
+    <cxf-xjc-utils-version>3.0.5</cxf-xjc-utils-version>
+    <deltaspike-version>1.8.0</deltaspike-version>
+    <depends-maven-plugin-version>1.3.1</depends-maven-plugin-version>
+    <derby-version>10.11.1.1</derby-version>
+    <digitalocean-api-client-version>2.12</digitalocean-api-client-version>
+    <digitalocean-api-client-bundle-version>2.12_1</digitalocean-api-client-bundle-version>
+    <disruptor-version>3.3.6</disruptor-version>
+    <dnsjava-version>2.1.8</dnsjava-version>
+    <dnsjava-bundle-version>2.1.8_1</dnsjava-bundle-version>
+    <docker-java-version>3.0.13</docker-java-version>
+    <docker-java-bundle-version>3.0.13_1</docker-java-bundle-version>
+    <docker-maven-plugin-version>0.22.0</docker-maven-plugin-version>
+    <dom4j-bundle-version>1.6.1_5</dom4j-bundle-version>
+    <dozer-version>6.1.0</dozer-version>
+    <drools-version>6.5.0.Final</drools-version>
+    <dropbox-version>1.8.2</dropbox-version>
+    <easymock-version>3.4</easymock-version>
+    <eclipse-equinox-common-version>3.3.0-v20070426</eclipse-equinox-common-version>
+    <egit-github-core-version>2.1.5</egit-github-core-version>
+    <egit-github-core-bundle-version>2.1.5_1</egit-github-core-bundle-version>
+    <ehcache-version>2.10.1</ehcache-version>
+    <ehcache3-version>3.4.0</ehcache3-version>
+    <ekstazi-maven-plugin-version>4.6.3</ekstazi-maven-plugin-version>
+    <elasticsearch-bundle-version>2.4.4_1</elasticsearch-bundle-version>
+    <elasticsearch-guava-version>18.0</elasticsearch-guava-version>
+    <elasticsearch-version>2.4.4</elasticsearch-version>
+    <elasticsearch5-version>5.5.2</elasticsearch5-version>
+    <elasticsearch5-bundle-version>5.5.2_1</elasticsearch5-bundle-version>
+    <elasticsearch-cluster-runner-version>2.4.0.0</elasticsearch-cluster-runner-version>
+    <elasticsearch5-cluster-runner-version>5.5.2.0</elasticsearch5-cluster-runner-version>
+    <elsql-version>1.2</elsql-version>
+    <el-api-1.0-version>1.0.1</el-api-1.0-version>
+    <!-- embedmongo 1.50.2 do not work -->
+    <embedmongo-version>1.50.1</embedmongo-version>
+    <etcd4j-version>2.13.0</etcd4j-version>
+    <exec-maven-plugin-version>1.6.0</exec-maven-plugin-version>
+    <ezmorph-bundle-version>1.0.6_1</ezmorph-bundle-version>
+    <fabric8-maven-plugin-version>3.5.26</fabric8-maven-plugin-version>
+    <facebook4j-core-version>2.4.10</facebook4j-core-version>
+    <facebook4j-core-bundle-version>2.4.10_1</facebook4j-core-bundle-version>
+    <fastinfoset-version>1.2.13_1</fastinfoset-version>
+    <fastjson-version>1.2.37</fastjson-version>
+    <fastjson-bundle-version>1.2.37_1</fastjson-bundle-version>
+    <felix-configadmin-version>1.8.8</felix-configadmin-version>
+    <felix-connect-version>0.1.0</felix-connect-version>
+    <felix-fileinstall-version>3.5.2</felix-fileinstall-version>
+    <felix-framework-version>3.2.2</felix-framework-version>
+    <felix-scr-annotations-version>1.9.12</felix-scr-annotations-version>
+    <findbugs-maven-plugin-version>2.5.2</findbugs-maven-plugin-version>
+    <flatpack-version>3.4.3</flatpack-version>
+    <flink-version>1.3.2</flink-version>
+    <fop-bundle-version>2.1_1</fop-bundle-version>
+    <fop-version>2.1</fop-version>
+    <ftpserver-version>1.0.6</ftpserver-version>
+    <freemarker-bundle-version>2.3.23_1</freemarker-bundle-version>
+    <freemarker-version>2.3.23</freemarker-version>
+    <generex-bundle-version>1.0.1_2</generex-bundle-version>
+    <gentlyweb-bundle-version>1.5_1</gentlyweb-bundle-version>
+    <geocoder-java-version>0.16</geocoder-java-version>
+    <geronimo-annotation-1.0-spec-version>1.1.1</geronimo-annotation-1.0-spec-version>
+    <geronimo-annotation-1.2-spec-version>1.0</geronimo-annotation-1.2-spec-version>
+    <geronimo-atinject-1.0-spec-version>1.0</geronimo-atinject-1.0-spec-version>
+    <geronimo-ejb_3.1_spec-version>1.0.2</geronimo-ejb_3.1_spec-version>
+    <geronimo-el-spec-version>1.0.1</geronimo-el-spec-version>
+    <geronimo-interceptor-1.1-spec-version>1.0</geronimo-interceptor-1.1-spec-version>
+    <geronimo-interceptor-1.2-spec-version>1.0</geronimo-interceptor-1.2-spec-version>
+    <geronimo-j2ee-connector-spec-version>2.0.0</geronimo-j2ee-connector-spec-version>
+    <geronimo-j2ee-jacc-spec-version>1.1</geronimo-j2ee-jacc-spec-version>
+    <geronimo-j2ee-management-spec-version>1.1</geronimo-j2ee-management-spec-version>
+    <geronimo-jcdi-1.0-spec-version>1.0</geronimo-jcdi-1.0-spec-version>
+    <geronimo-jcdi-1.1-spec-version>1.0</geronimo-jcdi-1.1-spec-version>
+    <geronimo-jms-spec-version>1.1.1</geronimo-jms-spec-version>
+    <geronimo-jms2-spec-version>1.0-alpha-2</geronimo-jms2-spec-version>
+    <geronimo-jpa-spec-version>1.0-alpha-1</geronimo-jpa-spec-version>
+    <geronimo-jsp-spec-version>1.1</geronimo-jsp-spec-version>
+    <geronimo-json-spec-version>1.0</geronimo-json-spec-version>
+    <geronimo-jta-spec-version>1.1.1</geronimo-jta-spec-version>
+    <geronimo-servlet-spec-version>1.0</geronimo-servlet-spec-version>
+    <geronimo-servlet-2.5-spec-version>1.2</geronimo-servlet-2.5-spec-version>
+    <geronimo-ws-metadata-spec-version>1.1.3</geronimo-ws-metadata-spec-version>
+    <gmetric4j-version>1.0.10</gmetric4j-version>
+    <google-guava-version>19.0</google-guava-version>
+    <google-api-client-version>1.22.0</google-api-client-version>
+    <google-api-services-drive-version>v2-rev263-1.22.0</google-api-services-drive-version>
+    <google-api-services-calendar-version>v3-rev243-1.22.0</google-api-services-calendar-version>
+    <google-api-services-mail-version>v1-rev63-1.22.0</google-api-services-mail-version>
+    <google-api-services-bigquery-version>v2-rev352-1.22.0</google-api-services-bigquery-version>
+    <google-api-services-pubsub-version>v1-rev12-1.22.0</google-api-services-pubsub-version>
+    <google-truth-version>0.30</google-truth-version>
+    <grizzly-websockets-version>2.3.25</grizzly-websockets-version>
+    <grpc-version>1.6.1</grpc-version>
+    <grpc-google-auth-library-version>0.7.1</grpc-google-auth-library-version>
+    <grpc-java-jwt-version>3.2.0</grpc-java-jwt-version>
+    <grpc-netty-tcnative-boringssl-static-version>2.0.5.Final</grpc-netty-tcnative-boringssl-static-version>
+    <grpc-bundle-version>1.6.1_1</grpc-bundle-version>
+    <gson-version>2.8.1</gson-version>
+    <guice-version>4.0</guice-version>
+    <guice3-version>3.0</guice3-version>
+    <guice-bundle-version>3.0_1</guice-bundle-version>
+    <hadoop-bundle-version>1.2.1_1</hadoop-bundle-version>
+    <hadoop-version>1.2.1</hadoop-version>
+    <hadoop2-bundle-version>2.7.2_1</hadoop2-bundle-version>
+    <hadoop2-version>2.7.2</hadoop2-version>
+    <hadoop2-protobuf-version>2.5.0</hadoop2-protobuf-version>
+    <hamcrest-version>2.0.0.0</hamcrest-version>
+    <hapi-version>2.2</hapi-version>
+    <hawtbuf-version>1.11</hawtbuf-version>
+    <hawtdb-version>1.6</hawtdb-version>
+    <hawtdispatch-version>1.22</hawtdispatch-version>
+    <hazelcast-version>3.8.5</hazelcast-version>
+    <hbase-version>1.2.6</hbase-version>
+    <hessian-version>4.0.38</hessian-version>
+    <hibernate-validator-version>5.4.1.Final</hibernate-validator-version>
+    <hibernate-version>5.0.12.Final</hibernate-version>
+    <hikaricp-version>2.3.13</hikaricp-version>
+    <hk2-version>2.3.0</hk2-version>
+    <hk2-osgi-resource-version>1.0.1</hk2-osgi-resource-version>
+    <hsqldb-version>2.4.0</hsqldb-version>
+    <htmlunit-version>2.24</htmlunit-version>
+    <htmlunit-bundle-version>2.24_1</htmlunit-bundle-version>
+    <htmlunit-core-js-version>2.23</htmlunit-core-js-version>
+    <htrace-version>3.1.0-incubating</htrace-version>
+    <httpunit-version>1.7</httpunit-version>
+    <httpcore4-version>4.4.6</httpcore4-version>
+    <httpclient4-version>4.5.3</httpclient4-version>
+    <httpasyncclient-version>4.1.3</httpasyncclient-version>
+    <httpclient-version>3.1</httpclient-version>
+    <hystrix-version>1.5.12</hystrix-version>
+    <hystrix-bundle-version>1.5.12_1</hystrix-bundle-version>
+    <ibatis-bundle-version>2.3.4.726_4</ibatis-bundle-version>
+    <ibatis-version>2.3.4.726</ibatis-version>
+    <ical4j-version>1.0.7</ical4j-version>
+    <ignite-version>1.9.0</ignite-version>
+    <infinispan-version>9.1.0.Final</infinispan-version>
+    <infinispan-spring-boot-version>1.0.0.Final</infinispan-spring-boot-version>
+    <influx-java-driver-version>2.7</influx-java-driver-version>
+    <influx-java-driver-bundle-version>2.7_1</influx-java-driver-bundle-version>
+    <influx-guava-version>20.0</influx-guava-version>
+    <irclib-bundle-version>1.10_5</irclib-bundle-version>
+    <irclib-version>1.10</irclib-version>
+    <ironmq-version>3.0.5</ironmq-version>
+    <ironmq-bundle-version>3.0.5_1</ironmq-bundle-version>
+    <isorelax-bundle-version>20050913_4</isorelax-bundle-version>
+    <isorelax-version>20090621</isorelax-version>
+    <isorelax-jaxp-bridge-version>1.1</isorelax-jaxp-bridge-version>
+    <ivy-version>2.4.0</ivy-version>
+    <jackson-version>1.9.12</jackson-version>
+    <jackson-spark-version>2.4.5</jackson-spark-version>
+    <jackson2-scala-version>2.6.1</jackson2-scala-version>
+    <!-- jackson 2.9.x is not yet working with all camel components such as swagger-java -->
+    <jackson2-version>2.8.7</jackson2-version>
+    <jackrabbit-version>2.15.5</jackrabbit-version>
+    <jackrabbit-guava-version>15.0</jackrabbit-guava-version>
+    <jain-sip-ri-bundle-version>1.2.154_2</jain-sip-ri-bundle-version>
+    <jasn1-version>1.8.2</jasn1-version>
+    <jasper-bundle-version>6.0.44_1</jasper-bundle-version>
+    <jasypt-bundle-version>1.9.2_1</jasypt-bundle-version>
+    <jasypt-version>1.9.2</jasypt-version>
+    <java-apns-bundle-version>1.0.0.Beta6_1</java-apns-bundle-version>
+    <java-apns-version>1.0.0.Beta6</java-apns-version>
+    <java-ewah-version>1.1.6</java-ewah-version>
+    <java-util-version>1.26.0</java-util-version>
+    <jna-version>4.2.1</jna-version>
+    <jnats-version>1.0</jnats-version>
+    <javacc-maven-plugin-version>2.6</javacc-maven-plugin-version>
+    <javacrumbs-version>0.22</javacrumbs-version>
+    <javapoet-version>1.8.0</javapoet-version>
+    <javassist-bundle-version>3.12.1.GA_3</javassist-bundle-version>
+    <javassist-version>3.20.0-GA</javassist-version>
+    <javax.el-api-version>2.2.5</javax.el-api-version>
+    <javax.el-version>2.2.5</javax.el-version>
+    <javax-inject-bundle-version>1_2</javax-inject-bundle-version>
+    <javax-mail-version>1.6.0</javax-mail-version>
+    <javax.servlet-api-version>3.1.0</javax.servlet-api-version>
+    <javax.ws.rs-api-version>2.0.1</javax.ws.rs-api-version>
+    <jaxb-bundle-version>2.2.11_1</jaxb-bundle-version>
+    <jaxen-version>1.1.6</jaxen-version>
+    <jbpm-version>6.5.0.Final</jbpm-version>
+    <jboss-javaee-6-version>1.0.0.Final</jboss-javaee-6-version>
+    <jboss-logging-version>3.3.0.Final</jboss-logging-version>
+    <jboss-marshalling-version>1.4.10.Final</jboss-marshalling-version>
+    <jboss-transaction-spi.version>7.5.1.Final</jboss-transaction-spi.version>
+    <jboss-xnio-version>3.3.8.Final</jboss-xnio-version>
+    <jcache-bundle-version>1.0.0_1</jcache-bundle-version>
+    <jclouds-version>2.0.2</jclouds-version>
+    <!-- jclouds must use this guava version -->
+    <jclouds-google-guava-version>16.0.1</jclouds-google-guava-version>
+    <jclouds-google-guava-version-range>[16.0,17.0)</jclouds-google-guava-version-range>
+    <jcommander-version>1.72</jcommander-version>
+    <jcr-version>2.0</jcr-version>
+    <jdom-bundle-version>1.1_4</jdom-bundle-version>
+    <jdom-version>1.1.3</jdom-version>
+    <jedis-client-version>2.9.0</jedis-client-version>
+    <jedis-client-bundle-version>2.9.0_1</jedis-client-bundle-version>
+    <jersey-version>2.11</jersey-version>
+    <jetty6-bundle-version>6.1.26_4</jetty6-bundle-version>
+    <jetty92-version>9.2.21.v20170120</jetty92-version>
+    <!-- Jetty version 9.3.15+ contains binary incopatible API changes that break -->
+    <!-- CXF's websocket support (< 3.1.11) and camel-atmosphere-websocket -->
+    <jetty9-version>9.3.14.v20161028</jetty9-version>
+    <jetty-version>${jetty9-version}</jetty-version>
+    <jetty-plugin-version>${jetty-version}</jetty-plugin-version>
+    <jetty-runner-groupId>org.eclipse.jetty</jetty-runner-groupId>
+    <jettison-version>1.3.8</jettison-version>
+    <jgit-version>4.8.0.201706111038-r</jgit-version>
+    <jgroups-version>4.0.6.Final</jgroups-version>
+    <libthrift-version>0.10.0</libthrift-version>
+    <jibx-version>1.2.6</jibx-version>
+    <jing-bundle-version>20030619_5</jing-bundle-version>
+    <jing-version>20030619</jing-version>
+    <jini-version>2.1</jini-version>
+    <jira-rest-client-version>1.2-m01</jira-rest-client-version>
+    <jira-rest-client-api-version>2.0.0-m30</jira-rest-client-api-version>
+    <jmh-version>1.19</jmh-version>
+    <jmockit-version>1.5</jmockit-version>
+    <jodatime-bundle-version>1.6.2</jodatime-bundle-version>
+    <jodatime2-bundle-version>2.9.9</jodatime2-bundle-version>
+    <jolokia-version>1.3.7</jolokia-version>
+    <jolt-version>0.1.0</jolt-version>
+    <jolt-bundle-version>0.1.0_1</jolt-bundle-version>
+    <johnzon-version>1.1.0</johnzon-version>
+    <jose4j-version>0.4.4</jose4j-version>
+    <josql-bundle-version>1.5_5</josql-bundle-version>
+    <josql-version>1.5</josql-version>
+    <!-- Upgrade to 1.7.26 causes stability issues. See CAMEL-10477 -->
+    <jruby-version>1.7.18</jruby-version>
+    <jsendnsca-version>2.1.1</jsendnsca-version>
+    <jsmpp-version>2.3.4</jsmpp-version>
+    <jsch-version>0.1.54</jsch-version>
+    <jsch-bundle-version>0.1.54_1</jsch-bundle-version>
+    <jsonlib-bundle-version>2.4_1</jsonlib-bundle-version>
+    <jsonlib-version>2.4</jsonlib-version>
+    <json4s-bundle-version>3.2.8_1</json4s-bundle-version>
+    <json-asm-version>1.0.2</json-asm-version>
+    <json-accessors-smart-version>1.2</json-accessors-smart-version>
+    <json-path-version>2.4.0</json-path-version>
+    <json-simple-version>1.1.1</json-simple-version>
+    <!-- spring-boot uses json-smart 2.2.x -->
+    <json-smart-version>2.2.1</json-smart-version>
+    <json-smart-karaf-version>2.3</json-smart-karaf-version>
+    <jsoup-version>1.9.2</jsoup-version>
+    <jsp-api-2.1-version>1.0.1</jsp-api-2.1-version>
+    <jsr311-api-version>1.1.1</jsr311-api-version>
+    <jt400-version>9.3</jt400-version>
+    <jt400-bundle-version>9.3_1</jt400-bundle-version>
+    <juel-bundle-version>2.1.3_1</juel-bundle-version>
+    <juel-version>2.1.3</juel-version>
+    <!-- camel-itest-karaf doesn't work with JUnit 4.12 at present -->
+    <junit-bundle-version>4.11_1</junit-bundle-version>
+    <junit-toolbox-version>2.3</junit-toolbox-version>
+    <junit-version>4.12</junit-version>
+    <jxmpp-version>0.5.0</jxmpp-version>
+    <jython-version>2.5.3</jython-version>
+    <jzlib-version>1.1.3</jzlib-version>
+    <jzlib-bundle-version>1.1.3_2</jzlib-bundle-version>
+    <kafka-version>0.11.0.0</kafka-version>
+    <kafka-bundle-version>0.11.0.0_1</kafka-bundle-version>
+    <karaf2-version>2.4.4</karaf2-version>
+    <karaf4-version>4.1.2</karaf4-version>
+    <kie-version>6.5.0.Final</kie-version>
+    <krati-version>0.4.9</krati-version>
+    <kubernetes-client-version>2.6.3</kubernetes-client-version>
+    <kubernetes-model-version>1.1.4</kubernetes-model-version>
+    <kxml2-bundle-version>2.3.0_3</kxml2-bundle-version>
+    <leveldbjni-version>1.8</leveldbjni-version>
+    <leveldb-api-version>0.9</leveldb-api-version>
+    <leveldb-version>0.9</leveldb-version>
+    <libphonenumber-version>8.8.0</libphonenumber-version>
+    <libphonenumber-bundle-version>8.8.0_1</libphonenumber-bundle-version>
+    <!-- virtual dependency only used by Eclipse m2e -->
+    <lifecycle-mapping-version>1.0.0</lifecycle-mapping-version>
+    <log4j-version>1.2.17</log4j-version>
+    <log4j2-version>2.8.2</log4j2-version>
+    <log4j2-25-version>2.5</log4j2-25-version>
+    <logback-version>1.2.0</logback-version>
+    <lucene3-bundle-version>3.6.0_1</lucene3-bundle-version>
+    <lucene3-version>3.6.0</lucene3-version>
+    <lucene-bundle-version>5.5.2_1</lucene-bundle-version>
+    <!-- lucene aligned with elasticsearch version of lucene in use -->
+    <lucene-version>5.5.2</lucene-version>
+    <lucene-version-range>[5,6)</lucene-version-range>
+    <lightcouch-version>0.1.8</lightcouch-version>
+    <lightcouch-gson-version>2.4</lightcouch-gson-version>
+    <lightcouch-bundle-version>0.1.8_2</lightcouch-bundle-version>
+    <!-- needed from tooling/archetypes -->
+    <!-- use antrun 1.6 as 1.7 fails with finding tools.jar on java on some platforms -->
+    <maven-antrun-plugin-version>1.6</maven-antrun-plugin-version>
+    <maven-archetype-plugin-version>2.0</maven-archetype-plugin-version>
+    <maven-archetype-packaging-version>2.0</maven-archetype-packaging-version>
+    <maven-assembly-plugin-version>3.0.0</maven-assembly-plugin-version>
+    <maven-bundle-version>${maven-bundle-plugin-version}</maven-bundle-version>
+    <maven-bundle-plugin-version>3.3.0</maven-bundle-plugin-version>
+    <maven-checkstyle-plugin-version>2.17</maven-checkstyle-plugin-version>
+    <maven-checkstyle-version>7.6.1</maven-checkstyle-version>
+    <maven-owasp-plugin-version>2.1.1</maven-owasp-plugin-version>
+    <maven-eclipse-plugin-version>2.10</maven-eclipse-plugin-version>
+    <maven-jar-plugin-version>3.0.2</maven-jar-plugin-version>
+    <maven-javadoc-plugin-version>2.10.4</maven-javadoc-plugin-version>
+    <maven-jboss-as-maven-plugin-version>7.7.Final</maven-jboss-as-maven-plugin-version>
+    <!-- plugin-plugin 3.5 does not work -->
+    <maven-plugin-plugin-version>3.4</maven-plugin-plugin-version>
+    <maven-plugin-annotations-version>3.5</maven-plugin-annotations-version>
+    <maven-plugin-testing-harness-version>3.3.0</maven-plugin-testing-harness-version>
+    <maven-remote-resources-plugin-version>1.5</maven-remote-resources-plugin-version>
+    <!-- resources plugin needed by Camel maven archetypes -->
+    <maven-resources-plugin-version>3.0.2</maven-resources-plugin-version>
+    <maven-reporting-api-version>2.2.1</maven-reporting-api-version>
+    <maven-reporting-impl-version>2.0.5</maven-reporting-impl-version>
+    <maven-scr-plugin-version>1.22.0</maven-scr-plugin-version>
+    <maven-shade-plugin-version>3.0.0</maven-shade-plugin-version>
+    <maven-surefire-report-plugin-version>2.13</maven-surefire-report-plugin-version>
+    <maven-war-plugin-version>3.0.0</maven-war-plugin-version>
+    <mchange-commons-java-version>0.2.11</mchange-commons-java-version>
+    <!-- TODO: spring-boot uses metrics 3.1.x -->
+    <metrics-version>3.1.5</metrics-version>
+    <milo-version>0.1.3</milo-version>
+    <mina-bundle-version>1.1.7_6</mina-bundle-version>
+    <mina-version>1.1.7</mina-version>
+    <mina2-version>2.0.16</mina2-version>
+    <minimal-json-version>0.9.4</minimal-json-version>
+    <mock-javamail-version>1.9</mock-javamail-version>
+    <mockwebserver-version>0.0.15</mockwebserver-version>
+    <mockito-version>1.10.19</mockito-version>
+    <mongo-java-driver-version>3.5.0</mongo-java-driver-version>
+    <mongo-java-driver32-version>3.2.2</mongo-java-driver32-version>
+    <mongo-hadoop-version>1.5.0</mongo-hadoop-version>
+    <mqtt-client-version>1.14</mqtt-client-version>
+    <msv-version>2013.6.1</msv-version>
+    <mustache-java-version>0.9.5</mustache-java-version>
+    <mustache-guava-version>16.0</mustache-guava-version>
+    <mustache-bundle-version>0.9.5_1</mustache-bundle-version>
+    <mvel-version>2.3.1.Final</mvel-version>
+    <mybatis-version>3.4.5</mybatis-version>
+    <narayana-version>5.6.4.Final</narayana-version>
+    <neethi-bundle-version>3.0.1</neethi-bundle-version>
+    <nekohtml-version>1.9.22</nekohtml-version>
+    <neoscada-version>0.4.0</neoscada-version>
+    <netty3-version>3.10.6.Final</netty3-version>
+    <netty-version>4.1.15.Final</netty-version>
+    <netty40-version>4.0.51.Final</netty40-version>
+    <noggit-bundle-version>0.5_1</noggit-bundle-version>
+    <!-- should be in-sync with deltaspike -->
+    <openwebbeans1-version>1.2.7</openwebbeans1-version>
+    <openwebbeans-version>1.7.3</openwebbeans-version>
+    <oauth-provider-bundle-version>20100527_1</oauth-provider-bundle-version>
+    <okclient-version>3.8.1</okclient-version>
+    <okclient-bundle-version>3.8.1_1</okclient-bundle-version>
+    <olingo2-version>2.0.9</olingo2-version>
+    <olingo-odata2-core-bundle-version>2.0.9_1</olingo-odata2-core-bundle-version>
+    <olingo2-gson-version>2.4</olingo2-gson-version>
+    <olingo4-version>4.3.0</olingo4-version>
+    <ognl-version>3.1.12</ognl-version>
+    <ognl-bundle-version>3.1.12_1</ognl-bundle-version>
+    <oncrpc-version>1.1.3</oncrpc-version>
+    <openejb-version>4.7.4</openejb-version>
+    <openhft-affinity-version>3.0.6</openhft-affinity-version>
+    <openhft-compiler-version>2.3.0</openhft-compiler-version>
+    <openhft-lang-version>6.8.2</openhft-lang-version>
+    <openjpa-version>2.4.2</openjpa-version>
+    <openshift-java-client-version>2.7.0.Final</openshift-java-client-version>
+    <openstack4j-version>3.0.2</openstack4j-version>
+    <openstack4j-guava-version>17.0</openstack4j-guava-version>
+    <opentracing-java-agent-version>0.1.0</opentracing-java-agent-version>
+    <opentracing-version>0.30.0</opentracing-version>
+    <opentracing-tracerresolver-version>0.1.0</opentracing-tracerresolver-version>
+    <ops4j-base-version>1.5.0</ops4j-base-version>
+    <optaplanner-version>6.5.0.Final</optaplanner-version>
+    <oro-bundle-version>2.0.8_6</oro-bundle-version>
+    <os-maven-plugin-version>1.4.1.Final</os-maven-plugin-version>
+    <oscache-bundle-version>2.4_5</oscache-bundle-version>
+    <osgi-version>4.3.1</osgi-version>
+    <paho-version>1.2.0</paho-version>
+    <paranamer-bundle-version>2.8_1</paranamer-bundle-version>
+    <pax-cdi-version>1.0.0.RC1</pax-cdi-version>
+    <pax-exam-version>4.9.2</pax-exam-version>
+    <pax-tiny-bundle-version>1.3.2</pax-tiny-bundle-version>
+    <pax-logging-version>1.8.6</pax-logging-version>
+    <pdfbox-version>1.8.13</pdfbox-version>
+    <pgjdbc-ng-driver-version>0.7.1</pgjdbc-ng-driver-version>
+    <powermock-version>1.6.6</powermock-version>
+    <protobuf-version>3.3.0</protobuf-version>
+    <protobuf-guava-version>20.0</protobuf-guava-version>
+    <protobuf-maven-plugin-version>0.5.0</protobuf-maven-plugin-version>
+    <pubnub-version>4.6.5</pubnub-version>
+    <qpid-bundle-version>0.28_1</qpid-bundle-version>
+    <qpid-proton-j-version>0.16.0</qpid-proton-j-version>
+    <qpid-proton-j-bundle-version>0.14.0</qpid-proton-j-bundle-version>
+    <qpid-jms-client-version>0.11.1</qpid-jms-client-version>
+    <quartz-bundle-version>1.8.6_1</quartz-bundle-version>
+    <quartz-version>1.8.6</quartz-version>
+    <quartz-version-range>[1.8,2)</quartz-version-range>
+    <quartz2-version>2.3.0</quartz2-version>
+    <quickfixj-version>1.6.3</quickfixj-version>
+    <rabbitmq-amqp-client-version>4.2.0</rabbitmq-amqp-client-version>
+    <reactive-streams-version>1.0.0</reactive-streams-version>
+    <reactor-version>3.0.7.RELEASE</reactor-version>
+    <reflections-bundle-version>0.9.10_3</reflections-bundle-version>
+    <regexp-bundle-version>1.4_1</regexp-bundle-version>
+    <rest-assured-version>3.0.3</rest-assured-version>
+    <restlet-version>2.3.6</restlet-version>
+    <restlet-jackson-version>2.4.4</restlet-jackson-version>
+    <restlet-woodstox-version>4.3.0</restlet-woodstox-version>
+    <restlet-yaml-version>1.13</restlet-yaml-version>
+    <restlet-gson-version>2.4</restlet-gson-version>
+    <restlet-joda-time-version>2.3</restlet-joda-time-version>
+    <rhino-bundle-version>1.7.7.1_1</rhino-bundle-version>
+    <rhino-version>1.7.7.1</rhino-version>
+    <rhino-js-version>1.7R2</rhino-js-version>
+    <ribbon-version>2.2.2</ribbon-version>
+    <roaster-version>2.20.1.Final</roaster-version>
+    <rome-bundle-version>1.0_3</rome-bundle-version>
+    <rome-version>1.0</rome-version>
+    <rxjava-version>1.3.1</rxjava-version>
+    <rxjava2-version>2.1.3</rxjava2-version>
+    <saaj-impl-version>1.3.2_2</saaj-impl-version>
+    <saxon-bundle-version>9.7.0-18_1</saxon-bundle-version>
+    <saxon-version>9.7.0-18</saxon-version>
+    <scala-version>2.11.7</scala-version>
+    <scala-maven-plugin-version>3.2.2</scala-maven-plugin-version>
+    <scalatest-version>2.2.5</scalatest-version>
+    <scalaxml-version>1.0.6</scalaxml-version>
+    <scribe-version>1.3.7</scribe-version>
+    <scribe-bundle-version>1.3.7_1</scribe-bundle-version>
+    <scriptengines-version>1.1.1</scriptengines-version>
+    <serp-bundle-version>1.14.1_1</serp-bundle-version>
+    <servicemix-specs-version>2.9.0</servicemix-specs-version>
+    <servlet-api-3.0-version>1.0</servlet-api-3.0-version>
+    <servlet-version-range>[3,4)</servlet-version-range>
+    <shiro-version>1.3.2</shiro-version>
+    <shrinkwrap-descriptors-version>2.0.0-alpha-10</shrinkwrap-descriptors-version>
+    <shrinkwrap-resolver-version>2.2.4</shrinkwrap-resolver-version>
+    <shrinkwrap-version>1.2.3</shrinkwrap-version>
+    <sip-api-version>1.1</sip-api-version>
+    <slf4j-api-version>1.7.22</slf4j-api-version>
+    <slf4j-version>1.7.22</slf4j-version>
+    <smack-version>4.2.1</smack-version>
+    <snakeyaml-version>1.18</snakeyaml-version>
+    <snappy-version>1.1.2.6</snappy-version>
+    <snmp4j-version>2.3.4_1</snmp4j-version>
+    <solr-bundle-version>5.5.2_1</solr-bundle-version>
+    <!-- solr version aligned with lucene -->
+    <solr-version>5.5.2</solr-version>
+    <solr-version-range>[5,6)</solr-version-range>
+    <spark-version>1.6.1</spark-version>
+    <spark-rest-version>2.6.0</spark-rest-version>
+    <spark-rest-bundle-version>2.6.0_1</spark-rest-bundle-version>
+    <splunk-version>1.6.3.0_1</splunk-version>
+    <spring-batch-version>3.0.8.RELEASE</spring-batch-version>
+    <spring-batch-bundle-version>3.0.8.RELEASE_1</spring-batch-bundle-version>
+    <spring-boot-version>1.5.6.RELEASE</spring-boot-version>
+    <spring-boot1-version>1.5.6.RELEASE</spring-boot1-version>
+    <spring-boot2-version>2.0.0.M3</spring-boot2-version>
+    <!-- use same version of spring-cloud 1.2.x -->
+    <spring-cloud-commons-version>1.2.3.RELEASE</spring-cloud-commons-version>
+    <spring-cloud-netflix-version>1.3.4.RELEASE</spring-cloud-netflix-version>
+    <spring-castor-bundle-version>1.2.0</spring-castor-bundle-version>
+    <spring-data-commons-version>1.13.6.RELEASE</spring-data-commons-version>
+    <spring-data-keyvalue-version>1.2.6.RELEASE</spring-data-keyvalue-version>
+    <spring-data-redis-version>1.8.6.RELEASE</spring-data-redis-version>
+    <spring-integration-version>4.3.11.RELEASE</spring-integration-version>
+    <spring-javaconfig-version>1.0.0-20090215</spring-javaconfig-version>
+    <spring-ldap-version>2.3.1.RELEASE</spring-ldap-version>
+    <spring-ldap-bundle-version>2.3.1.RELEASE_1</spring-ldap-bundle-version>
+    <!-- spring 1.1.0 is not OSGi bundle any more -->
+    <spring-retry-version>1.0.3.RELEASE</spring-retry-version>
+    <spring-all-version-range>[3.2,5)</spring-all-version-range>
+    <!-- karaf 3.x/4.x supports spring 4.1 onwards -->
+    <spring-version-range>[4.1,5)</spring-version-range>
+    <!-- and special for only spring 4.0.x -->
+    <spring40-version-range>[4.0,4.1)</spring40-version-range>
+    <!-- and for spring 4.2.x onwards-->
+    <spring42-version-range>[4.2,5)</spring42-version-range>
+    <spring-version>${spring4-version}</spring-version>
+    <spring40-version>4.0.9.RELEASE</spring40-version>
+    <spring41-version>4.1.9.RELEASE</spring41-version>
+    <spring42-version>4.2.9.RELEASE</spring42-version>
+    <spring43-version>4.3.10.RELEASE</spring43-version>
+    <spring4-version>4.3.10.RELEASE</spring4-version>
+    <spring5-version>5.0.0.RC3</spring5-version>
+    <spring-osgi-version>1.2.1</spring-osgi-version>
+    <spring-security-version>4.2.3.RELEASE</spring-security-version>
+    <spring-security-bundle-version>4.2.3.RELEASE_1</spring-security-bundle-version>
+    <spring-ws-bundle-version>2.3.0.RELEASE_1</spring-ws-bundle-version>
+    <spring-ws-version>2.3.0.RELEASE</spring-ws-version>
+    <spymemcached-bundle-version>2.5_2</spymemcached-bundle-version> <!-- FIXME cmueller: not in sync! -->
+    <spymemcached-version>2.12.0</spymemcached-version>
+    <squareup-okhttp-version>2.7.5</squareup-okhttp-version>
+    <squareup-okhttp3-version>3.8.1</squareup-okhttp3-version>
+    <squareup-okhttp-bundle-version>2.7.5_1</squareup-okhttp-bundle-version>
+    <squareup-okio-version>1.13.0</squareup-okio-version>
+    <squareup-okio-bundle-version>1.13.0_1</squareup-okio-bundle-version>
+    <squareup-retrofit-bundle-version>1.9.0_1</squareup-retrofit-bundle-version>
+    <squareup-retrofit2-bundle-version>2.3.0_1</squareup-retrofit2-bundle-version>
+    <sshd-version>1.6.0</sshd-version>
+    <stompjms-version>1.19</stompjms-version>
+    <swagger-scala-version>1.3.12</swagger-scala-version>
+    <swagger-scala-guava-version>15.0</swagger-scala-guava-version>
+    <swagger-scala-bundle-version>1.3.12_2</swagger-scala-bundle-version>
+    <swagger-java-version>1.5.16</swagger-java-version>
+    <swagger-java-parser-version>1.0.30</swagger-java-parser-version>
+    <swagger-java-guava-version>20.0</swagger-java-guava-version>
+    <swagger-ui-version>2.2.10</swagger-ui-version>
+    <stax-api-version>1.0.1</stax-api-version>
+    <stax2-api-bundle-version>3.1.4</stax2-api-bundle-version>
+    <stringtemplate-bundle-version>4.0.8_1</stringtemplate-bundle-version>
+    <stringtemplate-version>4.0.8</stringtemplate-version>
+    <tagsoup-bundle-version>1.2.1_1</tagsoup-bundle-version>
+    <tagsoup-version>1.2.1</tagsoup-version>
+    <testng-version>6.8.21</testng-version>
+    <tinybundles-version>2.1.1</tinybundles-version>
+    <tika-version>1.16</tika-version>
+    <twilio-version>7.9.1</twilio-version>
+    <twitter4j-bundle-version>4.0.6_1</twitter4j-bundle-version>
+    <twitter4j-version>4.0.6</twitter4j-version>
+    <undertow-version>1.4.18.Final</undertow-version>
+    <univocity-parsers-version>2.3.1</univocity-parsers-version>
+    <unix-socket-factory-version>2015-01-27T15-02-14</unix-socket-factory-version>
+    <unix-socket-factory-bundle-version>1.0.0</unix-socket-factory-bundle-version>
+    <urlrewritefilter-version>4.0.4</urlrewritefilter-version>
+    <urlrewritefilter-bundle-version>4.0.4_1</urlrewritefilter-bundle-version>
+    <validation-api-version>1.1.0.Final</validation-api-version>
+    <velocity-bundle-version>1.7_6</velocity-bundle-version>
+    <velocity-tools-version>2.0</velocity-tools-version>
+    <velocity-version>1.7</velocity-version>
+    <vertx-version>3.4.2</vertx-version>
+    <vysper-version>0.7</vysper-version>
+    <weld1-version>1.1.28.Final</weld1-version>
+    <weld2-version>2.4.4.Final</weld2-version>
+    <weld3-version>3.0.1.Final</weld3-version>
+    <werken-xpath-bundle-version>0.9.4_5</werken-xpath-bundle-version>
+    <wiremock-version>2.7.1</wiremock-version>
+    <woodstox-version>4.4.1</woodstox-version>
+    <ws-commons-util-bundle-version>1.0.2_2</ws-commons-util-bundle-version>
+    <wsdl4j-bundle-version>1.6.3_1</wsdl4j-bundle-version>
+    <wsdl4j-version>1.6.3</wsdl4j-version>
+    <xalan-bundle-version>2.7.2_3</xalan-bundle-version>
+    <xalan-version>2.7.2</xalan-version>
+    <xbean-spring-version>4.5</xbean-spring-version>
+    <!-- xbean-asm4-bundle is used by openjpa -->
+    <xbean-asm4-bundle-version>3.14</xbean-asm4-bundle-version>
+    <xerces-bundle-version>2.11.0_1</xerces-bundle-version>
+    <xerces-version>2.11.0</xerces-version>
+    <!-- needed to manage the xml-apis version in camel-xmljson -->
+    <xml-apis-version>1.4.01</xml-apis-version>
+    <xml-apis-ext-version>1.3.04</xml-apis-ext-version>
+    <xml-resolver-version>1.2</xml-resolver-version>
+    <xmlbeans-bundle-version>2.6.0_2</xmlbeans-bundle-version>
+    <xmlbeans-maven-plugin-version>2.3.3</xmlbeans-maven-plugin-version>
+    <xmlbeans-version>2.6.0</xmlbeans-version>
+    <xmlgraphics-commons-bundle-version>2.1_1</xmlgraphics-commons-bundle-version>
+    <xmlgraphics-batik-version>1.9.1</xmlgraphics-batik-version>
+    <xmlresolver-bundle-version>1.2_5</xmlresolver-bundle-version>
+    <xmlrpc-version>3.1.3</xmlrpc-version>
+    <xmlrpc-client-bundle-version>3.1.3_1</xmlrpc-client-bundle-version>
+    <xmlsec-version>2.0.9</xmlsec-version>
+    <xmlunit-version>2.3.0</xmlunit-version>
+    <xpp3-bundle-version>1.1.4c_7</xpp3-bundle-version>
+    <xpp3-version>1.1.4c</xpp3-version>
+    <xsdlib-version>2013.2</xsdlib-version>
+    <xstream-bundle-version>1.4.10_1</xstream-bundle-version>
+    <xstream-version>1.4.10</xstream-version>
+    <xom-version>1.2.5</xom-version>
+    <yammer-metrics-version>2.2.0</yammer-metrics-version>
+    <zendesk-client-version>0.5.4</zendesk-client-version>
+    <zipkin-libthrift-version>0.9.3</zipkin-libthrift-version>
+    <zipkin-reporter-version>1.0.1</zipkin-reporter-version>
+    <zipkin-version>1.29.1</zipkin-version>
+    <zjsonpatch-version>0.3.0</zjsonpatch-version>
+    <zookeeper-version>3.4.10</zookeeper-version>
+    <zookeeper-guava-version>16.0</zookeeper-guava-version>
+    <zxing-version>3.3.0</zxing-version>
+    <zxing-bundle-version>3.3.0_1</zxing-bundle-version>
+
   </properties>
 
   <mailingLists>
@@ -759,5 +1470,84 @@
       </build>
     </profile>
 
+    <profile>
+      <id>nochecks</id>
+      <activation>
+        <activeByDefault>true</activeByDefault>
+      </activation>
+    </profile>
+
+    <profile>
+      <id>fastinstall</id>
+      <activation>
+        <property>
+          <name>fastinstall</name>
+        </property>
+      </activation>
+      <properties>
+        <maven.test.skip.exec>true</maven.test.skip.exec>
+        <assembly.skipAssembly>true</assembly.skipAssembly>
+        <noassembly>true</noassembly>
+      </properties>
+    </profile>
+
+    <profile>
+      <id>sourcecheck</id>
+      <build>
+        <plugins>
+          <plugin>
+            <groupId>org.apache.maven.plugins</groupId>
+            <artifactId>maven-checkstyle-plugin</artifactId>
+          </plugin>
+        </plugins>
+      </build>
+    </profile>
+
+    <profile>
+      <id>dependencycheck</id>
+      <build>
+        <plugins>
+          <plugin>
+            <groupId>org.owasp</groupId>
+            <artifactId>dependency-check-maven</artifactId>
+          </plugin>
+        </plugins>
+      </build>
+    </profile>
+
+    <!-- spring-boot2 experiment -->
+    <profile>
+      <id>spring-boot2</id>
+      <properties>
+        <!-- spring-boot -->
+        <spring-boot-version>${spring-boot2-version}</spring-boot-version>
+        <spring-version>${spring5-version}</spring-version>
+        <jackson2-version>2.9.1</jackson2-version>
+        <!-- spring-cloud -->
+        <spring-cloud-commons-version>2.0.0.M2</spring-cloud-commons-version>
+        <spring-cloud-netflix-version>2.0.0.M2</spring-cloud-netflix-version>
+      </properties>
+      <repositories>
+        <repository>
+          <id>spring-milestones</id>
+          <name>Spring Milestones</name>
+          <url>https://repo.spring.io/libs-milestone</url>
+          <snapshots>
+            <enabled>false</enabled>
+          </snapshots>
+        </repository>
+      </repositories>
+      <pluginRepositories>
+        <pluginRepository>
+          <id>spring-milestones</id>
+          <name>Spring Milestones</name>
+          <url>https://repo.spring.io/libs-milestone</url>
+          <snapshots>
+            <enabled>false</enabled>
+          </snapshots>
+        </pluginRepository>
+      </pluginRepositories>
+    </profile>
+
   </profiles>
 </project>

http://git-wip-us.apache.org/repos/asf/camel/blob/45d81300/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/util/JarExporter.java
----------------------------------------------------------------------
diff --git a/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/util/JarExporter.java b/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/util/JarExporter.java
index 84dde29..4449592 100644
--- a/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/util/JarExporter.java
+++ b/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/util/JarExporter.java
@@ -32,7 +32,7 @@ public class JarExporter {
     public void exportJar() throws Exception {
 
         Archive<?> archive = ArquillianPackager.springBootPackage(new ITestConfigBuilder()
-                .module("camel-ahc")
+                .module("camel-sjms2")
                 .build());
 
         new ZipExporterImpl(archive).exportTo(new File("target/export.zip"), true);

Reply | Threaded
Open this post in threaded view
|

[2/3] camel git commit: moving properties to main camel pom and rebuild

nferraro
moving properties to main camel pom and rebuild


Project: http://git-wip-us.apache.org/repos/asf/camel/repo
Commit: http://git-wip-us.apache.org/repos/asf/camel/commit/45d81300
Tree: http://git-wip-us.apache.org/repos/asf/camel/tree/45d81300
Diff: http://git-wip-us.apache.org/repos/asf/camel/diff/45d81300

Branch: refs/heads/boot2
Commit: 45d81300ac0d60b5724cd3a0986b4e4a7ee81000
Parents: e7de255
Author: Nicola Ferraro <[hidden email]>
Authored: Mon Sep 18 16:02:19 2017 +0200
Committer: Nicola Ferraro <[hidden email]>
Committed: Mon Sep 18 16:02:19 2017 +0200

----------------------------------------------------------------------
 parent/pom.xml                                  | 786 ------------------
 .../camel-amqp-starter/pom.xml                  |   8 +
 .../camel-bam-starter/pom.xml                   |   8 +
 .../camel-cxf-starter/pom.xml                   |   8 +
 .../camel-cxf-transport-starter/pom.xml         |   8 +
 .../camel-drill-starter/pom.xml                 |   8 +
 .../camel-elsql-starter/pom.xml                 |   8 +
 .../camel-jms-starter/pom.xml                   |   8 +
 .../camel-jpa-starter/pom.xml                   |   8 +
 .../camel-spring-batch-starter/pom.xml          |   8 +
 .../camel-spring-boot2-starter/pom.xml          |   5 +
 .../camel-spring-cloud-starter/pom.xml          |   8 +
 .../camel-spring-integration-starter/pom.xml    |   8 +
 .../camel-spring-javaconfig-starter/pom.xml     |   8 +
 .../camel-spring-redis-starter/pom.xml          |   8 +
 .../camel-spring-starter/pom.xml                |   8 +
 .../camel-sql-starter/pom.xml                   |   8 +
 platforms/spring-boot/pom.xml                   |  78 +-
 pom.xml                                         | 790 +++++++++++++++++++
 .../itest/springboot/util/JarExporter.java      |   2 +-
 20 files changed, 993 insertions(+), 788 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/camel/blob/45d81300/parent/pom.xml
----------------------------------------------------------------------
diff --git a/parent/pom.xml b/parent/pom.xml
index 69c42d6..3242bd2 100644
--- a/parent/pom.xml
+++ b/parent/pom.xml
@@ -37,715 +37,6 @@
     <cxf.codegen.jvmArgs/>
     <camel.surefire.fork.vmargs/>
     <cxf.xjc.jvmArgs/>
-    <!-- dependency versions -->
-    <abdera-version>1.1.3</abdera-version>
-    <!-- Note that activemq dependency is only used for testing! -->
-    <activemq-version>5.15.0</activemq-version>
-    <activemq-artemis-version>2.2.0</activemq-artemis-version>
-    <aether-version>1.0.2.v20150114</aether-version>
-    <ahc-version>2.0.35</ahc-version>
-    <ant-bundle-version>1.7.0_6</ant-bundle-version>
-    <antlr-bundle-version>3.5.2_1</antlr-bundle-version>
-    <antlr-runtime-bundle-version>3.5.2_1</antlr-runtime-bundle-version>
-    <aopalliance-bundle-version>1.0_6</aopalliance-bundle-version>
-    <apacheds-version>2.0.0-M24</apacheds-version>
-    <apache-drill-version>1.11.0</apache-drill-version>
-    <apache-gora-version>0.7</apache-gora-version>
-    <apache-mime4j-version>0.7.2</apache-mime4j-version>
-    <aries-blueprint-api-version>1.0.1</aries-blueprint-api-version>
-    <aries-blueprint-cm-version>1.0.6</aries-blueprint-cm-version>
-    <aries-blueprint-core-version>1.4.4</aries-blueprint-core-version>
-    <aries-blueprint-proxy-version>1.0.1</aries-blueprint-proxy-version>
-    <aries-blueprint-proxy-impl-version>1.0.4</aries-blueprint-proxy-impl-version>
-    <aries-spifly-version>1.0.8</aries-spifly-version>
-    <aries-util-version>1.1.3</aries-util-version>
-    <arquillian-container-se-managed-version>1.0.0.Final</arquillian-container-se-managed-version>
-    <arquillian-version>1.1.13.Final</arquillian-version>
-    <arquillian-weld-embedded-version>2.0.0.Beta4</arquillian-weld-embedded-version>
-    <asciidoctorj-version>1.5.6</asciidoctorj-version>
-    <asm-version>5.0.4</asm-version>
-    <aspectj-version>1.8.10</aspectj-version>
-    <assertj-version>3.8.0</assertj-version>
-    <asterisk-java-version>1.0.0-final</asterisk-java-version>
-    <asterisk-java-bundle-version>1.0.0-final_1</asterisk-java-bundle-version>
-    <atmos-client-version>2.2.2</atmos-client-version>
-    <atmosphere-version>2.4.10</atmosphere-version>
-    <atmosphere-version-range>[2.4,3.0)</atmosphere-version-range>
-    <atomix-version>1.0.8</atomix-version>
-    <atomix-catalyst-version>1.2.1</atomix-catalyst-version>
-    <atomix-copycat-version>1.2.8</atomix-copycat-version>
-    <automaton-bundle-version>1.11-8_1</automaton-bundle-version>
-    <avalon-bundle-version>4.3.1_1</avalon-bundle-version>
-    <avalon-version>4.3.1</avalon-version>
-    <avro-version>1.8.2</avro-version>
-    <avro-bundle-version>1.8.2_1</avro-bundle-version>
-    <avro-ipc-bundle-version>1.8.2_1</avro-ipc-bundle-version>
-    <awaitility-version>3.0.0</awaitility-version>
-    <aws-java-sdk-bundle-version>1.11.186_1</aws-java-sdk-bundle-version>
-    <aws-java-sdk-version>1.11.186</aws-java-sdk-version>
-    <axiom-version>1.2.14</axiom-version>
-    <azure-storage-java-sdk-version>5.5.0</azure-storage-java-sdk-version>
-    <azure-storage-java-sdk-bundle-version>5.5.0_1</azure-storage-java-sdk-bundle-version>
-    <azure-keyvault-core-bundle-version>1.0.0_1</azure-keyvault-core-bundle-version>
-    <backport-util-concurrent-version>3.1</backport-util-concurrent-version>
-    <bcel-bundle-version>5.2_4</bcel-bundle-version>
-    <beanio-version>2.1.0</beanio-version>
-    <beanstalkd-client-version>1.4.6</beanstalkd-client-version>
-    <bndlib-version>2.4.0</bndlib-version>
-    <bsh-version>2.0b6</bsh-version>
-    <boon-version>0.34</boon-version>
-    <bouncycastle-version>1.57</bouncycastle-version>
-    <boxjavalibv2.version>3.2.1</boxjavalibv2.version>
-    <box-java-sdk-version>2.1.1</box-java-sdk-version>
-    <braintree-gateway-version>2.63.0</braintree-gateway-version>
-    <brave-zipkin-version>4.5.2</brave-zipkin-version>
-    <build-helper-maven-plugin-version>1.10</build-helper-maven-plugin-version>
-    <c3p0-version>0.9.5.2</c3p0-version>
-    <c3p0-bundle-version>0.9.5.2_1</c3p0-bundle-version>
-    <caffeine-version>2.5.5</caffeine-version>
-    <californium-version>1.0.6</californium-version>
-    <camel-test-spring-artifactId>camel-test-spring</camel-test-spring-artifactId>
-    <cassandra-driver-version>3.3.0</cassandra-driver-version>
-    <cassandra-metrics-version>3.2.2</cassandra-metrics-version>
-    <cassandra-driver-guava-version>18.0</cassandra-driver-guava-version>
-    <cassandra-version>3.7</cassandra-version>
-    <cassandra-unit-version>3.1.3.2</cassandra-unit-version>
-    <castor-version>1.3.3</castor-version>
-    <castor-bundle-version>1.3.3_1</castor-bundle-version>
-    <cdi-api-1.0-version>1.0-SP4</cdi-api-1.0-version>
-    <cdi-api-1.1-version>1.1</cdi-api-1.1-version>
-    <cdi-api-1.2-version>1.2</cdi-api-1.2-version>
-    <cdi-api-2.0-version>2.0</cdi-api-2.0-version>
-    <jta-api-1.2-version>1.2</jta-api-1.2-version>
-    <cglib-bundle-version>3.2.5_1</cglib-bundle-version>
-    <cglib-version>3.2.5</cglib-version>
-    <chronicle-bytes-version>1.9.7</chronicle-bytes-version>
-    <chronicle-core-version>1.9.9</chronicle-core-version>
-    <chronicle-engine-version>1.13.27</chronicle-engine-version>
-    <chronicle-map-version>2.4.17</chronicle-map-version>
-    <chronicle-network-version>1.9.4</chronicle-network-version>
-    <chronicle-queue-version>4.5.27</chronicle-queue-version>
-    <chronicle-threads-version>1.8.2</chronicle-threads-version>
-    <chronicle-wire-version>1.9.13</chronicle-wire-version>
-    <chunk-templates-version>3.2.4</chunk-templates-version>
-    <chunk-templates-bundle-version>3.2.4_1</chunk-templates-bundle-version>
-    <classmate-version>1.3.3</classmate-version>
-    <cmis-version>0.13.0</cmis-version>
-    <cometd-bayeux-version>6.1.11</cometd-bayeux-version>
-    <cometd-java-client-version>3.1.2</cometd-java-client-version>
-    <cometd-java-server-bundle-version>2.3.1_2</cometd-java-server-bundle-version>
-    <cometd-java-server>3.1.2</cometd-java-server>
-    <commons-beanutils-version>1.9.3</commons-beanutils-version>
-    <commons-beanutils-bundle-version>1.8.3_1</commons-beanutils-bundle-version>
-    <commons-codec-version>1.10</commons-codec-version>
-    <commons-collections-version>3.2.2</commons-collections-version>
-    <commons-compress-version>1.14</commons-compress-version>
-    <commons-configuration-version>1.9</commons-configuration-version>
-    <commons-configuration-bundle-version>1.9_1</commons-configuration-bundle-version>
-    <commons-csv-version>1.4</commons-csv-version>
-    <commons-cli-version>1.3.1</commons-cli-version>
-    <commons-daemon-version>1.0.15</commons-daemon-version>
-    <commons-dbcp-version>1.4</commons-dbcp-version>
-    <commons-dbcp2-version>2.1.1</commons-dbcp2-version>
-    <commons-digester-1x-version>1.8.1</commons-digester-1x-version>
-    <commons-digester-version>2.1</commons-digester-version>
-    <commons-exec-version>1.3</commons-exec-version>
-    <commons-httpclient-bundle-version>3.1_7</commons-httpclient-bundle-version>
-    <commons-io-version>2.4</commons-io-version>
-    <commons-jexl2-version>2.1.1</commons-jexl2-version>
-    <commons-jxpath-version>1.3</commons-jxpath-version>
-    <commons-lang-version>2.6</commons-lang-version>
-    <commons-lang3-version>3.6</commons-lang3-version>
-    <commons-logging-version>1.2</commons-logging-version>
-    <commons-math-version>2.2</commons-math-version>
-    <commons-math3-version>3.6.1</commons-math3-version>
-    <commons-net-version>3.6</commons-net-version>
-    <commons-pool-version>1.6</commons-pool-version>
-    <commons-pool2-version>2.4.2</commons-pool2-version>
-    <commons-text-version>1.1</commons-text-version>
-    <commons-vfs2-version>2.0</commons-vfs2-version>
-    <compress-lzf-version>1.0.4</compress-lzf-version>
-    <consul-client-version>0.16.2</consul-client-version>
-    <consul-client-bundle-version>0.16.2_1</consul-client-bundle-version>
-    <cobertura-maven-plugin-version>2.7</cobertura-maven-plugin-version>
-    <couchbase-client-version>1.4.13</couchbase-client-version>
-    <couchbase-client-bundle-version>1.4.13_1</couchbase-client-bundle-version>
-    <curator-version>2.12.0</curator-version>
-    <cxf-version>3.1.12</cxf-version>
-    <cxf-version-range>[3.0,4.0)</cxf-version-range>
-    <cxf-xjc-plugin-version>3.0.5</cxf-xjc-plugin-version>
-    <cxf-xjc-utils-version>3.0.5</cxf-xjc-utils-version>
-    <deltaspike-version>1.8.0</deltaspike-version>
-    <depends-maven-plugin-version>1.3.1</depends-maven-plugin-version>
-    <derby-version>10.11.1.1</derby-version>
-    <digitalocean-api-client-version>2.12</digitalocean-api-client-version>
-    <digitalocean-api-client-bundle-version>2.12_1</digitalocean-api-client-bundle-version>
-    <disruptor-version>3.3.6</disruptor-version>
-    <dnsjava-version>2.1.8</dnsjava-version>
-    <dnsjava-bundle-version>2.1.8_1</dnsjava-bundle-version>
-    <docker-java-version>3.0.13</docker-java-version>
-    <docker-java-bundle-version>3.0.13_1</docker-java-bundle-version>
-    <docker-maven-plugin-version>0.22.0</docker-maven-plugin-version>
-    <dom4j-bundle-version>1.6.1_5</dom4j-bundle-version>
-    <dozer-version>6.1.0</dozer-version>
-    <drools-version>6.5.0.Final</drools-version>
-    <dropbox-version>1.8.2</dropbox-version>
-    <easymock-version>3.4</easymock-version>
-    <eclipse-equinox-common-version>3.3.0-v20070426</eclipse-equinox-common-version>
-    <egit-github-core-version>2.1.5</egit-github-core-version>
-    <egit-github-core-bundle-version>2.1.5_1</egit-github-core-bundle-version>
-    <ehcache-version>2.10.1</ehcache-version>
-    <ehcache3-version>3.4.0</ehcache3-version>
-    <ekstazi-maven-plugin-version>4.6.3</ekstazi-maven-plugin-version>
-    <elasticsearch-bundle-version>2.4.4_1</elasticsearch-bundle-version>
-    <elasticsearch-guava-version>18.0</elasticsearch-guava-version>
-    <elasticsearch-version>2.4.4</elasticsearch-version>
-    <elasticsearch5-version>5.5.2</elasticsearch5-version>
-    <elasticsearch5-bundle-version>5.5.2_1</elasticsearch5-bundle-version>
-    <elasticsearch-cluster-runner-version>2.4.0.0</elasticsearch-cluster-runner-version>
-    <elasticsearch5-cluster-runner-version>5.5.2.0</elasticsearch5-cluster-runner-version>
-    <elsql-version>1.2</elsql-version>
-    <el-api-1.0-version>1.0.1</el-api-1.0-version>
-    <!-- embedmongo 1.50.2 do not work -->
-    <embedmongo-version>1.50.1</embedmongo-version>
-    <etcd4j-version>2.13.0</etcd4j-version>
-    <exec-maven-plugin-version>1.6.0</exec-maven-plugin-version>
-    <ezmorph-bundle-version>1.0.6_1</ezmorph-bundle-version>
-    <fabric8-maven-plugin-version>3.5.26</fabric8-maven-plugin-version>
-    <facebook4j-core-version>2.4.10</facebook4j-core-version>
-    <facebook4j-core-bundle-version>2.4.10_1</facebook4j-core-bundle-version>
-    <fastinfoset-version>1.2.13_1</fastinfoset-version>
-    <fastjson-version>1.2.37</fastjson-version>
-    <fastjson-bundle-version>1.2.37_1</fastjson-bundle-version>
-    <felix-configadmin-version>1.8.8</felix-configadmin-version>
-    <felix-connect-version>0.1.0</felix-connect-version>
-    <felix-fileinstall-version>3.5.2</felix-fileinstall-version>
-    <felix-framework-version>3.2.2</felix-framework-version>
-    <felix-scr-annotations-version>1.9.12</felix-scr-annotations-version>
-    <findbugs-maven-plugin-version>2.5.2</findbugs-maven-plugin-version>
-    <flatpack-version>3.4.3</flatpack-version>
-    <flink-version>1.3.2</flink-version>
-    <fop-bundle-version>2.1_1</fop-bundle-version>
-    <fop-version>2.1</fop-version>
-    <ftpserver-version>1.0.6</ftpserver-version>
-    <freemarker-bundle-version>2.3.23_1</freemarker-bundle-version>
-    <freemarker-version>2.3.23</freemarker-version>
-    <generex-bundle-version>1.0.1_2</generex-bundle-version>
-    <gentlyweb-bundle-version>1.5_1</gentlyweb-bundle-version>
-    <geocoder-java-version>0.16</geocoder-java-version>
-    <geronimo-annotation-1.0-spec-version>1.1.1</geronimo-annotation-1.0-spec-version>
-    <geronimo-annotation-1.2-spec-version>1.0</geronimo-annotation-1.2-spec-version>
-    <geronimo-atinject-1.0-spec-version>1.0</geronimo-atinject-1.0-spec-version>
-    <geronimo-ejb_3.1_spec-version>1.0.2</geronimo-ejb_3.1_spec-version>
-    <geronimo-el-spec-version>1.0.1</geronimo-el-spec-version>
-    <geronimo-interceptor-1.1-spec-version>1.0</geronimo-interceptor-1.1-spec-version>
-    <geronimo-interceptor-1.2-spec-version>1.0</geronimo-interceptor-1.2-spec-version>
-    <geronimo-j2ee-connector-spec-version>2.0.0</geronimo-j2ee-connector-spec-version>
-    <geronimo-j2ee-jacc-spec-version>1.1</geronimo-j2ee-jacc-spec-version>
-    <geronimo-j2ee-management-spec-version>1.1</geronimo-j2ee-management-spec-version>
-    <geronimo-jcdi-1.0-spec-version>1.0</geronimo-jcdi-1.0-spec-version>
-    <geronimo-jcdi-1.1-spec-version>1.0</geronimo-jcdi-1.1-spec-version>
-    <geronimo-jms-spec-version>1.1.1</geronimo-jms-spec-version>
-    <geronimo-jms2-spec-version>1.0-alpha-2</geronimo-jms2-spec-version>
-    <geronimo-jpa-spec-version>1.0-alpha-1</geronimo-jpa-spec-version>
-    <geronimo-jsp-spec-version>1.1</geronimo-jsp-spec-version>
-    <geronimo-json-spec-version>1.0</geronimo-json-spec-version>
-    <geronimo-jta-spec-version>1.1.1</geronimo-jta-spec-version>
-    <geronimo-servlet-spec-version>1.0</geronimo-servlet-spec-version>
-    <geronimo-servlet-2.5-spec-version>1.2</geronimo-servlet-2.5-spec-version>
-    <geronimo-ws-metadata-spec-version>1.1.3</geronimo-ws-metadata-spec-version>
-    <gmetric4j-version>1.0.10</gmetric4j-version>
-    <google-guava-version>19.0</google-guava-version>
-    <google-api-client-version>1.22.0</google-api-client-version>
-    <google-api-services-drive-version>v2-rev263-1.22.0</google-api-services-drive-version>
-    <google-api-services-calendar-version>v3-rev243-1.22.0</google-api-services-calendar-version>
-    <google-api-services-mail-version>v1-rev63-1.22.0</google-api-services-mail-version>
-    <google-api-services-bigquery-version>v2-rev352-1.22.0</google-api-services-bigquery-version>
-    <google-api-services-pubsub-version>v1-rev12-1.22.0</google-api-services-pubsub-version>
-    <google-truth-version>0.30</google-truth-version>
-    <grizzly-websockets-version>2.3.25</grizzly-websockets-version>
-    <grpc-version>1.6.1</grpc-version>
-    <grpc-google-auth-library-version>0.7.1</grpc-google-auth-library-version>
-    <grpc-java-jwt-version>3.2.0</grpc-java-jwt-version>
-    <grpc-netty-tcnative-boringssl-static-version>2.0.5.Final</grpc-netty-tcnative-boringssl-static-version>
-    <grpc-bundle-version>1.6.1_1</grpc-bundle-version>
-    <gson-version>2.8.1</gson-version>
-    <guice-version>4.0</guice-version>
-    <guice3-version>3.0</guice3-version>
-    <guice-bundle-version>3.0_1</guice-bundle-version>
-    <hadoop-bundle-version>1.2.1_1</hadoop-bundle-version>
-    <hadoop-version>1.2.1</hadoop-version>
-    <hadoop2-bundle-version>2.7.2_1</hadoop2-bundle-version>
-    <hadoop2-version>2.7.2</hadoop2-version>
-    <hadoop2-protobuf-version>2.5.0</hadoop2-protobuf-version>
-    <hamcrest-version>2.0.0.0</hamcrest-version>
-    <hapi-version>2.2</hapi-version>
-    <hawtbuf-version>1.11</hawtbuf-version>
-    <hawtdb-version>1.6</hawtdb-version>
-    <hawtdispatch-version>1.22</hawtdispatch-version>
-    <hazelcast-version>3.8.5</hazelcast-version>
-    <hbase-version>1.2.6</hbase-version>
-    <hessian-version>4.0.38</hessian-version>
-    <hibernate-validator-version>5.4.1.Final</hibernate-validator-version>
-    <hibernate-version>5.0.12.Final</hibernate-version>
-    <hikaricp-version>2.3.13</hikaricp-version>
-    <hk2-version>2.3.0</hk2-version>
-    <hk2-osgi-resource-version>1.0.1</hk2-osgi-resource-version>
-    <hsqldb-version>2.4.0</hsqldb-version>
-    <htmlunit-version>2.24</htmlunit-version>
-    <htmlunit-bundle-version>2.24_1</htmlunit-bundle-version>
-    <htmlunit-core-js-version>2.23</htmlunit-core-js-version>
-    <htrace-version>3.1.0-incubating</htrace-version>
-    <httpunit-version>1.7</httpunit-version>
-    <httpcore4-version>4.4.6</httpcore4-version>
-    <httpclient4-version>4.5.3</httpclient4-version>
-    <httpasyncclient-version>4.1.3</httpasyncclient-version>
-    <httpclient-version>3.1</httpclient-version>
-    <hystrix-version>1.5.12</hystrix-version>
-    <hystrix-bundle-version>1.5.12_1</hystrix-bundle-version>
-    <ibatis-bundle-version>2.3.4.726_4</ibatis-bundle-version>
-    <ibatis-version>2.3.4.726</ibatis-version>
-    <ical4j-version>1.0.7</ical4j-version>
-    <ignite-version>1.9.0</ignite-version>
-    <infinispan-version>9.1.0.Final</infinispan-version>
-    <infinispan-spring-boot-version>1.0.0.Final</infinispan-spring-boot-version>
-    <influx-java-driver-version>2.7</influx-java-driver-version>
-    <influx-java-driver-bundle-version>2.7_1</influx-java-driver-bundle-version>
-    <influx-guava-version>20.0</influx-guava-version>
-    <irclib-bundle-version>1.10_5</irclib-bundle-version>
-    <irclib-version>1.10</irclib-version>
-    <ironmq-version>3.0.5</ironmq-version>
-    <ironmq-bundle-version>3.0.5_1</ironmq-bundle-version>
-    <isorelax-bundle-version>20050913_4</isorelax-bundle-version>
-    <isorelax-version>20090621</isorelax-version>
-    <isorelax-jaxp-bridge-version>1.1</isorelax-jaxp-bridge-version>
-    <ivy-version>2.4.0</ivy-version>
-    <jackson-version>1.9.12</jackson-version>
-    <jackson-spark-version>2.4.5</jackson-spark-version>
-    <jackson2-scala-version>2.6.1</jackson2-scala-version>
-    <!-- jackson 2.9.x is not yet working with all camel components such as swagger-java -->
-    <jackson2-version>2.8.7</jackson2-version>
-    <jackrabbit-version>2.15.5</jackrabbit-version>
-    <jackrabbit-guava-version>15.0</jackrabbit-guava-version>
-    <jain-sip-ri-bundle-version>1.2.154_2</jain-sip-ri-bundle-version>
-    <jasn1-version>1.8.2</jasn1-version>
-    <jasper-bundle-version>6.0.44_1</jasper-bundle-version>
-    <jasypt-bundle-version>1.9.2_1</jasypt-bundle-version>
-    <jasypt-version>1.9.2</jasypt-version>
-    <java-apns-bundle-version>1.0.0.Beta6_1</java-apns-bundle-version>
-    <java-apns-version>1.0.0.Beta6</java-apns-version>
-    <java-ewah-version>1.1.6</java-ewah-version>
-    <java-util-version>1.26.0</java-util-version>
-    <jna-version>4.2.1</jna-version>
-    <jnats-version>1.0</jnats-version>
-    <javacc-maven-plugin-version>2.6</javacc-maven-plugin-version>
-    <javacrumbs-version>0.22</javacrumbs-version>
-    <javapoet-version>1.8.0</javapoet-version>
-    <javassist-bundle-version>3.12.1.GA_3</javassist-bundle-version>
-    <javassist-version>3.20.0-GA</javassist-version>
-    <javax.el-api-version>2.2.5</javax.el-api-version>
-    <javax.el-version>2.2.5</javax.el-version>
-    <javax-inject-bundle-version>1_2</javax-inject-bundle-version>
-    <javax-mail-version>1.6.0</javax-mail-version>
-    <javax.servlet-api-version>3.1.0</javax.servlet-api-version>
-    <javax.ws.rs-api-version>2.0.1</javax.ws.rs-api-version>
-    <jaxb-bundle-version>2.2.11_1</jaxb-bundle-version>
-    <jaxen-version>1.1.6</jaxen-version>
-    <jbpm-version>6.5.0.Final</jbpm-version>
-    <jboss-javaee-6-version>1.0.0.Final</jboss-javaee-6-version>
-    <jboss-logging-version>3.3.0.Final</jboss-logging-version>
-    <jboss-marshalling-version>1.4.10.Final</jboss-marshalling-version>
-    <jboss-transaction-spi.version>7.5.1.Final</jboss-transaction-spi.version>
-    <jboss-xnio-version>3.3.8.Final</jboss-xnio-version>
-    <jcache-bundle-version>1.0.0_1</jcache-bundle-version>
-    <jclouds-version>2.0.2</jclouds-version>
-    <!-- jclouds must use this guava version -->
-    <jclouds-google-guava-version>16.0.1</jclouds-google-guava-version>
-    <jclouds-google-guava-version-range>[16.0,17.0)</jclouds-google-guava-version-range>
-    <jcommander-version>1.72</jcommander-version>
-    <jcr-version>2.0</jcr-version>
-    <jdom-bundle-version>1.1_4</jdom-bundle-version>
-    <jdom-version>1.1.3</jdom-version>
-    <jedis-client-version>2.9.0</jedis-client-version>
-    <jedis-client-bundle-version>2.9.0_1</jedis-client-bundle-version>
-    <jersey-version>2.11</jersey-version>
-    <jetty6-bundle-version>6.1.26_4</jetty6-bundle-version>
-    <jetty92-version>9.2.21.v20170120</jetty92-version>
-    <!-- Jetty version 9.3.15+ contains binary incopatible API changes that break -->
-    <!-- CXF's websocket support (< 3.1.11) and camel-atmosphere-websocket -->
-    <jetty9-version>9.3.14.v20161028</jetty9-version>
-    <jetty-version>${jetty9-version}</jetty-version>
-    <jetty-plugin-version>${jetty-version}</jetty-plugin-version>
-    <jetty-runner-groupId>org.eclipse.jetty</jetty-runner-groupId>
-    <jettison-version>1.3.8</jettison-version>
-    <jgit-version>4.8.0.201706111038-r</jgit-version>
-    <jgroups-version>4.0.6.Final</jgroups-version>
-    <libthrift-version>0.10.0</libthrift-version>
-    <jibx-version>1.2.6</jibx-version>
-    <jing-bundle-version>20030619_5</jing-bundle-version>
-    <jing-version>20030619</jing-version>
-    <jini-version>2.1</jini-version>
-    <jira-rest-client-version>1.2-m01</jira-rest-client-version>
-    <jira-rest-client-api-version>2.0.0-m30</jira-rest-client-api-version>
-    <jmh-version>1.19</jmh-version>
-    <jmockit-version>1.5</jmockit-version>
-    <jodatime-bundle-version>1.6.2</jodatime-bundle-version>
-    <jodatime2-bundle-version>2.9.9</jodatime2-bundle-version>
-    <jolokia-version>1.3.7</jolokia-version>
-    <jolt-version>0.1.0</jolt-version>
-    <jolt-bundle-version>0.1.0_1</jolt-bundle-version>
-    <johnzon-version>1.1.0</johnzon-version>
-    <jose4j-version>0.4.4</jose4j-version>
-    <josql-bundle-version>1.5_5</josql-bundle-version>
-    <josql-version>1.5</josql-version>
-    <!-- Upgrade to 1.7.26 causes stability issues. See CAMEL-10477 -->
-    <jruby-version>1.7.18</jruby-version>
-    <jsendnsca-version>2.1.1</jsendnsca-version>
-    <jsmpp-version>2.3.4</jsmpp-version>
-    <jsch-version>0.1.54</jsch-version>
-    <jsch-bundle-version>0.1.54_1</jsch-bundle-version>
-    <jsonlib-bundle-version>2.4_1</jsonlib-bundle-version>
-    <jsonlib-version>2.4</jsonlib-version>
-    <json4s-bundle-version>3.2.8_1</json4s-bundle-version>
-    <json-asm-version>1.0.2</json-asm-version>
-    <json-accessors-smart-version>1.2</json-accessors-smart-version>
-    <json-path-version>2.4.0</json-path-version>
-    <json-simple-version>1.1.1</json-simple-version>
-    <!-- spring-boot uses json-smart 2.2.x -->
-    <json-smart-version>2.2.1</json-smart-version>
-    <json-smart-karaf-version>2.3</json-smart-karaf-version>
-    <jsoup-version>1.9.2</jsoup-version>
-    <jsp-api-2.1-version>1.0.1</jsp-api-2.1-version>
-    <jsr311-api-version>1.1.1</jsr311-api-version>
-    <jt400-version>9.3</jt400-version>
-    <jt400-bundle-version>9.3_1</jt400-bundle-version>
-    <juel-bundle-version>2.1.3_1</juel-bundle-version>
-    <juel-version>2.1.3</juel-version>
-    <!-- camel-itest-karaf doesn't work with JUnit 4.12 at present -->
-    <junit-bundle-version>4.11_1</junit-bundle-version>
-    <junit-toolbox-version>2.3</junit-toolbox-version>
-    <junit-version>4.12</junit-version>
-    <jxmpp-version>0.5.0</jxmpp-version>
-    <jython-version>2.5.3</jython-version>
-    <jzlib-version>1.1.3</jzlib-version>
-    <jzlib-bundle-version>1.1.3_2</jzlib-bundle-version>
-    <kafka-version>0.11.0.0</kafka-version>
-    <kafka-bundle-version>0.11.0.0_1</kafka-bundle-version>
-    <karaf2-version>2.4.4</karaf2-version>
-    <karaf4-version>4.1.2</karaf4-version>
-    <kie-version>6.5.0.Final</kie-version>
-    <krati-version>0.4.9</krati-version>
-    <kubernetes-client-version>2.6.3</kubernetes-client-version>
-    <kubernetes-model-version>1.1.4</kubernetes-model-version>
-    <kxml2-bundle-version>2.3.0_3</kxml2-bundle-version>
-    <leveldbjni-version>1.8</leveldbjni-version>
-    <leveldb-api-version>0.9</leveldb-api-version>
-    <leveldb-version>0.9</leveldb-version>
-    <libphonenumber-version>8.8.0</libphonenumber-version>
-    <libphonenumber-bundle-version>8.8.0_1</libphonenumber-bundle-version>
-    <!-- virtual dependency only used by Eclipse m2e -->
-    <lifecycle-mapping-version>1.0.0</lifecycle-mapping-version>
-    <log4j-version>1.2.17</log4j-version>
-    <log4j2-version>2.8.2</log4j2-version>
-    <log4j2-25-version>2.5</log4j2-25-version>
-    <logback-version>1.2.0</logback-version>
-    <lucene3-bundle-version>3.6.0_1</lucene3-bundle-version>
-    <lucene3-version>3.6.0</lucene3-version>
-    <lucene-bundle-version>5.5.2_1</lucene-bundle-version>
-    <!-- lucene aligned with elasticsearch version of lucene in use -->
-    <lucene-version>5.5.2</lucene-version>
-    <lucene-version-range>[5,6)</lucene-version-range>
-    <lightcouch-version>0.1.8</lightcouch-version>
-    <lightcouch-gson-version>2.4</lightcouch-gson-version>
-    <lightcouch-bundle-version>0.1.8_2</lightcouch-bundle-version>
-    <!-- needed from tooling/archetypes -->
-    <!-- use antrun 1.6 as 1.7 fails with finding tools.jar on java on some platforms -->
-    <maven-antrun-plugin-version>1.6</maven-antrun-plugin-version>
-    <maven-archetype-plugin-version>2.0</maven-archetype-plugin-version>
-    <maven-archetype-packaging-version>2.0</maven-archetype-packaging-version>
-    <maven-assembly-plugin-version>3.0.0</maven-assembly-plugin-version>
-    <maven-bundle-version>${maven-bundle-plugin-version}</maven-bundle-version>
-    <maven-bundle-plugin-version>3.3.0</maven-bundle-plugin-version>
-    <maven-checkstyle-plugin-version>2.17</maven-checkstyle-plugin-version>
-    <maven-checkstyle-version>7.6.1</maven-checkstyle-version>
-    <maven-owasp-plugin-version>2.1.1</maven-owasp-plugin-version>
-    <maven-eclipse-plugin-version>2.10</maven-eclipse-plugin-version>
-    <maven-jar-plugin-version>3.0.2</maven-jar-plugin-version>
-    <maven-javadoc-plugin-version>2.10.4</maven-javadoc-plugin-version>
-    <maven-jboss-as-maven-plugin-version>7.7.Final</maven-jboss-as-maven-plugin-version>
-    <!-- plugin-plugin 3.5 does not work -->
-    <maven-plugin-plugin-version>3.4</maven-plugin-plugin-version>
-    <maven-plugin-annotations-version>3.5</maven-plugin-annotations-version>
-    <maven-plugin-testing-harness-version>3.3.0</maven-plugin-testing-harness-version>
-    <maven-remote-resources-plugin-version>1.5</maven-remote-resources-plugin-version>
-    <!-- resources plugin needed by Camel maven archetypes -->
-    <maven-resources-plugin-version>3.0.2</maven-resources-plugin-version>
-    <maven-reporting-api-version>2.2.1</maven-reporting-api-version>
-    <maven-reporting-impl-version>2.0.5</maven-reporting-impl-version>
-    <maven-scr-plugin-version>1.22.0</maven-scr-plugin-version>
-    <maven-shade-plugin-version>3.0.0</maven-shade-plugin-version>
-    <maven-surefire-report-plugin-version>2.13</maven-surefire-report-plugin-version>
-    <maven-war-plugin-version>3.0.0</maven-war-plugin-version>
-    <mchange-commons-java-version>0.2.11</mchange-commons-java-version>
-    <!-- TODO: spring-boot uses metrics 3.1.x -->
-    <metrics-version>3.1.5</metrics-version>
-    <milo-version>0.1.3</milo-version>
-    <mina-bundle-version>1.1.7_6</mina-bundle-version>
-    <mina-version>1.1.7</mina-version>
-    <mina2-version>2.0.16</mina2-version>
-    <minimal-json-version>0.9.4</minimal-json-version>
-    <mock-javamail-version>1.9</mock-javamail-version>
-    <mockwebserver-version>0.0.15</mockwebserver-version>
-    <mockito-version>1.10.19</mockito-version>
-    <mongo-java-driver-version>3.5.0</mongo-java-driver-version>
-    <mongo-java-driver32-version>3.2.2</mongo-java-driver32-version>
-    <mongo-hadoop-version>1.5.0</mongo-hadoop-version>
-    <mqtt-client-version>1.14</mqtt-client-version>
-    <msv-version>2013.6.1</msv-version>
-    <mustache-java-version>0.9.5</mustache-java-version>
-    <mustache-guava-version>16.0</mustache-guava-version>
-    <mustache-bundle-version>0.9.5_1</mustache-bundle-version>
-    <mvel-version>2.3.1.Final</mvel-version>
-    <mybatis-version>3.4.5</mybatis-version>
-    <narayana-version>5.6.4.Final</narayana-version>
-    <neethi-bundle-version>3.0.1</neethi-bundle-version>
-    <nekohtml-version>1.9.22</nekohtml-version>
-    <neoscada-version>0.4.0</neoscada-version>
-    <netty3-version>3.10.6.Final</netty3-version>
-    <netty-version>4.1.15.Final</netty-version>
-    <netty40-version>4.0.51.Final</netty40-version>
-    <noggit-bundle-version>0.5_1</noggit-bundle-version>
-    <!-- should be in-sync with deltaspike -->
-    <openwebbeans1-version>1.2.7</openwebbeans1-version>
-    <openwebbeans-version>1.7.3</openwebbeans-version>
-    <oauth-provider-bundle-version>20100527_1</oauth-provider-bundle-version>
-    <okclient-version>3.8.1</okclient-version>
-    <okclient-bundle-version>3.8.1_1</okclient-bundle-version>
-    <olingo2-version>2.0.9</olingo2-version>
-    <olingo-odata2-core-bundle-version>2.0.9_1</olingo-odata2-core-bundle-version>
-    <olingo2-gson-version>2.4</olingo2-gson-version>
-    <olingo4-version>4.3.0</olingo4-version>
-    <ognl-version>3.1.12</ognl-version>
-    <ognl-bundle-version>3.1.12_1</ognl-bundle-version>
-    <oncrpc-version>1.1.3</oncrpc-version>
-    <openejb-version>4.7.4</openejb-version>
-    <openhft-affinity-version>3.0.6</openhft-affinity-version>
-    <openhft-compiler-version>2.3.0</openhft-compiler-version>
-    <openhft-lang-version>6.8.2</openhft-lang-version>
-    <openjpa-version>2.4.2</openjpa-version>
-    <openshift-java-client-version>2.7.0.Final</openshift-java-client-version>
-    <openstack4j-version>3.0.2</openstack4j-version>
-    <openstack4j-guava-version>17.0</openstack4j-guava-version>
-    <opentracing-java-agent-version>0.1.0</opentracing-java-agent-version>
-    <opentracing-version>0.30.0</opentracing-version>
-    <opentracing-tracerresolver-version>0.1.0</opentracing-tracerresolver-version>
-    <ops4j-base-version>1.5.0</ops4j-base-version>
-    <optaplanner-version>6.5.0.Final</optaplanner-version>
-    <oro-bundle-version>2.0.8_6</oro-bundle-version>
-    <os-maven-plugin-version>1.4.1.Final</os-maven-plugin-version>
-    <oscache-bundle-version>2.4_5</oscache-bundle-version>
-    <osgi-version>4.3.1</osgi-version>
-    <paho-version>1.2.0</paho-version>
-    <paranamer-bundle-version>2.8_1</paranamer-bundle-version>
-    <pax-cdi-version>1.0.0.RC1</pax-cdi-version>
-    <pax-exam-version>4.9.2</pax-exam-version>
-    <pax-tiny-bundle-version>1.3.2</pax-tiny-bundle-version>
-    <pax-logging-version>1.8.6</pax-logging-version>
-    <pdfbox-version>1.8.13</pdfbox-version>
-    <pgjdbc-ng-driver-version>0.7.1</pgjdbc-ng-driver-version>
-    <powermock-version>1.6.6</powermock-version>
-    <protobuf-version>3.3.0</protobuf-version>
-    <protobuf-guava-version>20.0</protobuf-guava-version>
-    <protobuf-maven-plugin-version>0.5.0</protobuf-maven-plugin-version>
-    <pubnub-version>4.6.5</pubnub-version>
-    <qpid-bundle-version>0.28_1</qpid-bundle-version>
-    <qpid-proton-j-version>0.16.0</qpid-proton-j-version>
-    <qpid-proton-j-bundle-version>0.14.0</qpid-proton-j-bundle-version>
-    <qpid-jms-client-version>0.11.1</qpid-jms-client-version>
-    <quartz-bundle-version>1.8.6_1</quartz-bundle-version>
-    <quartz-version>1.8.6</quartz-version>
-    <quartz-version-range>[1.8,2)</quartz-version-range>
-    <quartz2-version>2.3.0</quartz2-version>
-    <quickfixj-version>1.6.3</quickfixj-version>
-    <rabbitmq-amqp-client-version>4.2.0</rabbitmq-amqp-client-version>
-    <reactive-streams-version>1.0.0</reactive-streams-version>
-    <reactor-version>3.0.7.RELEASE</reactor-version>
-    <reflections-bundle-version>0.9.10_3</reflections-bundle-version>
-    <regexp-bundle-version>1.4_1</regexp-bundle-version>
-    <rest-assured-version>3.0.3</rest-assured-version>
-    <restlet-version>2.3.6</restlet-version>
-    <restlet-jackson-version>2.4.4</restlet-jackson-version>
-    <restlet-woodstox-version>4.3.0</restlet-woodstox-version>
-    <restlet-yaml-version>1.13</restlet-yaml-version>
-    <restlet-gson-version>2.4</restlet-gson-version>
-    <restlet-joda-time-version>2.3</restlet-joda-time-version>
-    <rhino-bundle-version>1.7.7.1_1</rhino-bundle-version>
-    <rhino-version>1.7.7.1</rhino-version>
-    <rhino-js-version>1.7R2</rhino-js-version>
-    <ribbon-version>2.2.2</ribbon-version>
-    <roaster-version>2.20.1.Final</roaster-version>
-    <rome-bundle-version>1.0_3</rome-bundle-version>
-    <rome-version>1.0</rome-version>
-    <rxjava-version>1.3.1</rxjava-version>
-    <rxjava2-version>2.1.3</rxjava2-version>
-    <saaj-impl-version>1.3.2_2</saaj-impl-version>
-    <saxon-bundle-version>9.7.0-18_1</saxon-bundle-version>
-    <saxon-version>9.7.0-18</saxon-version>
-    <scala-version>2.11.7</scala-version>
-    <scala-maven-plugin-version>3.2.2</scala-maven-plugin-version>
-    <scalatest-version>2.2.5</scalatest-version>
-    <scalaxml-version>1.0.6</scalaxml-version>
-    <scribe-version>1.3.7</scribe-version>
-    <scribe-bundle-version>1.3.7_1</scribe-bundle-version>
-    <scriptengines-version>1.1.1</scriptengines-version>
-    <serp-bundle-version>1.14.1_1</serp-bundle-version>
-    <servicemix-specs-version>2.9.0</servicemix-specs-version>
-    <servlet-api-3.0-version>1.0</servlet-api-3.0-version>
-    <servlet-version-range>[3,4)</servlet-version-range>
-    <shiro-version>1.3.2</shiro-version>
-    <shrinkwrap-descriptors-version>2.0.0-alpha-10</shrinkwrap-descriptors-version>
-    <shrinkwrap-resolver-version>2.2.4</shrinkwrap-resolver-version>
-    <shrinkwrap-version>1.2.3</shrinkwrap-version>
-    <sip-api-version>1.1</sip-api-version>
-    <slf4j-api-version>1.7.22</slf4j-api-version>
-    <slf4j-version>1.7.22</slf4j-version>
-    <smack-version>4.2.1</smack-version>
-    <snakeyaml-version>1.18</snakeyaml-version>
-    <snappy-version>1.1.2.6</snappy-version>
-    <snmp4j-version>2.3.4_1</snmp4j-version>
-    <solr-bundle-version>5.5.2_1</solr-bundle-version>
-    <!-- solr version aligned with lucene -->
-    <solr-version>5.5.2</solr-version>
-    <solr-version-range>[5,6)</solr-version-range>
-    <spark-version>1.6.1</spark-version>
-    <spark-rest-version>2.6.0</spark-rest-version>
-    <spark-rest-bundle-version>2.6.0_1</spark-rest-bundle-version>
-    <splunk-version>1.6.3.0_1</splunk-version>
-    <spring-batch-version>3.0.8.RELEASE</spring-batch-version>
-    <spring-batch-bundle-version>3.0.8.RELEASE_1</spring-batch-bundle-version>
-    <spring-boot-version>1.5.6.RELEASE</spring-boot-version>
-    <spring-boot1-version>1.5.6.RELEASE</spring-boot1-version>
-    <spring-boot2-version>2.0.0.M3</spring-boot2-version>
-    <!-- use same version of spring-cloud 1.2.x -->
-    <spring-cloud-commons-version>1.2.3.RELEASE</spring-cloud-commons-version>
-    <spring-cloud-netflix-version>1.3.4.RELEASE</spring-cloud-netflix-version>
-    <spring-castor-bundle-version>1.2.0</spring-castor-bundle-version>
-    <spring-data-commons-version>1.13.6.RELEASE</spring-data-commons-version>
-    <spring-data-keyvalue-version>1.2.6.RELEASE</spring-data-keyvalue-version>
-    <spring-data-redis-version>1.8.6.RELEASE</spring-data-redis-version>
-    <spring-integration-version>4.3.11.RELEASE</spring-integration-version>
-    <spring-javaconfig-version>1.0.0-20090215</spring-javaconfig-version>
-    <spring-ldap-version>2.3.1.RELEASE</spring-ldap-version>
-    <spring-ldap-bundle-version>2.3.1.RELEASE_1</spring-ldap-bundle-version>
-    <!-- spring 1.1.0 is not OSGi bundle any more -->
-    <spring-retry-version>1.0.3.RELEASE</spring-retry-version>
-    <spring-all-version-range>[3.2,5)</spring-all-version-range>
-    <!-- karaf 3.x/4.x supports spring 4.1 onwards -->
-    <spring-version-range>[4.1,5)</spring-version-range>
-    <!-- and special for only spring 4.0.x -->
-    <spring40-version-range>[4.0,4.1)</spring40-version-range>
-    <!-- and for spring 4.2.x onwards-->
-    <spring42-version-range>[4.2,5)</spring42-version-range>
-    <spring-version>${spring4-version}</spring-version>
-    <spring40-version>4.0.9.RELEASE</spring40-version>
-    <spring41-version>4.1.9.RELEASE</spring41-version>
-    <spring42-version>4.2.9.RELEASE</spring42-version>
-    <spring43-version>4.3.10.RELEASE</spring43-version>
-    <spring4-version>4.3.10.RELEASE</spring4-version>
-    <spring5-version>5.0.0.RC3</spring5-version>
-    <spring-osgi-version>1.2.1</spring-osgi-version>
-    <spring-security-version>4.2.3.RELEASE</spring-security-version>
-    <spring-security-bundle-version>4.2.3.RELEASE_1</spring-security-bundle-version>
-    <spring-ws-bundle-version>2.3.0.RELEASE_1</spring-ws-bundle-version>
-    <spring-ws-version>2.3.0.RELEASE</spring-ws-version>
-    <spymemcached-bundle-version>2.5_2</spymemcached-bundle-version> <!-- FIXME cmueller: not in sync! -->
-    <spymemcached-version>2.12.0</spymemcached-version>
-    <squareup-okhttp-version>2.7.5</squareup-okhttp-version>
-    <squareup-okhttp3-version>3.8.1</squareup-okhttp3-version>
-    <squareup-okhttp-bundle-version>2.7.5_1</squareup-okhttp-bundle-version>
-    <squareup-okio-version>1.13.0</squareup-okio-version>
-    <squareup-okio-bundle-version>1.13.0_1</squareup-okio-bundle-version>
-    <squareup-retrofit-bundle-version>1.9.0_1</squareup-retrofit-bundle-version>
-    <squareup-retrofit2-bundle-version>2.3.0_1</squareup-retrofit2-bundle-version>
-    <sshd-version>1.6.0</sshd-version>
-    <stompjms-version>1.19</stompjms-version>
-    <swagger-scala-version>1.3.12</swagger-scala-version>
-    <swagger-scala-guava-version>15.0</swagger-scala-guava-version>
-    <swagger-scala-bundle-version>1.3.12_2</swagger-scala-bundle-version>
-    <swagger-java-version>1.5.16</swagger-java-version>
-    <swagger-java-parser-version>1.0.30</swagger-java-parser-version>
-    <swagger-java-guava-version>20.0</swagger-java-guava-version>
-    <swagger-ui-version>2.2.10</swagger-ui-version>
-    <stax-api-version>1.0.1</stax-api-version>
-    <stax2-api-bundle-version>3.1.4</stax2-api-bundle-version>
-    <stringtemplate-bundle-version>4.0.8_1</stringtemplate-bundle-version>
-    <stringtemplate-version>4.0.8</stringtemplate-version>
-    <tagsoup-bundle-version>1.2.1_1</tagsoup-bundle-version>
-    <tagsoup-version>1.2.1</tagsoup-version>
-    <testng-version>6.8.21</testng-version>
-    <tinybundles-version>2.1.1</tinybundles-version>
-    <tika-version>1.16</tika-version>
-    <twilio-version>7.9.1</twilio-version>
-    <twitter4j-bundle-version>4.0.6_1</twitter4j-bundle-version>
-    <twitter4j-version>4.0.6</twitter4j-version>
-    <undertow-version>1.4.18.Final</undertow-version>
-    <univocity-parsers-version>2.3.1</univocity-parsers-version>
-    <unix-socket-factory-version>2015-01-27T15-02-14</unix-socket-factory-version>
-    <unix-socket-factory-bundle-version>1.0.0</unix-socket-factory-bundle-version>
-    <urlrewritefilter-version>4.0.4</urlrewritefilter-version>
-    <urlrewritefilter-bundle-version>4.0.4_1</urlrewritefilter-bundle-version>
-    <validation-api-version>1.1.0.Final</validation-api-version>
-    <velocity-bundle-version>1.7_6</velocity-bundle-version>
-    <velocity-tools-version>2.0</velocity-tools-version>
-    <velocity-version>1.7</velocity-version>
-    <vertx-version>3.4.2</vertx-version>
-    <vysper-version>0.7</vysper-version>
-    <weld1-version>1.1.28.Final</weld1-version>
-    <weld2-version>2.4.4.Final</weld2-version>
-    <weld3-version>3.0.1.Final</weld3-version>
-    <werken-xpath-bundle-version>0.9.4_5</werken-xpath-bundle-version>
-    <wiremock-version>2.7.1</wiremock-version>
-    <woodstox-version>4.4.1</woodstox-version>
-    <ws-commons-util-bundle-version>1.0.2_2</ws-commons-util-bundle-version>
-    <wsdl4j-bundle-version>1.6.3_1</wsdl4j-bundle-version>
-    <wsdl4j-version>1.6.3</wsdl4j-version>
-    <xalan-bundle-version>2.7.2_3</xalan-bundle-version>
-    <xalan-version>2.7.2</xalan-version>
-    <xbean-spring-version>4.5</xbean-spring-version>
-    <!-- xbean-asm4-bundle is used by openjpa -->
-    <xbean-asm4-bundle-version>3.14</xbean-asm4-bundle-version>
-    <xerces-bundle-version>2.11.0_1</xerces-bundle-version>
-    <xerces-version>2.11.0</xerces-version>
-    <!-- needed to manage the xml-apis version in camel-xmljson -->
-    <xml-apis-version>1.4.01</xml-apis-version>
-    <xml-apis-ext-version>1.3.04</xml-apis-ext-version>
-    <xml-resolver-version>1.2</xml-resolver-version>
-    <xmlbeans-bundle-version>2.6.0_2</xmlbeans-bundle-version>
-    <xmlbeans-maven-plugin-version>2.3.3</xmlbeans-maven-plugin-version>
-    <xmlbeans-version>2.6.0</xmlbeans-version>
-    <xmlgraphics-commons-bundle-version>2.1_1</xmlgraphics-commons-bundle-version>
-    <xmlgraphics-batik-version>1.9.1</xmlgraphics-batik-version>
-    <xmlresolver-bundle-version>1.2_5</xmlresolver-bundle-version>
-    <xmlrpc-version>3.1.3</xmlrpc-version>
-    <xmlrpc-client-bundle-version>3.1.3_1</xmlrpc-client-bundle-version>
-    <xmlsec-version>2.0.9</xmlsec-version>
-    <xmlunit-version>2.3.0</xmlunit-version>
-    <xpp3-bundle-version>1.1.4c_7</xpp3-bundle-version>
-    <xpp3-version>1.1.4c</xpp3-version>
-    <xsdlib-version>2013.2</xsdlib-version>
-    <xstream-bundle-version>1.4.10_1</xstream-bundle-version>
-    <xstream-version>1.4.10</xstream-version>
-    <xom-version>1.2.5</xom-version>
-    <yammer-metrics-version>2.2.0</yammer-metrics-version>
-    <zendesk-client-version>0.5.4</zendesk-client-version>
-    <zipkin-libthrift-version>0.9.3</zipkin-libthrift-version>
-    <zipkin-reporter-version>1.0.1</zipkin-reporter-version>
-    <zipkin-version>1.29.1</zipkin-version>
-    <zjsonpatch-version>0.3.0</zjsonpatch-version>
-    <zookeeper-version>3.4.10</zookeeper-version>
-    <zookeeper-guava-version>16.0</zookeeper-guava-version>
-    <zxing-version>3.3.0</zxing-version>
-    <zxing-bundle-version>3.3.0_1</zxing-bundle-version>
 
     <!-- OSGi bundles properties -->
     <camel.osgi.import.camel.version>version="[$(version;==;${camel.osgi.version.clean}),$(version;=+;${camel.osgi.version.clean}))"</camel.osgi.import.camel.version>
@@ -5244,50 +4535,7 @@
 
   <profiles>
 
-    <profile>
-      <id>nochecks</id>
-      <activation>
-        <activeByDefault>true</activeByDefault>
-      </activation>
-    </profile>
-
-    <profile>
-      <id>fastinstall</id>
-      <activation>
-        <property>
-          <name>fastinstall</name>
-        </property>
-      </activation>
-      <properties>
-        <maven.test.skip.exec>true</maven.test.skip.exec>
-        <assembly.skipAssembly>true</assembly.skipAssembly>
-        <noassembly>true</noassembly>
-      </properties>
-    </profile>
-
-    <profile>
-      <id>sourcecheck</id>
-      <build>
-        <plugins>
-          <plugin>
-            <groupId>org.apache.maven.plugins</groupId>
-            <artifactId>maven-checkstyle-plugin</artifactId>
-          </plugin>
-        </plugins>
-      </build>
-    </profile>
 
-    <profile>
-      <id>dependencycheck</id>
-      <build>
-        <plugins>
-          <plugin>
-            <groupId>org.owasp</groupId>
-            <artifactId>dependency-check-maven</artifactId>
-          </plugin>
-        </plugins>
-      </build>
-    </profile>
 
     <profile>
       <id>errorprone</id>
@@ -5354,40 +4602,6 @@
       </build>
     </profile>
 
-    <!-- spring-boot2 experiment -->
-    <profile>
-      <id>spring-boot2</id>
-      <properties>
-        <!-- spring-boot -->
-        <spring-boot-version>${spring-boot2-version}</spring-boot-version>
-        <spring-version>${spring5-version}</spring-version>
-        <jackson2-version>2.9.1</jackson2-version>
-        <!-- spring-cloud -->
-        <spring-cloud-commons-version>2.0.0.M2</spring-cloud-commons-version>
-        <spring-cloud-netflix-version>2.0.0.M2</spring-cloud-netflix-version>
-      </properties>
-       <repositories>
-        <repository>
-          <id>spring-milestones</id>
-          <name>Spring Milestones</name>
-          <url>https://repo.spring.io/libs-milestone</url>
-          <snapshots>
-            <enabled>false</enabled>
-          </snapshots>
-        </repository>
-      </repositories>
-      <pluginRepositories>
-        <pluginRepository>
-          <id>spring-milestones</id>
-          <name>Spring Milestones</name>
-          <url>https://repo.spring.io/libs-milestone</url>
-          <snapshots>
-            <enabled>false</enabled>
-          </snapshots>
-        </pluginRepository>
-      </pluginRepositories>
-    </profile>
-
     <profile>
       <id>jdk1.8</id>
       <activation>

http://git-wip-us.apache.org/repos/asf/camel/blob/45d81300/platforms/spring-boot/components-starter/camel-amqp-starter/pom.xml
----------------------------------------------------------------------
diff --git a/platforms/spring-boot/components-starter/camel-amqp-starter/pom.xml b/platforms/spring-boot/components-starter/camel-amqp-starter/pom.xml
index 47f3f0c..ed8f494 100644
--- a/platforms/spring-boot/components-starter/camel-amqp-starter/pom.xml
+++ b/platforms/spring-boot/components-starter/camel-amqp-starter/pom.xml
@@ -38,6 +38,14 @@
       <groupId>org.apache.camel</groupId>
       <artifactId>camel-amqp</artifactId>
       <version>${project.version}</version>
+      <!--START OF GENERATED CODE-->
+      <exclusions>
+        <exclusion>
+          <groupId>commons-logging</groupId>
+          <artifactId>commons-logging</artifactId>
+        </exclusion>
+      </exclusions>
+      <!--END OF GENERATED CODE-->
     </dependency>
     <!--START OF GENERATED CODE-->
     <dependency>

http://git-wip-us.apache.org/repos/asf/camel/blob/45d81300/platforms/spring-boot/components-starter/camel-bam-starter/pom.xml
----------------------------------------------------------------------
diff --git a/platforms/spring-boot/components-starter/camel-bam-starter/pom.xml b/platforms/spring-boot/components-starter/camel-bam-starter/pom.xml
index 18ad7d5..80c4b10 100644
--- a/platforms/spring-boot/components-starter/camel-bam-starter/pom.xml
+++ b/platforms/spring-boot/components-starter/camel-bam-starter/pom.xml
@@ -38,6 +38,14 @@
       <groupId>org.apache.camel</groupId>
       <artifactId>camel-bam</artifactId>
       <version>${project.version}</version>
+      <!--START OF GENERATED CODE-->
+      <exclusions>
+        <exclusion>
+          <groupId>commons-logging</groupId>
+          <artifactId>commons-logging</artifactId>
+        </exclusion>
+      </exclusions>
+      <!--END OF GENERATED CODE-->
     </dependency>
     <!--START OF GENERATED CODE-->
     <dependency>

http://git-wip-us.apache.org/repos/asf/camel/blob/45d81300/platforms/spring-boot/components-starter/camel-cxf-starter/pom.xml
----------------------------------------------------------------------
diff --git a/platforms/spring-boot/components-starter/camel-cxf-starter/pom.xml b/platforms/spring-boot/components-starter/camel-cxf-starter/pom.xml
index 12a0485..f8d4a19 100644
--- a/platforms/spring-boot/components-starter/camel-cxf-starter/pom.xml
+++ b/platforms/spring-boot/components-starter/camel-cxf-starter/pom.xml
@@ -38,6 +38,14 @@
       <groupId>org.apache.camel</groupId>
       <artifactId>camel-cxf</artifactId>
       <version>${project.version}</version>
+      <!--START OF GENERATED CODE-->
+      <exclusions>
+        <exclusion>
+          <groupId>commons-logging</groupId>
+          <artifactId>commons-logging</artifactId>
+        </exclusion>
+      </exclusions>
+      <!--END OF GENERATED CODE-->
     </dependency>
     <!--START OF GENERATED CODE-->
     <dependency>

http://git-wip-us.apache.org/repos/asf/camel/blob/45d81300/platforms/spring-boot/components-starter/camel-cxf-transport-starter/pom.xml
----------------------------------------------------------------------
diff --git a/platforms/spring-boot/components-starter/camel-cxf-transport-starter/pom.xml b/platforms/spring-boot/components-starter/camel-cxf-transport-starter/pom.xml
index df3dc9f..9d0366c 100644
--- a/platforms/spring-boot/components-starter/camel-cxf-transport-starter/pom.xml
+++ b/platforms/spring-boot/components-starter/camel-cxf-transport-starter/pom.xml
@@ -38,6 +38,14 @@
       <groupId>org.apache.camel</groupId>
       <artifactId>camel-cxf-transport</artifactId>
       <version>${project.version}</version>
+      <!--START OF GENERATED CODE-->
+      <exclusions>
+        <exclusion>
+          <groupId>commons-logging</groupId>
+          <artifactId>commons-logging</artifactId>
+        </exclusion>
+      </exclusions>
+      <!--END OF GENERATED CODE-->
     </dependency>
     <!--START OF GENERATED CODE-->
     <dependency>

http://git-wip-us.apache.org/repos/asf/camel/blob/45d81300/platforms/spring-boot/components-starter/camel-drill-starter/pom.xml
----------------------------------------------------------------------
diff --git a/platforms/spring-boot/components-starter/camel-drill-starter/pom.xml b/platforms/spring-boot/components-starter/camel-drill-starter/pom.xml
index 316823e..2ed1711 100644
--- a/platforms/spring-boot/components-starter/camel-drill-starter/pom.xml
+++ b/platforms/spring-boot/components-starter/camel-drill-starter/pom.xml
@@ -38,6 +38,14 @@
       <groupId>org.apache.camel</groupId>
       <artifactId>camel-drill</artifactId>
       <version>${project.version}</version>
+      <!--START OF GENERATED CODE-->
+      <exclusions>
+        <exclusion>
+          <groupId>commons-logging</groupId>
+          <artifactId>commons-logging</artifactId>
+        </exclusion>
+      </exclusions>
+      <!--END OF GENERATED CODE-->
     </dependency>
     <!--START OF GENERATED CODE-->
     <dependency>

http://git-wip-us.apache.org/repos/asf/camel/blob/45d81300/platforms/spring-boot/components-starter/camel-elsql-starter/pom.xml
----------------------------------------------------------------------
diff --git a/platforms/spring-boot/components-starter/camel-elsql-starter/pom.xml b/platforms/spring-boot/components-starter/camel-elsql-starter/pom.xml
index 2fef60e..f492853 100644
--- a/platforms/spring-boot/components-starter/camel-elsql-starter/pom.xml
+++ b/platforms/spring-boot/components-starter/camel-elsql-starter/pom.xml
@@ -38,6 +38,14 @@
       <groupId>org.apache.camel</groupId>
       <artifactId>camel-elsql</artifactId>
       <version>${project.version}</version>
+      <!--START OF GENERATED CODE-->
+      <exclusions>
+        <exclusion>
+          <groupId>commons-logging</groupId>
+          <artifactId>commons-logging</artifactId>
+        </exclusion>
+      </exclusions>
+      <!--END OF GENERATED CODE-->
     </dependency>
     <!--START OF GENERATED CODE-->
     <dependency>

http://git-wip-us.apache.org/repos/asf/camel/blob/45d81300/platforms/spring-boot/components-starter/camel-jms-starter/pom.xml
----------------------------------------------------------------------
diff --git a/platforms/spring-boot/components-starter/camel-jms-starter/pom.xml b/platforms/spring-boot/components-starter/camel-jms-starter/pom.xml
index c65bad5..ac49e36 100644
--- a/platforms/spring-boot/components-starter/camel-jms-starter/pom.xml
+++ b/platforms/spring-boot/components-starter/camel-jms-starter/pom.xml
@@ -38,6 +38,14 @@
       <groupId>org.apache.camel</groupId>
       <artifactId>camel-jms</artifactId>
       <version>${project.version}</version>
+      <!--START OF GENERATED CODE-->
+      <exclusions>
+        <exclusion>
+          <groupId>commons-logging</groupId>
+          <artifactId>commons-logging</artifactId>
+        </exclusion>
+      </exclusions>
+      <!--END OF GENERATED CODE-->
     </dependency>
     <dependency>
       <groupId>org.apache.geronimo.specs</groupId>

http://git-wip-us.apache.org/repos/asf/camel/blob/45d81300/platforms/spring-boot/components-starter/camel-jpa-starter/pom.xml
----------------------------------------------------------------------
diff --git a/platforms/spring-boot/components-starter/camel-jpa-starter/pom.xml b/platforms/spring-boot/components-starter/camel-jpa-starter/pom.xml
index 886732a..58b660e 100644
--- a/platforms/spring-boot/components-starter/camel-jpa-starter/pom.xml
+++ b/platforms/spring-boot/components-starter/camel-jpa-starter/pom.xml
@@ -38,6 +38,14 @@
       <groupId>org.apache.camel</groupId>
       <artifactId>camel-jpa</artifactId>
       <version>${project.version}</version>
+      <!--START OF GENERATED CODE-->
+      <exclusions>
+        <exclusion>
+          <groupId>commons-logging</groupId>
+          <artifactId>commons-logging</artifactId>
+        </exclusion>
+      </exclusions>
+      <!--END OF GENERATED CODE-->
     </dependency>
     <dependency>
       <groupId>org.apache.geronimo.specs</groupId>

http://git-wip-us.apache.org/repos/asf/camel/blob/45d81300/platforms/spring-boot/components-starter/camel-spring-batch-starter/pom.xml
----------------------------------------------------------------------
diff --git a/platforms/spring-boot/components-starter/camel-spring-batch-starter/pom.xml b/platforms/spring-boot/components-starter/camel-spring-batch-starter/pom.xml
index f8c5733..802570e 100644
--- a/platforms/spring-boot/components-starter/camel-spring-batch-starter/pom.xml
+++ b/platforms/spring-boot/components-starter/camel-spring-batch-starter/pom.xml
@@ -38,6 +38,14 @@
       <groupId>org.apache.camel</groupId>
       <artifactId>camel-spring-batch</artifactId>
       <version>${project.version}</version>
+      <!--START OF GENERATED CODE-->
+      <exclusions>
+        <exclusion>
+          <groupId>commons-logging</groupId>
+          <artifactId>commons-logging</artifactId>
+        </exclusion>
+      </exclusions>
+      <!--END OF GENERATED CODE-->
     </dependency>
     <!--START OF GENERATED CODE-->
     <dependency>

http://git-wip-us.apache.org/repos/asf/camel/blob/45d81300/platforms/spring-boot/components-starter/camel-spring-boot2-starter/pom.xml
----------------------------------------------------------------------
diff --git a/platforms/spring-boot/components-starter/camel-spring-boot2-starter/pom.xml b/platforms/spring-boot/components-starter/camel-spring-boot2-starter/pom.xml
index 90797e5..9c36f78 100644
--- a/platforms/spring-boot/components-starter/camel-spring-boot2-starter/pom.xml
+++ b/platforms/spring-boot/components-starter/camel-spring-boot2-starter/pom.xml
@@ -60,6 +60,11 @@
       <groupId>org.apache.camel</groupId>
       <artifactId>camel-core-starter</artifactId>
     </dependency>
+    <dependency>
+      <groupId>org.apache.camel</groupId>
+      <artifactId>camel-spring-boot</artifactId>
+      <optional>true</optional>
+    </dependency>
     <!--END OF GENERATED CODE-->
   </dependencies>
   <!--START OF GENERATED CODE-->

http://git-wip-us.apache.org/repos/asf/camel/blob/45d81300/platforms/spring-boot/components-starter/camel-spring-cloud-starter/pom.xml
----------------------------------------------------------------------
diff --git a/platforms/spring-boot/components-starter/camel-spring-cloud-starter/pom.xml b/platforms/spring-boot/components-starter/camel-spring-cloud-starter/pom.xml
index 2864de1..5a5a574 100644
--- a/platforms/spring-boot/components-starter/camel-spring-cloud-starter/pom.xml
+++ b/platforms/spring-boot/components-starter/camel-spring-cloud-starter/pom.xml
@@ -38,6 +38,14 @@
       <groupId>org.apache.camel</groupId>
       <artifactId>camel-spring-cloud</artifactId>
       <version>${project.version}</version>
+      <!--START OF GENERATED CODE-->
+      <exclusions>
+        <exclusion>
+          <groupId>commons-logging</groupId>
+          <artifactId>commons-logging</artifactId>
+        </exclusion>
+      </exclusions>
+      <!--END OF GENERATED CODE-->
     </dependency>
     <!--START OF GENERATED CODE-->
     <dependency>

http://git-wip-us.apache.org/repos/asf/camel/blob/45d81300/platforms/spring-boot/components-starter/camel-spring-integration-starter/pom.xml
----------------------------------------------------------------------
diff --git a/platforms/spring-boot/components-starter/camel-spring-integration-starter/pom.xml b/platforms/spring-boot/components-starter/camel-spring-integration-starter/pom.xml
index 5e8d719..25738cd 100644
--- a/platforms/spring-boot/components-starter/camel-spring-integration-starter/pom.xml
+++ b/platforms/spring-boot/components-starter/camel-spring-integration-starter/pom.xml
@@ -38,6 +38,14 @@
       <groupId>org.apache.camel</groupId>
       <artifactId>camel-spring-integration</artifactId>
       <version>${project.version}</version>
+      <!--START OF GENERATED CODE-->
+      <exclusions>
+        <exclusion>
+          <groupId>commons-logging</groupId>
+          <artifactId>commons-logging</artifactId>
+        </exclusion>
+      </exclusions>
+      <!--END OF GENERATED CODE-->
     </dependency>
     <!--START OF GENERATED CODE-->
     <dependency>

http://git-wip-us.apache.org/repos/asf/camel/blob/45d81300/platforms/spring-boot/components-starter/camel-spring-javaconfig-starter/pom.xml
----------------------------------------------------------------------
diff --git a/platforms/spring-boot/components-starter/camel-spring-javaconfig-starter/pom.xml b/platforms/spring-boot/components-starter/camel-spring-javaconfig-starter/pom.xml
index 243190a..9c6a122 100644
--- a/platforms/spring-boot/components-starter/camel-spring-javaconfig-starter/pom.xml
+++ b/platforms/spring-boot/components-starter/camel-spring-javaconfig-starter/pom.xml
@@ -38,6 +38,14 @@
       <groupId>org.apache.camel</groupId>
       <artifactId>camel-spring-javaconfig</artifactId>
       <version>${project.version}</version>
+      <!--START OF GENERATED CODE-->
+      <exclusions>
+        <exclusion>
+          <groupId>commons-logging</groupId>
+          <artifactId>commons-logging</artifactId>
+        </exclusion>
+      </exclusions>
+      <!--END OF GENERATED CODE-->
     </dependency>
     <!--START OF GENERATED CODE-->
     <dependency>

http://git-wip-us.apache.org/repos/asf/camel/blob/45d81300/platforms/spring-boot/components-starter/camel-spring-redis-starter/pom.xml
----------------------------------------------------------------------
diff --git a/platforms/spring-boot/components-starter/camel-spring-redis-starter/pom.xml b/platforms/spring-boot/components-starter/camel-spring-redis-starter/pom.xml
index 422d876..78b96d5 100644
--- a/platforms/spring-boot/components-starter/camel-spring-redis-starter/pom.xml
+++ b/platforms/spring-boot/components-starter/camel-spring-redis-starter/pom.xml
@@ -38,6 +38,14 @@
       <groupId>org.apache.camel</groupId>
       <artifactId>camel-spring-redis</artifactId>
       <version>${project.version}</version>
+      <!--START OF GENERATED CODE-->
+      <exclusions>
+        <exclusion>
+          <groupId>commons-logging</groupId>
+          <artifactId>commons-logging</artifactId>
+        </exclusion>
+      </exclusions>
+      <!--END OF GENERATED CODE-->
     </dependency>
     <!--START OF GENERATED CODE-->
     <dependency>

http://git-wip-us.apache.org/repos/asf/camel/blob/45d81300/platforms/spring-boot/components-starter/camel-spring-starter/pom.xml
----------------------------------------------------------------------
diff --git a/platforms/spring-boot/components-starter/camel-spring-starter/pom.xml b/platforms/spring-boot/components-starter/camel-spring-starter/pom.xml
index b270e00..9fe0a7f 100644
--- a/platforms/spring-boot/components-starter/camel-spring-starter/pom.xml
+++ b/platforms/spring-boot/components-starter/camel-spring-starter/pom.xml
@@ -38,6 +38,14 @@
       <groupId>org.apache.camel</groupId>
       <artifactId>camel-spring</artifactId>
       <version>${project.version}</version>
+      <!--START OF GENERATED CODE-->
+      <exclusions>
+        <exclusion>
+          <groupId>commons-logging</groupId>
+          <artifactId>commons-logging</artifactId>
+        </exclusion>
+      </exclusions>
+      <!--END OF GENERATED CODE-->
     </dependency>
     <!--START OF GENERATED CODE-->
     <dependency>

http://git-wip-us.apache.org/repos/asf/camel/blob/45d81300/platforms/spring-boot/components-starter/camel-sql-starter/pom.xml
----------------------------------------------------------------------
diff --git a/platforms/spring-boot/components-starter/camel-sql-starter/pom.xml b/platforms/spring-boot/components-starter/camel-sql-starter/pom.xml
index 9a1c345..1c1f643 100644
--- a/platforms/spring-boot/components-starter/camel-sql-starter/pom.xml
+++ b/platforms/spring-boot/components-starter/camel-sql-starter/pom.xml
@@ -38,6 +38,14 @@
       <groupId>org.apache.camel</groupId>
       <artifactId>camel-sql</artifactId>
       <version>${project.version}</version>
+      <!--START OF GENERATED CODE-->
+      <exclusions>
+        <exclusion>
+          <groupId>commons-logging</groupId>
+          <artifactId>commons-logging</artifactId>
+        </exclusion>
+      </exclusions>
+      <!--END OF GENERATED CODE-->
     </dependency>
     <dependency>
       <groupId>org.springframework.boot</groupId>

http://git-wip-us.apache.org/repos/asf/camel/blob/45d81300/platforms/spring-boot/pom.xml
----------------------------------------------------------------------
diff --git a/platforms/spring-boot/pom.xml b/platforms/spring-boot/pom.xml
index a8d9434..c10d8de 100644
--- a/platforms/spring-boot/pom.xml
+++ b/platforms/spring-boot/pom.xml
@@ -21,9 +21,10 @@
          xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
          xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
     <parent>
-        <artifactId>platforms</artifactId>
+        <artifactId>camel</artifactId>
         <groupId>org.apache.camel</groupId>
         <version>2.20.0-SNAPSHOT</version>
+        <relativePath>../../</relativePath>
     </parent>
     <modelVersion>4.0.0</modelVersion>
 
@@ -36,4 +37,79 @@
         <module>components-starter</module>
     </modules>
 
+    <build>
+        <plugins>
+
+            <plugin>
+                <groupId>org.apache.maven.plugins</groupId>
+                <artifactId>maven-checkstyle-plugin</artifactId>
+                <version>${maven-checkstyle-plugin-version}</version>
+                <dependencies>
+                    <dependency>
+                        <groupId>org.apache.camel</groupId>
+                        <artifactId>camel-buildtools</artifactId>
+                        <version>${project.version}</version>
+                    </dependency>
+                    <dependency>
+                        <groupId>com.puppycrawl.tools</groupId>
+                        <artifactId>checkstyle</artifactId>
+                        <version>${maven-checkstyle-version}</version>
+                    </dependency>
+                </dependencies>
+                <executions>
+                    <execution>
+                        <id>default-cli</id>
+                        <phase>validate</phase>
+                        <configuration>
+                            <includeResources>false</includeResources>
+                            <configLocation>camel-checkstyle.xml</configLocation>
+                            <consoleOutput>true</consoleOutput>
+                            <failsOnError>true</failsOnError>
+                            <linkXRef>false</linkXRef>
+                            <suppressionsLocation>camel-checkstyle-suppressions.xml</suppressionsLocation>
+                            <encoding>UTF-8</encoding>
+                            <sourceDirectory>${basedir}/src</sourceDirectory>
+                            <excludes>**/archetype-resources/**/*.java</excludes>
+                        </configuration>
+                        <goals>
+                            <goal>checkstyle</goal>
+                        </goals>
+                    </execution>
+                </executions>
+            </plugin>
+            <plugin>
+                <groupId>org.apache.maven.plugins</groupId>
+                <artifactId>maven-compiler-plugin</artifactId>
+                <version>${maven-compiler-plugin-version}</version>
+                <configuration>
+                    <source>${jdk.version}</source>
+                    <target>${jdk.version}</target>
+                    <maxmem>512M</maxmem>
+                    <fork>${compiler.fork}</fork>
+                </configuration>
+            </plugin>
+            <plugin>
+                <groupId>org.apache.maven.plugins</groupId>
+                <artifactId>maven-javadoc-plugin</artifactId>
+                <configuration>
+                    <attach>true</attach>
+                    <source>${jdk.version}</source>
+                    <quiet>true</quiet>
+                    <bottom>Apache Camel</bottom>
+                    <detectOfflineLinks>false</detectOfflineLinks>
+                    <javadocVersion>${jdk.version}</javadocVersion>
+                    <encoding>UTF-8</encoding>
+                </configuration>
+            </plugin>
+            <plugin>
+                <groupId>org.apache.maven.plugins</groupId>
+                <artifactId>maven-resources-plugin</artifactId>
+                <configuration>
+                    <encoding>UTF-8</encoding>
+                </configuration>
+            </plugin>
+
+        </plugins>
+    </build>
+
 </project>

Reply | Threaded
Open this post in threaded view
|

[3/3] camel git commit: fixing tests and refactoring properties

nferraro
In reply to this post by nferraro
fixing tests and refactoring properties


Project: http://git-wip-us.apache.org/repos/asf/camel/repo
Commit: http://git-wip-us.apache.org/repos/asf/camel/commit/8033b30c
Tree: http://git-wip-us.apache.org/repos/asf/camel/tree/8033b30c
Diff: http://git-wip-us.apache.org/repos/asf/camel/diff/8033b30c

Branch: refs/heads/boot2
Commit: 8033b30c9b7e616df638bd849912d3bdf8779d1a
Parents: 45d8130
Author: Nicola Ferraro <[hidden email]>
Authored: Tue Sep 19 02:14:00 2017 +0200
Committer: Nicola Ferraro <[hidden email]>
Committed: Tue Sep 19 02:14:00 2017 +0200

----------------------------------------------------------------------
 components/camel-ahc-ws/pom.xml                 |   6 -
 components/camel-gora/pom.xml                   |  10 +
 components/camel-hdfs/pom.xml                   |  10 +
 components/camel-hdfs2/pom.xml                  |  10 +
 components/camel-restlet/pom.xml                |   1 +
 components/camel-servlet/pom.xml                |   1 +
 components/camel-sjms2/pom.xml                  | 275 ++++++++++---------
 components/camel-spark/pom.xml                  |  26 ++
 .../camel-bam-starter/pom.xml                   |   8 +
 pom.xml                                         |   8 +-
 tests/camel-itest-spring-boot/pom.xml           |  47 +---
 .../camel/itest/springboot/ITestConfig.java     |  14 +-
 .../itest/springboot/ITestConfigBuilder.java    |   8 +-
 .../itest/springboot/CamelCassandraqlTest.java  |   6 -
 .../springboot/util/ArquillianPackager.java     |  36 ++-
 .../itest/springboot/util/BOMResolver.java      |  47 +++-
 .../springboot/util/DependencyResolver.java     |   7 +
 .../itest/springboot/util/JarExporter.java      |   4 +-
 18 files changed, 294 insertions(+), 230 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/camel/blob/8033b30c/components/camel-ahc-ws/pom.xml
----------------------------------------------------------------------
diff --git a/components/camel-ahc-ws/pom.xml b/components/camel-ahc-ws/pom.xml
index 31c77a9..634cff7 100644
--- a/components/camel-ahc-ws/pom.xml
+++ b/components/camel-ahc-ws/pom.xml
@@ -89,12 +89,6 @@
     <!-- Jetty8 for testing-->
     <dependency>
       <groupId>org.eclipse.jetty.websocket</groupId>
-      <artifactId>websocket-api</artifactId>
-      <version>${jetty-version}</version>
-      <scope>test</scope>
-    </dependency>
-    <dependency>
-      <groupId>org.eclipse.jetty.websocket</groupId>
       <artifactId>websocket-server</artifactId>
       <version>${jetty-version}</version>
       <scope>test</scope>

http://git-wip-us.apache.org/repos/asf/camel/blob/8033b30c/components/camel-gora/pom.xml
----------------------------------------------------------------------
diff --git a/components/camel-gora/pom.xml b/components/camel-gora/pom.xml
index 0ba69df..20e8b5e 100644
--- a/components/camel-gora/pom.xml
+++ b/components/camel-gora/pom.xml
@@ -144,10 +144,20 @@
     </dependency>
     <dependency>
       <groupId>org.codehaus.jackson</groupId>
+      <artifactId>jackson-jaxrs</artifactId>
+      <version>${jackson-version}</version>
+    </dependency>
+    <dependency>
+      <groupId>org.codehaus.jackson</groupId>
       <artifactId>jackson-mapper-asl</artifactId>
       <version>${jackson-version}</version>
     </dependency>
     <dependency>
+      <groupId>org.codehaus.jackson</groupId>
+      <artifactId>jackson-xc</artifactId>
+      <version>${jackson-version}</version>
+    </dependency>
+    <dependency>
       <groupId>org.apache.servicemix.bundles</groupId>
       <artifactId>org.apache.servicemix.bundles.jdom</artifactId>
       <version>${jdom-bundle-version}</version>

http://git-wip-us.apache.org/repos/asf/camel/blob/8033b30c/components/camel-hdfs/pom.xml
----------------------------------------------------------------------
diff --git a/components/camel-hdfs/pom.xml b/components/camel-hdfs/pom.xml
index 7b9442a..24b1bf0 100644
--- a/components/camel-hdfs/pom.xml
+++ b/components/camel-hdfs/pom.xml
@@ -108,9 +108,19 @@
         </dependency>
         <dependency>
             <groupId>org.codehaus.jackson</groupId>
+            <artifactId>jackson-jaxrs</artifactId>
+            <version>${jackson-version}</version>
+        </dependency>
+        <dependency>
+            <groupId>org.codehaus.jackson</groupId>
             <artifactId>jackson-mapper-asl</artifactId>
             <version>${jackson-version}</version>
         </dependency>
+        <dependency>
+            <groupId>org.codehaus.jackson</groupId>
+            <artifactId>jackson-xc</artifactId>
+            <version>${jackson-version}</version>
+        </dependency>
 
         <!-- testing -->
         <dependency>

http://git-wip-us.apache.org/repos/asf/camel/blob/8033b30c/components/camel-hdfs2/pom.xml
----------------------------------------------------------------------
diff --git a/components/camel-hdfs2/pom.xml b/components/camel-hdfs2/pom.xml
index 40b8b70..e91ee5d 100644
--- a/components/camel-hdfs2/pom.xml
+++ b/components/camel-hdfs2/pom.xml
@@ -122,9 +122,19 @@
     </dependency>
     <dependency>
       <groupId>org.codehaus.jackson</groupId>
+      <artifactId>jackson-jaxrs</artifactId>
+      <version>${jackson-version}</version>
+    </dependency>
+    <dependency>
+      <groupId>org.codehaus.jackson</groupId>
       <artifactId>jackson-mapper-asl</artifactId>
       <version>${jackson-version}</version>
     </dependency>
+    <dependency>
+      <groupId>org.codehaus.jackson</groupId>
+      <artifactId>jackson-xc</artifactId>
+      <version>${jackson-version}</version>
+    </dependency>
 
     <!-- testing -->
     <dependency>

http://git-wip-us.apache.org/repos/asf/camel/blob/8033b30c/components/camel-restlet/pom.xml
----------------------------------------------------------------------
diff --git a/components/camel-restlet/pom.xml b/components/camel-restlet/pom.xml
index 5a8570e..e41b60f 100644
--- a/components/camel-restlet/pom.xml
+++ b/components/camel-restlet/pom.xml
@@ -147,6 +147,7 @@
     <dependency>
       <groupId>com.google.guava</groupId>
       <artifactId>guava</artifactId>
+      <version>${google-guava-version}</version>
       <scope>test</scope>
     </dependency>
 

http://git-wip-us.apache.org/repos/asf/camel/blob/8033b30c/components/camel-servlet/pom.xml
----------------------------------------------------------------------
diff --git a/components/camel-servlet/pom.xml b/components/camel-servlet/pom.xml
index a80f3c5..83cde13 100644
--- a/components/camel-servlet/pom.xml
+++ b/components/camel-servlet/pom.xml
@@ -148,6 +148,7 @@
     <dependency>
       <groupId>org.jboss.arquillian.junit</groupId>
       <artifactId>arquillian-junit-container</artifactId>
+      <version>${arquillian-version}</version>
       <scope>test</scope>
     </dependency>
     <!--jetty-->

http://git-wip-us.apache.org/repos/asf/camel/blob/8033b30c/components/camel-sjms2/pom.xml
----------------------------------------------------------------------
diff --git a/components/camel-sjms2/pom.xml b/components/camel-sjms2/pom.xml
index 965ce6e..ce63a7f 100644
--- a/components/camel-sjms2/pom.xml
+++ b/components/camel-sjms2/pom.xml
@@ -17,152 +17,153 @@
     limitations under the License.
 
 -->
-<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
+<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+         xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
 
-  <modelVersion>4.0.0</modelVersion>
+    <modelVersion>4.0.0</modelVersion>
 
-  <parent>
-    <artifactId>components</artifactId>
-    <groupId>org.apache.camel</groupId>
-    <version>2.20.0-SNAPSHOT</version>
-  </parent>
+    <parent>
+        <artifactId>components</artifactId>
+        <groupId>org.apache.camel</groupId>
+        <version>2.20.0-SNAPSHOT</version>
+    </parent>
 
-  <artifactId>camel-sjms2</artifactId>
-  <packaging>jar</packaging>
-  <name>Camel :: Simple JMS2</name>
-  <description>A pure Java JMS 2.0 Camel Component</description>
+    <artifactId>camel-sjms2</artifactId>
+    <packaging>jar</packaging>
+    <name>Camel :: Simple JMS2</name>
+    <description>A pure Java JMS 2.0 Camel Component</description>
 
-  <properties>
-    <camel.osgi.export.pkg>
-      org.apache.camel.component.sjms2,
-      org.apache.camel.component.sjms2.jms
-    </camel.osgi.export.pkg>
-    <camel.osgi.export.service>
-      org.apache.camel.spi.ComponentResolver;component=sjms2
-    </camel.osgi.export.service>
-    <camel.osgi.import.additional>javax.jms;version="[2,3)"</camel.osgi.import.additional>
-  </properties>
+    <properties>
+        <camel.osgi.export.pkg>
+            org.apache.camel.component.sjms2,
+            org.apache.camel.component.sjms2.jms
+        </camel.osgi.export.pkg>
+        <camel.osgi.export.service>
+            org.apache.camel.spi.ComponentResolver;component=sjms2
+        </camel.osgi.export.service>
+        <camel.osgi.import.additional>javax.jms;version="[2,3)"</camel.osgi.import.additional>
+    </properties>
 
-  <dependencies>
-    <dependency>
-      <groupId>org.apache.camel</groupId>
-      <artifactId>camel-core</artifactId>
-    </dependency>
-    <dependency>
-      <groupId>org.apache.camel</groupId>
-      <artifactId>camel-sjms</artifactId>
-    </dependency>
-    <dependency>
-      <groupId>commons-pool</groupId>
-      <artifactId>commons-pool</artifactId>
-    </dependency>
+    <dependencies>
+        <dependency>
+            <groupId>org.apache.camel</groupId>
+            <artifactId>camel-core</artifactId>
+        </dependency>
+        <dependency>
+            <groupId>org.apache.camel</groupId>
+            <artifactId>camel-sjms</artifactId>
+        </dependency>
+        <dependency>
+            <groupId>commons-pool</groupId>
+            <artifactId>commons-pool</artifactId>
+        </dependency>
 
-    <dependency>
-      <groupId>org.apache.geronimo.specs</groupId>
-      <artifactId>geronimo-jms_2.0_spec</artifactId>
-      <version>${geronimo-jms2-spec-version}</version>
-      <scope>provided</scope>
-    </dependency>
-    <dependency>
-      <groupId>org.apache.geronimo.specs</groupId>
-      <artifactId>geronimo-annotation_1.0_spec</artifactId>
-      <version>${geronimo-annotation-1.0-spec-version}</version>
-      <scope>provided</scope>
-    </dependency>
+        <dependency>
+            <groupId>org.apache.geronimo.specs</groupId>
+            <artifactId>geronimo-jms_2.0_spec</artifactId>
+            <version>${geronimo-jms2-spec-version}</version>
+            <scope>provided</scope>
+        </dependency>
+        <dependency>
+            <groupId>org.apache.geronimo.specs</groupId>
+            <artifactId>geronimo-annotation_1.0_spec</artifactId>
+            <version>${geronimo-annotation-1.0-spec-version}</version>
+            <scope>provided</scope>
+        </dependency>
 
-    <!-- logging -->
-    <dependency>
-      <groupId>org.apache.logging.log4j</groupId>
-      <artifactId>log4j-api</artifactId>
-      <scope>test</scope>
-    </dependency>
-    <dependency>
-      <groupId>org.apache.logging.log4j</groupId>
-      <artifactId>log4j-core</artifactId>
-      <scope>test</scope>
-    </dependency>
-    <dependency>
-      <groupId>org.apache.logging.log4j</groupId>
-      <artifactId>log4j-slf4j-impl</artifactId>
-      <scope>test</scope>
-    </dependency>
+        <!-- logging -->
+        <dependency>
+            <groupId>org.apache.logging.log4j</groupId>
+            <artifactId>log4j-api</artifactId>
+            <scope>test</scope>
+        </dependency>
+        <dependency>
+            <groupId>org.apache.logging.log4j</groupId>
+            <artifactId>log4j-core</artifactId>
+            <scope>test</scope>
+        </dependency>
+        <dependency>
+            <groupId>org.apache.logging.log4j</groupId>
+            <artifactId>log4j-slf4j-impl</artifactId>
+            <scope>test</scope>
+        </dependency>
 
-    <!-- testing -->
-    <dependency>
-      <groupId>org.apache.camel</groupId>
-      <artifactId>camel-test</artifactId>
-      <scope>test</scope>
-    </dependency>
-    <dependency>
-      <groupId>org.apache.activemq</groupId>
-      <artifactId>activemq-broker</artifactId>
-      <scope>test</scope>
-    </dependency>
-    <dependency>
-      <groupId>org.apache.activemq</groupId>
-      <artifactId>activemq-kahadb-store</artifactId>
-      <scope>test</scope>
-    </dependency>
-    <dependency>
-      <groupId>org.apache.activemq</groupId>
-      <artifactId>activemq-pool</artifactId>
-      <scope>test</scope>
-    </dependency>
-    <dependency>
-      <groupId>commons-io</groupId>
-      <artifactId>commons-io</artifactId>
-      <version>${commons-io-version}</version>
-      <scope>test</scope>
-    </dependency>
+        <!-- testing -->
+        <dependency>
+            <groupId>org.apache.camel</groupId>
+            <artifactId>camel-test</artifactId>
+            <scope>test</scope>
+        </dependency>
+        <dependency>
+            <groupId>org.apache.activemq</groupId>
+            <artifactId>activemq-broker</artifactId>
+            <scope>test</scope>
+        </dependency>
+        <dependency>
+            <groupId>org.apache.activemq</groupId>
+            <artifactId>activemq-kahadb-store</artifactId>
+            <scope>test</scope>
+        </dependency>
+        <dependency>
+            <groupId>org.apache.activemq</groupId>
+            <artifactId>activemq-pool</artifactId>
+            <scope>test</scope>
+        </dependency>
+        <dependency>
+            <groupId>commons-io</groupId>
+            <artifactId>commons-io</artifactId>
+            <version>${commons-io-version}</version>
+            <scope>test</scope>
+        </dependency>
 
-    <dependency>
-      <groupId>org.apache.activemq</groupId>
-      <artifactId>artemis-server</artifactId>
-      <version>${activemq-artemis-version}</version>
-      <scope>test</scope>
-    </dependency>
-    <dependency>
-      <groupId>org.apache.activemq</groupId>
-      <artifactId>artemis-jms-server</artifactId>
-      <version>${activemq-artemis-version}</version>
-      <scope>test</scope>
-    </dependency>
-    <dependency>
-      <groupId>org.apache.activemq</groupId>
-      <artifactId>artemis-jms-client</artifactId>
-      <version>${activemq-artemis-version}</version>
-      <scope>test</scope>
-    </dependency>
-    <dependency>
-      <groupId>org.apache.activemq</groupId>
-      <artifactId>artemis-amqp-protocol</artifactId>
-      <version>${activemq-artemis-version}</version>
-      <scope>test</scope>
-    </dependency>
-  </dependencies>
+        <dependency>
+            <groupId>org.apache.activemq</groupId>
+            <artifactId>artemis-server</artifactId>
+            <version>${activemq-artemis-version}</version>
+            <scope>test</scope>
+        </dependency>
+        <dependency>
+            <groupId>org.apache.activemq</groupId>
+            <artifactId>artemis-jms-server</artifactId>
+            <version>${activemq-artemis-version}</version>
+            <scope>test</scope>
+        </dependency>
+        <dependency>
+            <groupId>org.apache.activemq</groupId>
+            <artifactId>artemis-jms-client</artifactId>
+            <version>${activemq-artemis-version}</version>
+            <scope>test</scope>
+        </dependency>
+        <dependency>
+            <groupId>org.apache.activemq</groupId>
+            <artifactId>artemis-amqp-protocol</artifactId>
+            <version>${activemq-artemis-version}</version>
+            <scope>test</scope>
+        </dependency>
+    </dependencies>
 
-  <build>
-    <plugins>
-      <plugin>
-        <artifactId>maven-surefire-plugin</artifactId>
-        <configuration>
-          <forkCount>1</forkCount>
-          <reuseForks>false</reuseForks>
-          <forkedProcessTimeoutInSeconds>6000</forkedProcessTimeoutInSeconds>
-        </configuration>
-      </plugin>
-      <plugin>
-        <groupId>org.apache.maven.plugins</groupId>
-        <artifactId>maven-clean-plugin</artifactId>
-        <configuration>
-          <filesets>
-            <fileset>
-              <directory>${basedir}/activemq-data</directory>
-            </fileset>
-          </filesets>
-        </configuration>
-      </plugin>
-    </plugins>
-  </build>
+    <build>
+        <plugins>
+            <plugin>
+                <artifactId>maven-surefire-plugin</artifactId>
+                <configuration>
+                    <forkCount>1</forkCount>
+                    <reuseForks>false</reuseForks>
+                    <forkedProcessTimeoutInSeconds>6000</forkedProcessTimeoutInSeconds>
+                </configuration>
+            </plugin>
+            <plugin>
+                <groupId>org.apache.maven.plugins</groupId>
+                <artifactId>maven-clean-plugin</artifactId>
+                <configuration>
+                    <filesets>
+                        <fileset>
+                            <directory>${basedir}/activemq-data</directory>
+                        </fileset>
+                    </filesets>
+                </configuration>
+            </plugin>
+        </plugins>
+    </build>
 
 </project>

http://git-wip-us.apache.org/repos/asf/camel/blob/8033b30c/components/camel-spark/pom.xml
----------------------------------------------------------------------
diff --git a/components/camel-spark/pom.xml b/components/camel-spark/pom.xml
index 94b1331..d9bdf0e 100644
--- a/components/camel-spark/pom.xml
+++ b/components/camel-spark/pom.xml
@@ -168,6 +168,32 @@
         </exclusion>
       </exclusions>
     </dependency>
+    <dependency>
+      <groupId>org.codehaus.jackson</groupId>
+      <artifactId>jackson-core-asl</artifactId>
+      <version>${jackson-version}</version>
+    </dependency>
+    <dependency>
+      <groupId>org.codehaus.jackson</groupId>
+      <artifactId>jackson-jaxrs</artifactId>
+      <version>${jackson-version}</version>
+    </dependency>
+    <dependency>
+      <groupId>org.codehaus.jackson</groupId>
+      <artifactId>jackson-mapper-asl</artifactId>
+      <version>${jackson-version}</version>
+    </dependency>
+    <dependency>
+      <groupId>org.codehaus.jackson</groupId>
+      <artifactId>jackson-xc</artifactId>
+      <version>${jackson-version}</version>
+    </dependency>
+    <dependency>
+      <groupId>org.apache.avro</groupId>
+      <artifactId>avro-mapred</artifactId>
+      <classifier>hadoop2</classifier>
+      <version>${avro-version}</version>
+    </dependency>
 
     <!-- Optional -->
     <dependency>

http://git-wip-us.apache.org/repos/asf/camel/blob/8033b30c/platforms/spring-boot/components-starter/camel-bam-starter/pom.xml
----------------------------------------------------------------------
diff --git a/platforms/spring-boot/components-starter/camel-bam-starter/pom.xml b/platforms/spring-boot/components-starter/camel-bam-starter/pom.xml
index 80c4b10..3ec6564 100644
--- a/platforms/spring-boot/components-starter/camel-bam-starter/pom.xml
+++ b/platforms/spring-boot/components-starter/camel-bam-starter/pom.xml
@@ -35,6 +35,14 @@
       <version>${spring-boot-version}</version>
     </dependency>
     <dependency>
+      <groupId>org.hibernate</groupId>
+      <artifactId>hibernate-entitymanager</artifactId>
+    </dependency>
+    <dependency>
+      <groupId>org.apache.geronimo.specs</groupId>
+      <artifactId>geronimo-jta_1.1_spec</artifactId>
+    </dependency>
+    <dependency>
       <groupId>org.apache.camel</groupId>
       <artifactId>camel-bam</artifactId>
       <version>${project.version}</version>

http://git-wip-us.apache.org/repos/asf/camel/blob/8033b30c/pom.xml
----------------------------------------------------------------------
diff --git a/pom.xml b/pom.xml
index 0abd51a..ec755a7 100755
--- a/pom.xml
+++ b/pom.xml
@@ -648,9 +648,9 @@
     <splunk-version>1.6.3.0_1</splunk-version>
     <spring-batch-version>3.0.8.RELEASE</spring-batch-version>
     <spring-batch-bundle-version>3.0.8.RELEASE_1</spring-batch-bundle-version>
-    <spring-boot-version>1.5.6.RELEASE</spring-boot-version>
-    <spring-boot1-version>1.5.6.RELEASE</spring-boot1-version>
-    <spring-boot2-version>2.0.0.M3</spring-boot2-version>
+    <spring-boot-version>1.5.7.RELEASE</spring-boot-version>
+    <spring-boot1-version>1.5.7.RELEASE</spring-boot1-version>
+    <spring-boot2-version>2.0.0.M4</spring-boot2-version>
     <!-- use same version of spring-cloud 1.2.x -->
     <spring-cloud-commons-version>1.2.3.RELEASE</spring-cloud-commons-version>
     <spring-cloud-netflix-version>1.3.4.RELEASE</spring-cloud-netflix-version>
@@ -677,7 +677,7 @@
     <spring42-version>4.2.9.RELEASE</spring42-version>
     <spring43-version>4.3.10.RELEASE</spring43-version>
     <spring4-version>4.3.10.RELEASE</spring4-version>
-    <spring5-version>5.0.0.RC3</spring5-version>
+    <spring5-version>5.0.0.RC4</spring5-version>
     <spring-osgi-version>1.2.1</spring-osgi-version>
     <spring-security-version>4.2.3.RELEASE</spring-security-version>
     <spring-security-bundle-version>4.2.3.RELEASE_1</spring-security-bundle-version>

http://git-wip-us.apache.org/repos/asf/camel/blob/8033b30c/tests/camel-itest-spring-boot/pom.xml
----------------------------------------------------------------------
diff --git a/tests/camel-itest-spring-boot/pom.xml b/tests/camel-itest-spring-boot/pom.xml
index b525928..9caa6dc 100644
--- a/tests/camel-itest-spring-boot/pom.xml
+++ b/tests/camel-itest-spring-boot/pom.xml
@@ -193,6 +193,10 @@
               <name>itest.springboot.mavenOfflineResolution</name>
               <value>false</value>
             </property>
+            <property>
+              <name>itest.springboot.springBootVersion</name>
+              <value>${spring-boot-version}</value>
+            </property>
 
           </systemProperties>
         </configuration>
@@ -218,49 +222,6 @@
     <profile>
       <id>spring-boot2</id>
 
-      <build>
-        <plugins>
-          <plugin>
-            <artifactId>maven-surefire-plugin</artifactId>
-            <configuration>
-              <childDelegation>false</childDelegation>
-              <forkedProcessTimeoutInSeconds>15000</forkedProcessTimeoutInSeconds>
-              <rerunFailingTestsCount>1</rerunFailingTestsCount>
-              <includes>
-                <include>**/*Test.java</include>
-              </includes>
-              <systemProperties>
-                <!-- Test configuration -->
-                <!--
-                It is better disabling unit testing in surefire, as some of them fail for various reasons
-                (unrelated to spring-boot) when running in the arquillian jar.
-
-                Tests are enabled when running from IDE. See org.apache.camel.itest.springboot.ITestConfigBuilder
-                for property names and defaults values.
-                -->
-                <property>
-                  <name>itest.springboot.unitTestEnabled</name>
-                  <value>false</value>
-                </property>
-                <property>
-                  <name>itest.springboot.includeTestDependencies</name>
-                  <value>true</value>
-                </property>
-                <property>
-                  <name>itest.springboot.mavenOfflineResolution</name>
-                  <value>false</value>
-                </property>
-                <!-- Adding spring-boot version -->
-                <property>
-                  <name>itest.springboot.springBootMajorVersion</name>
-                  <value>2</value>
-                </property>
-              </systemProperties>
-            </configuration>
-          </plugin>
-        </plugins>
-      </build>
-
       <dependencies>
         <dependency>
           <groupId>org.apache.camel</groupId>

http://git-wip-us.apache.org/repos/asf/camel/blob/8033b30c/tests/camel-itest-spring-boot/src/main/java/org/apache/camel/itest/springboot/ITestConfig.java
----------------------------------------------------------------------
diff --git a/tests/camel-itest-spring-boot/src/main/java/org/apache/camel/itest/springboot/ITestConfig.java b/tests/camel-itest-spring-boot/src/main/java/org/apache/camel/itest/springboot/ITestConfig.java
index 9c194e8..611c9a0 100644
--- a/tests/camel-itest-spring-boot/src/main/java/org/apache/camel/itest/springboot/ITestConfig.java
+++ b/tests/camel-itest-spring-boot/src/main/java/org/apache/camel/itest/springboot/ITestConfig.java
@@ -71,7 +71,7 @@ public class ITestConfig implements Serializable {
 
     private Map<String, String> testLibraryVersions;
 
-    private Integer springBootMajorVersion;
+    private String springBootVersion;
 
     public ITestConfig() {
     }
@@ -252,12 +252,16 @@ public class ITestConfig implements Serializable {
         this.testLibraryVersions = testLibraryVersions;
     }
 
+    public String getSpringBootVersion() {
+        return springBootVersion;
+    }
+
     public Integer getSpringBootMajorVersion() {
-        return springBootMajorVersion;
+        return Integer.parseInt(springBootVersion.substring(0, 1));
     }
 
-    public void setSpringBootMajorVersion(Integer springBootMajorVersion) {
-        this.springBootMajorVersion = springBootMajorVersion;
+    public void setSpringBootVersion(String springBootVersion) {
+        this.springBootVersion = springBootVersion;
     }
 
     @Override
@@ -285,7 +289,7 @@ public class ITestConfig implements Serializable {
                 ", useCustomLog=" + useCustomLog +
                 ", ignoreLibraryMismatch=" + ignoreLibraryMismatch +
                 ", testLibraryVersions=" + testLibraryVersions +
-                ", springBootMajorVersion=" + springBootMajorVersion +
+                ", springBootVersion=" + springBootVersion +
                 '}';
     }
 }

http://git-wip-us.apache.org/repos/asf/camel/blob/8033b30c/tests/camel-itest-spring-boot/src/main/java/org/apache/camel/itest/springboot/ITestConfigBuilder.java
----------------------------------------------------------------------
diff --git a/tests/camel-itest-spring-boot/src/main/java/org/apache/camel/itest/springboot/ITestConfigBuilder.java b/tests/camel-itest-spring-boot/src/main/java/org/apache/camel/itest/springboot/ITestConfigBuilder.java
index 614eac7..1b529d8 100644
--- a/tests/camel-itest-spring-boot/src/main/java/org/apache/camel/itest/springboot/ITestConfigBuilder.java
+++ b/tests/camel-itest-spring-boot/src/main/java/org/apache/camel/itest/springboot/ITestConfigBuilder.java
@@ -165,8 +165,8 @@ public class ITestConfigBuilder {
         return this;
     }
 
-    public ITestConfigBuilder springBootMajorVersion(Integer springBootMajorVersion) {
-        config.setSpringBootMajorVersion(springBootMajorVersion);
+    public ITestConfigBuilder springBootVersion(String springBootVersion) {
+        config.setSpringBootVersion(springBootVersion);
         return this;
     }
 
@@ -258,8 +258,8 @@ public class ITestConfigBuilder {
             config.setTestLibraryVersions(new HashMap<>());
         }
 
-        if (config.getSpringBootMajorVersion() == null) {
-            config.setSpringBootMajorVersion(integerPropertyOr("springBootMajorVersion", 1));
+        if (config.getSpringBootVersion() == null) {
+            config.setSpringBootVersion(propertyOr("springBootVersion", null));
         }
 
         return config;

http://git-wip-us.apache.org/repos/asf/camel/blob/8033b30c/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/CamelCassandraqlTest.java
----------------------------------------------------------------------
diff --git a/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/CamelCassandraqlTest.java b/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/CamelCassandraqlTest.java
index 17c45c7..ae838cb 100644
--- a/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/CamelCassandraqlTest.java
+++ b/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/CamelCassandraqlTest.java
@@ -36,13 +36,7 @@ public class CamelCassandraqlTest extends AbstractSpringBootTestSupport {
     public static ITestConfig createTestConfig() {
         return new ITestConfigBuilder()
                 .module(inferModuleName(CamelCassandraqlTest.class))
-                .dependency("io.netty:netty-all:" + DependencyResolver.resolveParentProperty("${cassandra-netty-version-testing}"))
-                //.dependency(DependencyResolver.withVersion("io.netty:netty-all"))
-//                .dependency(DependencyResolver.withVersion("io.dropwizard.metrics:metrics-core"))
-//                .exclusion("com.codahale.metrics:*")
                 .unitTestExclusionPattern(".*(\\.integration\\..*|IntegrationTest$|CassandraComponentProducerTest$|CassandraComponentBeanRefTest$|CassandraComponentConsumerTest$)")
-                //.unitTestInclusionPattern(".*NamedCassandraAggregationRepositoryTest$")
-                // excluded tests have been checked manually (they need to run on their own JVM)
                 .build();
     }
 

http://git-wip-us.apache.org/repos/asf/camel/blob/8033b30c/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/util/ArquillianPackager.java
----------------------------------------------------------------------
diff --git a/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/util/ArquillianPackager.java b/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/util/ArquillianPackager.java
index 56b89e6..7cdc03a 100644
--- a/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/util/ArquillianPackager.java
+++ b/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/util/ArquillianPackager.java
@@ -300,8 +300,11 @@ public final class ArquillianPackager {
         ignore.add("com.github.jnr");
         ignore.add("com.sun.xml.bind:jaxb-xjc");
         ignore.add("commons-beanutils:commons-beanutils");
+        ignore.add("io.dropwizard.metrics:metrics-json"); // PR to spring-boot
+        ignore.add("io.dropwizard.metrics:metrics-jvm"); // PR to spring-boot
         ignore.add("io.fabric8:kubernetes-");
         ignore.add("io.netty:netty:jar"); // an old version
+        ignore.add("io.netty:netty-tcnative-boringssl-static");
         ignore.add("io.swagger:swagger-parser");
         ignore.add("org.apache.commons");
         ignore.add("org.apache.curator");
@@ -309,19 +312,27 @@ public final class ArquillianPackager {
         ignore.add("org.apache.geronimo.specs");
         ignore.add("org.apache.maven");
         ignore.add("org.apache.parquet");
+        ignore.add("org.apache.solr:solr-solrj"); // PR to spring-boot
         ignore.add("org.apache.velocity");
         ignore.add("org.apache.qpid:qpid-jms-client");
         ignore.add("org.opensaml");
         ignore.add("org.ow2.asm"); // No problem
         ignore.add("org.codehaus.plexus");
+        ignore.add("org.eclipse.jetty.websocket:websocket-api"); // PR to spring-boot
+        ignore.add("org.infinispan");
         ignore.add("org.jboss.arquillian.container");
+        ignore.add("org.jboss.logging");
+        ignore.add("org.jboss.marshalling");
         ignore.add("org.jboss:");
         ignore.add("org.hibernate:hibernate-validator"); // does not match with hibernate-core
         ignore.add("org.mortbay.jetty:servlet-api-2.5");
         ignore.add("org.scala-lang:scala-compiler");
+        ignore.add("org.slf4j:slf4j-ext"); // PR to spring-boot
         ignore.add("org.easytesting");
+        ignore.add("net.java.dev.jna:jna-platform"); // PR to spring-boot
         ignore.add("net.openhft");
         ignore.add("net.sourceforge.htmlunit:htmlunit-core-js"); // v 2.21 does not exist
+        ignore.add("org.springframework.cloud"); // too many different versions
         ignore.add("org.springframework.data");
         ignore.add("org.springframework.security:spring-security-jwt");
         ignore.add("org.springframework.security:spring-security-rsa");
@@ -329,9 +340,8 @@ public final class ArquillianPackager {
         ignore.add("org.webjars"); // No problem
         ignore.add("stax:stax-api");
         ignore.add("xml-apis:xml-apis-ext");
-        ignore.add("org.infinispan");
-        ignore.add("org.jboss.logging");
-        ignore.add("org.jboss.marshalling");
+
+
 
         Map<String, Map<String, String>> status = new TreeMap<>();
         Set<String> mismatches = new TreeSet<>();
@@ -487,6 +497,8 @@ public final class ArquillianPackager {
             pom = pom.replace(property, resolvedProperties.get(property));
         }
 
+
+
         pom = pom.replace("#{module}", config.getModuleName());
 
         File pomFile = new File(config.getModuleBasePath() + "/target/itest-spring-boot-pom.xml");
@@ -577,22 +589,28 @@ public final class ArquillianPackager {
         String groupId = textBetween(dependencyXml, "<groupId>", "</groupId>");
         String artifactId = textBetween(dependencyXml, "<artifactId>", "</artifactId>");
 
-        String bomVersion = config.getTestLibraryVersions().get(groupId + ":" + artifactId);
-        if (bomVersion == null) {
-            bomVersion = BOMResolver.getInstance().getBOMVersion(groupId, artifactId);
+        String version = config.getTestLibraryVersions().get(groupId + ":" + artifactId);
+        boolean stripVersion = false;
+        if (version == null) {
+            boolean testsLib = dependencyXml.contains("<classifier>tests");
+            stripVersion = !testsLib && BOMResolver.getInstance(config).getBOMVersion(groupId, artifactId) != null;
         }
 
-        if (bomVersion != null) {
+        if (version != null) {
             if (dependencyXml.contains("<version>")) {
                 int from = dependencyXml.indexOf("<version>") + 9;
                 int to = dependencyXml.indexOf("</version>");
 
-                dependencyXml = dependencyXml.substring(0, from) + bomVersion + dependencyXml.substring(to);
+                dependencyXml = dependencyXml.substring(0, from) + version + dependencyXml.substring(to);
             } else {
                 String kw = "</artifactId>";
                 int pos = dependencyXml.indexOf(kw) + kw.length();
-                dependencyXml = dependencyXml.substring(0, pos) + "<version>" + bomVersion + "</version>" + dependencyXml.substring(pos);
+                dependencyXml = dependencyXml.substring(0, pos) + "<version>" + version + "</version>" + dependencyXml.substring(pos);
             }
+        } else if (stripVersion && dependencyXml.contains("<version>")) {
+            int from = dependencyXml.indexOf("<version>");
+            int to = dependencyXml.indexOf("</version>") + 10;
+            dependencyXml = dependencyXml.substring(0, from) + dependencyXml.substring(to);
         }
 
         return dependencyXml;

http://git-wip-us.apache.org/repos/asf/camel/blob/8033b30c/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/util/BOMResolver.java
----------------------------------------------------------------------
diff --git a/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/util/BOMResolver.java b/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/util/BOMResolver.java
index 8ffaea5..be0531a 100644
--- a/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/util/BOMResolver.java
+++ b/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/util/BOMResolver.java
@@ -31,6 +31,7 @@ import java.util.List;
 import java.util.Map;
 import java.util.TreeMap;
 
+import org.apache.camel.itest.springboot.ITestConfig;
 import org.apache.commons.io.FileUtils;
 import org.apache.maven.repository.internal.MavenRepositorySystemUtils;
 import org.eclipse.aether.DefaultRepositorySystemSession;
@@ -43,6 +44,7 @@ import org.eclipse.aether.graph.Dependency;
 import org.eclipse.aether.impl.DefaultServiceLocator;
 import org.eclipse.aether.repository.LocalRepository;
 import org.eclipse.aether.repository.RemoteRepository;
+import org.eclipse.aether.resolution.ArtifactDescriptorException;
 import org.eclipse.aether.resolution.ArtifactDescriptorRequest;
 import org.eclipse.aether.resolution.ArtifactDescriptorResult;
 import org.eclipse.aether.spi.connector.RepositoryConnectorFactory;
@@ -58,13 +60,16 @@ public final class BOMResolver {
 
     private static final File CACHE_FILE = LocationUtils.camelRoot("tests/camel-itest-spring-boot/target/bom-versions-cache");
 
-    private static final BOMResolver INSTANCE = new BOMResolver();
+    private static BOMResolver INSTANCE;
+
+    private ITestConfig config;
 
     private Map<String, String> versions;
 
     @SuppressWarnings("unchecked")
-    private BOMResolver() {
+    private BOMResolver(ITestConfig config) {
         try {
+            this.config = config;
             cleanupLocalRepo();
 
             if (canUseCache()) {
@@ -107,19 +112,21 @@ public final class BOMResolver {
         String camelVersion = DependencyResolver.resolveCamelParentProperty("${project.version}");
 
         List<Artifact> neededArtifacts = new LinkedList<>();
-        neededArtifacts.add(new DefaultArtifact("org.apache.camel:camel:pom:"
-            + camelVersion).setFile(camelRoot("pom.xml")));
-        neededArtifacts.add(new DefaultArtifact("org.apache.camel:camel-parent:pom:"
-            + camelVersion).setFile(camelRoot("parent/pom.xml")));
+        Artifact camelRoot = new DefaultArtifact("org.apache.camel:camel:pom:"
+                + camelVersion).setFile(camelRoot("pom.xml"));
+        neededArtifacts.add(camelRoot);
+        Artifact camelParent = new DefaultArtifact("org.apache.camel:camel-parent:pom:"
+                + camelVersion).setFile(camelRoot("parent/pom.xml"));
+        neededArtifacts.add(camelParent);
         neededArtifacts.add(new DefaultArtifact("org.apache.camel:spring-boot:pom:"
             + camelVersion).setFile(camelRoot("platforms/spring-boot/pom.xml")));
         neededArtifacts.add(new DefaultArtifact("org.apache.camel:camel-spring-boot-dm:pom:"
             + camelVersion).setFile(camelRoot("platforms/spring-boot/spring-boot-dm/pom.xml")));
         neededArtifacts.add(new DefaultArtifact("org.apache.camel:camel-spring-boot-dependencies:pom:"
             + camelVersion).setFile(camelRoot("platforms/spring-boot/spring-boot-dm/camel-spring-boot-dependencies/pom.xml")));
-        Artifact camelSpringBootParent = new DefaultArtifact("org.apache.camel:camel-starter-parent:pom:"
+        Artifact camelStarterParent = new DefaultArtifact("org.apache.camel:camel-starter-parent:pom:"
             + camelVersion).setFile(camelRoot("platforms/spring-boot/spring-boot-dm/camel-starter-parent/pom.xml"));
-        neededArtifacts.add(camelSpringBootParent);
+        neededArtifacts.add(camelStarterParent);
 
         RemoteRepository localRepoDist = new RemoteRepository.Builder("org.apache.camel.itest.springboot", "default", new File(LOCAL_REPO).toURI().toString()).build();
 
@@ -131,22 +138,34 @@ public final class BOMResolver {
             system.deploy(session, deployRequest);
         }
 
-
         RemoteRepository mavenCentral = new RemoteRepository.Builder("central", "default", "http://repo1.maven.org/maven2/").build();
         RemoteRepository apacheSnapshots = new RemoteRepository.Builder("apache-snapshots", "default", "http://repository.apache.org/snapshots/").build();
-
-        ArtifactDescriptorRequest dReq = new ArtifactDescriptorRequest(camelSpringBootParent, Arrays.asList(localRepoDist, mavenCentral, apacheSnapshots), null);
-        ArtifactDescriptorResult dRes = system.readArtifactDescriptor(session, dReq);
+        RemoteRepository springMilestones = new RemoteRepository.Builder("spring-milestones", "default", "https://repo.spring.io/libs-milestone/").build();
 
         this.versions = new TreeMap<>();
-        for (Dependency dependency : dRes.getManagedDependencies()) {
+
+        ArtifactDescriptorRequest springBootParentReq = new ArtifactDescriptorRequest(camelStarterParent, Arrays.asList(localRepoDist, mavenCentral, apacheSnapshots, springMilestones), null);
+        ArtifactDescriptorResult springBootParentRes = system.readArtifactDescriptor(session, springBootParentReq);
+        for (Dependency dependency : springBootParentRes.getManagedDependencies()) {
+            Artifact a = dependency.getArtifact();
+            String key = a.getGroupId() + ":" + a.getArtifactId();
+            versions.put(key, dependency.getArtifact().getVersion());
+        }
+
+        Artifact springBootDependencies = new DefaultArtifact("org.springframework.boot:spring-boot-dependencies:pom:" + config.getSpringBootVersion());
+        ArtifactDescriptorRequest springBootDependenciesReq = new ArtifactDescriptorRequest(springBootDependencies, Arrays.asList(localRepoDist, mavenCentral, apacheSnapshots, springMilestones), null);
+        ArtifactDescriptorResult springBootDependenciesRes = system.readArtifactDescriptor(session, springBootDependenciesReq);
+        for (Dependency dependency : springBootDependenciesRes.getManagedDependencies()) {
             Artifact a = dependency.getArtifact();
             String key = a.getGroupId() + ":" + a.getArtifactId();
             versions.put(key, dependency.getArtifact().getVersion());
         }
     }
 
-    public static BOMResolver getInstance() {
+    public static BOMResolver getInstance(ITestConfig config) {
+        if (INSTANCE == null) {
+            INSTANCE = new BOMResolver(config);
+        }
         return INSTANCE;
     }
 

http://git-wip-us.apache.org/repos/asf/camel/blob/8033b30c/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/util/DependencyResolver.java
----------------------------------------------------------------------
diff --git a/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/util/DependencyResolver.java b/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/util/DependencyResolver.java
index 7b05ff0..5bd525e 100644
--- a/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/util/DependencyResolver.java
+++ b/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/util/DependencyResolver.java
@@ -85,6 +85,9 @@ public final class DependencyResolver {
         if (property != null && !isResolved(property)) {
             property = resolveCamelParentProperty(property);
         }
+        if (property != null && !isResolved(property)) {
+            property = resolveCamelProperty(property);
+        }
 
         return property;
     }
@@ -106,6 +109,10 @@ public final class DependencyResolver {
         return resolveProperty(camelRoot("parent/pom.xml"), property, 0);
     }
 
+    public static String resolveCamelProperty(String property) {
+        return resolveProperty(camelRoot("pom.xml"), property, 0);
+    }
+
 
     private static String resolveProperty(File pom, String property, int depth) {
         try {

http://git-wip-us.apache.org/repos/asf/camel/blob/8033b30c/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/util/JarExporter.java
----------------------------------------------------------------------
diff --git a/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/util/JarExporter.java b/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/util/JarExporter.java
index 4449592..10c7aaf 100644
--- a/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/util/JarExporter.java
+++ b/tests/camel-itest-spring-boot/src/test/java/org/apache/camel/itest/springboot/util/JarExporter.java
@@ -24,7 +24,7 @@ import org.jboss.shrinkwrap.impl.base.exporter.zip.ZipExporterImpl;
 import org.junit.Test;
 
 /**
- * Utililty to export a spring-boot jar and check the content.
+ * Utility to export a spring-boot jar and check the content.
  */
 public class JarExporter {
 
@@ -32,7 +32,7 @@ public class JarExporter {
     public void exportJar() throws Exception {
 
         Archive<?> archive = ArquillianPackager.springBootPackage(new ITestConfigBuilder()
-                .module("camel-sjms2")
+                .module("camel-websocket")
                 .build());
 
         new ZipExporterImpl(archive).exportTo(new File("target/export.zip"), true);