Quantcast

Camel uses 2 different versions of JAXB

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Camel uses 2 different versions of JAXB

yogu13
Hi,

I am using Karaf (4.0.8) along with Camel and CXF. On installing Camel (v2.16.5) and CXF (v3.1.9) via features There are 2 versions of JAXB which get installed as CXF uses 2.2.11 Jaxb release and Camel seems to be also depend on 2.2.6 for its execution.

I noticed that the camel-parent project has defined both the versions i.e. 2.2.6 for bundle and 2.2.11 as dependency

would it be possible to have camel rely on one single version of Jaxb ?

Regards,
-Yogesh
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Camel uses 2 different versions of JAXB

yogu13
I saw that with the latest version of camel relies on a single version of Jaxb

Thank you!

Regards,
-Yogesh
Loading...