[GitHub] [camel-k] squakez opened a new issue #1652: Add a warning when operating from a CLI with a different installed Operator version

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[GitHub] [camel-k] squakez opened a new issue #1652: Add a warning when operating from a CLI with a different installed Operator version

GitBox

squakez opened a new issue #1652:
URL: https://github.com/apache/camel-k/issues/1652


   As experienced in #1648 there may be certain incompatibilities when a `kamel` CLI with a version is operating against an operator with another version. It would be nice to add a simple log warning the user about this incompatibility, either on CLI or on operator log.


----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

For queries about this service, please contact Infrastructure at:
[hidden email]


Reply | Threaded
Open this post in threaded view
|

[GitHub] [camel-k] nicolaferraro commented on issue #1652: Add a warning when operating from a CLI with a different installed Operator version

GitBox

nicolaferraro commented on issue #1652:
URL: https://github.com/apache/camel-k/issues/1652#issuecomment-668596274


   We should also add some options to `kamel version` (e.g. `kamel version --operator`) to return also the operator version when asked.
   
   Note that the operator may be installed also globally, in which case we can try some common namespaces to find it or we may not be able to determine its version.


----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

For queries about this service, please contact Infrastructure at:
[hidden email]


Reply | Threaded
Open this post in threaded view
|

[GitHub] [camel-k] squakez commented on issue #1652: Add a warning when operating from a CLI with a different installed Operator version

GitBox
In reply to this post by GitBox

squakez commented on issue #1652:
URL: https://github.com/apache/camel-k/issues/1652#issuecomment-759312202


   I can work on this


----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

For queries about this service, please contact Infrastructure at:
[hidden email]