Regarding Error with upgraded camel - 3.4

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Regarding Error with upgraded camel - 3.4

Manjunath
Hi,

  We have upgraded camel from 2.22.0 to 3.4.0
  Spring config looks like this :

  <bean id="camelContext" class="org.apache.camel.impl.DefaultCamelContext">

   <constructor-arg ref="camelRegistry" />
</bean>

<bean id="camelRegistry"
class="org.apache.camel.spring.spi.ApplicationContextRegistry">
   <constructor-arg value="#{appCtxInjector.applicationContext}" />
</bean>

    After this in run time its showing :
     Bean instantiation via constructor failed; nested exception is
org.springframework.beans.BeanInstantiationException: Failed to instantiate
[org.apache.camel.impl.DefaultCamelContext]: Constructor threw exception;
nested exception is java.lang.NoClassDefFoundError:
org/apache/activemq/command/ActiveMQDestination.
     ActiveMQDestination  : This class exist in jar apachemq-client , which
I have added as gradle dependency already. Still facing same issue. Please
help