[camel] branch camel-3.4.x updated (5e635a8 -> 3928cc6)

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[camel] branch camel-3.4.x updated (5e635a8 -> 3928cc6)

davsclaus-2
This is an automated email from the ASF dual-hosted git repository.

davsclaus pushed a change to branch camel-3.4.x
in repository https://gitbox.apache.org/repos/asf/camel.git.


    from 5e635a8  CAMEL-15403: Fixed CS
     new 920676e  CAMEL-15415: Upgrade dependencies for spring boot 2.3.3 upgrade
     new 9f84460  CAMEL-15403: Added to junit 4 for backport
     new 3928cc6  CAMEL-15415: Upgrade dependencies for spring boot 2.3.3 upgrade. Regen

The 3 revisions listed above as "new" are entirely new to this
repository and will be described in separate emails.  The revisions
listed as "add" were already present in the repository and have only
been added to this reference.


Summary of changes:
 camel-dependencies/pom.xml                         |  8 ++++----
 .../org/apache/camel/test/junit4/TestSupport.java  | 24 ++++++++++++++++++----
 .../modules/ROOT/pages/rest-component.adoc         |  2 +-
 .../modules/ROOT/pages/salesforce-component.adoc   |  2 +-
 parent/pom.xml                                     |  8 ++++----
 5 files changed, 30 insertions(+), 14 deletions(-)

Reply | Threaded
Open this post in threaded view
|

[camel] 01/03: CAMEL-15415: Upgrade dependencies for spring boot 2.3.3 upgrade

davsclaus-2
This is an automated email from the ASF dual-hosted git repository.

davsclaus pushed a commit to branch camel-3.4.x
in repository https://gitbox.apache.org/repos/asf/camel.git

commit 920676eefc7abdebcb0ddbd01f41d8c383aeefe6
Author: Claus Ibsen <[hidden email]>
AuthorDate: Fri Aug 14 08:36:04 2020 +0200

    CAMEL-15415: Upgrade dependencies for spring boot 2.3.3 upgrade
---
 parent/pom.xml | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/parent/pom.xml b/parent/pom.xml
index cee1a52..12c1bea 100644
--- a/parent/pom.xml
+++ b/parent/pom.xml
@@ -313,7 +313,7 @@
         <jcr-version>2.0</jcr-version>
         <jedis-client-version>3.1.0</jedis-client-version>
         <jersey-version>2.28</jersey-version>
-        <jetty9-version>9.4.29.v20200521</jetty9-version>
+        <jetty9-version>9.4.31.v20200723</jetty9-version>
         <jetty-version>${jetty9-version}</jetty-version>
         <jetty-plugin-version>${jetty-version}</jetty-plugin-version>
         <jetty-runner-groupId>org.eclipse.jetty</jetty-runner-groupId>
@@ -402,8 +402,8 @@
         <maven-shade-plugin-version>3.2.1</maven-shade-plugin-version>
         <maven-surefire-report-plugin-version>3.0.0-M4</maven-surefire-report-plugin-version>
         <maven-war-plugin-version>3.2.3</maven-war-plugin-version>
-        <metrics-version>4.1.5</metrics-version>
-        <micrometer-version>1.5.1</micrometer-version>
+        <metrics-version>4.1.11</metrics-version>
+        <micrometer-version>1.5.4</micrometer-version>
         <microprofile-config-version>1.4</microprofile-config-version>
         <microprofile-metrics-version>2.3</microprofile-metrics-version>
         <microprofile-health-version>2.2</microprofile-health-version>
@@ -517,7 +517,7 @@
         <spring-version-range>[5,6)</spring-version-range>
         <spring-version>${spring5-version}</spring-version>
         <spring5-version>5.2.8.RELEASE</spring5-version>
-        <spring-security-version>5.3.3.RELEASE</spring-security-version>
+        <spring-security-version>5.3.4.RELEASE</spring-security-version>
         <spring-ws-version>3.0.9.RELEASE</spring-ws-version>
         <sql-maven-plugin-version>1.5</sql-maven-plugin-version>
         <squareup-okhttp-version>3.14.7</squareup-okhttp-version>

Reply | Threaded
Open this post in threaded view
|

[camel] 02/03: CAMEL-15403: Added to junit 4 for backport

davsclaus-2
In reply to this post by davsclaus-2
This is an automated email from the ASF dual-hosted git repository.

davsclaus pushed a commit to branch camel-3.4.x
in repository https://gitbox.apache.org/repos/asf/camel.git

commit 9f844604cb1f50037dbb5510b5eb5de3b663479e
Author: Claus Ibsen <[hidden email]>
AuthorDate: Fri Aug 14 10:30:32 2020 +0200

    CAMEL-15403: Added to junit 4 for backport
---
 .../org/apache/camel/test/junit4/TestSupport.java  | 24 ++++++++++++++++++----
 1 file changed, 20 insertions(+), 4 deletions(-)

diff --git a/components/camel-test/src/main/java/org/apache/camel/test/junit4/TestSupport.java b/components/camel-test/src/main/java/org/apache/camel/test/junit4/TestSupport.java
index 19de853..61aa141 100644
--- a/components/camel-test/src/main/java/org/apache/camel/test/junit4/TestSupport.java
+++ b/components/camel-test/src/main/java/org/apache/camel/test/junit4/TestSupport.java
@@ -490,7 +490,6 @@ public abstract class TestSupport extends Assert {
     @Deprecated
     public static boolean isJava16() {
         return getJavaMajorVersion() == 6;
-
     }
     
     /**
@@ -502,7 +501,6 @@ public abstract class TestSupport extends Assert {
     @Deprecated
     public static boolean isJava17() {
         return getJavaMajorVersion() == 7;
-
     }
 
     /**
@@ -512,8 +510,27 @@ public abstract class TestSupport extends Assert {
      */
     public static boolean isJava18() {
         return getJavaMajorVersion() == 8;
+    }
 
+    /**
+     * Tells whether the current Java version is 1.8 and build_no 261 and later.
+     *
+     * @return <tt>true</tt> if its Java 1.8.0_261 and later, <tt>false</tt> if its not (for
+     *         example Java 1.8.0_251)
+     */
+    // CHECKSTYLE:OFF
+    public static boolean isJava18_261_later() {
+        boolean ret;
+        String version = System.getProperty("java.version");
+        try {
+            ret = version != null && version.startsWith("1.8.0_")
+                    && Integer.parseInt(version.substring(6)) >= 261;
+        } catch (NumberFormatException ex) {
+            ret = false;
+        }
+        return ret;
     }
+    // CHECKSTYLE:ON
 
     /**
      * Is this Java 1.9
@@ -522,14 +539,13 @@ public abstract class TestSupport extends Assert {
      */
     public static boolean isJava19() {
         return getJavaMajorVersion() == 9;
-
     }
 
     /**
      * Returns the current major Java version e.g 8.
      * <p/>
      * Uses <tt>java.specification.version</tt> from the system properties to determine the major version.
-
+     *
      * @return the current major Java version.
      */
     public static int getJavaMajorVersion() {

Reply | Threaded
Open this post in threaded view
|

[camel] 03/03: CAMEL-15415: Upgrade dependencies for spring boot 2.3.3 upgrade. Regen

davsclaus-2
In reply to this post by davsclaus-2
This is an automated email from the ASF dual-hosted git repository.

davsclaus pushed a commit to branch camel-3.4.x
in repository https://gitbox.apache.org/repos/asf/camel.git

commit 3928cc63b3defcba954638a69bcd77f1398db32b
Author: Claus Ibsen <[hidden email]>
AuthorDate: Fri Aug 14 10:47:00 2020 +0200

    CAMEL-15415: Upgrade dependencies for spring boot 2.3.3 upgrade. Regen
---
 camel-dependencies/pom.xml                                   | 8 ++++----
 docs/components/modules/ROOT/pages/rest-component.adoc       | 2 +-
 docs/components/modules/ROOT/pages/salesforce-component.adoc | 2 +-
 3 files changed, 6 insertions(+), 6 deletions(-)

diff --git a/camel-dependencies/pom.xml b/camel-dependencies/pom.xml
index 53af12b..b49b8d7 100644
--- a/camel-dependencies/pom.xml
+++ b/camel-dependencies/pom.xml
@@ -334,7 +334,7 @@
     <jetty-plugin-version>${jetty-version}</jetty-plugin-version>
     <jetty-runner-groupId>org.eclipse.jetty</jetty-runner-groupId>
     <jetty-version>${jetty9-version}</jetty-version>
-    <jetty9-version>9.4.29.v20200521</jetty9-version>
+    <jetty9-version>9.4.31.v20200723</jetty9-version>
     <jgit-version>5.7.0.202003110725-r</jgit-version>
     <jgroups-raft-leveldbjni-version>1.8</jgroups-raft-leveldbjni-version>
     <jgroups-raft-mapdb-version>1.0.8</jgroups-raft-mapdb-version>
@@ -417,8 +417,8 @@
     <maven-shade-plugin-version>3.2.1</maven-shade-plugin-version>
     <maven-surefire-report-plugin-version>3.0.0-M4</maven-surefire-report-plugin-version>
     <maven-war-plugin-version>3.2.3</maven-war-plugin-version>
-    <metrics-version>4.1.5</metrics-version>
-    <micrometer-version>1.5.1</micrometer-version>
+    <metrics-version>4.1.11</metrics-version>
+    <micrometer-version>1.5.4</micrometer-version>
     <microprofile-config-version>1.4</microprofile-config-version>
     <microprofile-fault-tolerance-version>2.1</microprofile-fault-tolerance-version>
     <microprofile-health-version>2.2</microprofile-health-version>
@@ -527,7 +527,7 @@
     <spring-data-redis-version>2.3.0.RELEASE</spring-data-redis-version>
     <spring-integration-version>5.3.0.RELEASE</spring-integration-version>
     <spring-ldap-version>2.3.3.RELEASE</spring-ldap-version>
-    <spring-security-version>5.3.3.RELEASE</spring-security-version>
+    <spring-security-version>5.3.4.RELEASE</spring-security-version>
     <spring-version>${spring5-version}</spring-version>
     <spring-version-range>[5,6)</spring-version-range>
     <spring-ws-version>3.0.9.RELEASE</spring-ws-version>
diff --git a/docs/components/modules/ROOT/pages/rest-component.adoc b/docs/components/modules/ROOT/pages/rest-component.adoc
index 7e3612a..62d60b9 100644
--- a/docs/components/modules/ROOT/pages/rest-component.adoc
+++ b/docs/components/modules/ROOT/pages/rest-component.adoc
@@ -90,7 +90,7 @@ with the following path and query parameters:
 | *host* (producer) | Host and port of HTTP service to use (override host in openapi schema) |  | String
 | *lazyStartProducer* (producer) | Whether the producer should be started lazy (on the first message). By starting lazy you can use this to allow CamelContext and routes to startup in situations where a producer may otherwise fail during starting and cause the route to fail being started. By deferring this startup to be lazy then the startup failure can be handled during routing messages via Camel's routing error handlers. Beware that when the first message is processed then creating and [...]
 | *producerComponentName* (producer) | The Camel Rest component to use for (producer) the REST transport, such as http, undertow. If no component has been explicit configured, then Camel will lookup if there is a Camel component that integrates with the Rest DSL, or if a org.apache.camel.spi.RestProducerFactory is registered in the registry. If either one is found, then that is being used. |  | String
-| *queryParameters* (producer) | Query parameters for the HTTP service to call |  | String
+| *queryParameters* (producer) | Query parameters for the HTTP service to call. The query parameters can contain multiple parameters separated by ampersand such such as foo=123&bar=456. |  | String
 | *basicPropertyBinding* (advanced) | Whether the endpoint should use basic property binding (Camel 2.x) or the newer property binding with additional capabilities | false | boolean
 | *synchronous* (advanced) | Sets whether synchronous processing should be strictly used, or Camel is allowed to use asynchronous processing (if supported). | false | boolean
 |===
diff --git a/docs/components/modules/ROOT/pages/salesforce-component.adoc b/docs/components/modules/ROOT/pages/salesforce-component.adoc
index fbb0c9c..7c94784 100644
--- a/docs/components/modules/ROOT/pages/salesforce-component.adoc
+++ b/docs/components/modules/ROOT/pages/salesforce-component.adoc
@@ -691,7 +691,7 @@ The Salesforce component supports 72 options, which are listed below.
 | *notifyForOperationUndelete* (common) | Notify for un-delete operation, defaults to false (API version = 29.0) |  | Boolean
 | *notifyForOperationUpdate* (common) | Notify for update operation, defaults to false (API version = 29.0) |  | Boolean
 | *objectMapper* (common) | Custom Jackson ObjectMapper to use when serializing/deserializing Salesforce objects. |  | ObjectMapper
-| *packages* (common) | *Deprecated* In what packages are the generated DTO classes. Typically the classes would be generated using camel-salesforce-maven-plugin. Set it if using the generated DTOs to gain the benefit of using short SObject names in parameters/header values. Multiple packages can be separated by comma. |  | String
+| *packages* (common) | In what packages are the generated DTO classes. Typically the classes would be generated using camel-salesforce-maven-plugin. Set it if using the generated DTOs to gain the benefit of using short SObject names in parameters/header values. Multiple packages can be separated by comma. |  | String
 | *rawPayload* (common) | Use raw payload String for request and response (either JSON or XML depending on format), instead of DTOs, false by default | false | boolean
 | *reportId* (common) | Salesforce1 Analytics report Id |  | String
 | *reportMetadata* (common) | Salesforce1 Analytics report metadata for filtering |  | ReportMetadata