java11 support

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

java11 support

Swaminathan, Arun
Hi all,
We have a project involving migration to java11.
Couple of questions:  
- Does camel 2.22.1 support running under Java11?   If not, when is the support planned?

- is camel 2.22.1 compatible with Apache Karaf 4.2.1 which was recently released.
 
Thx,
arun
Reply | Threaded
Open this post in threaded view
|

R: java11 support

Andrea Cosentino-2
No Camel 2.22.1 is not supported to run on JDK 11. We are working on making stuff work on JDK 11. No defined date for the moment.
Yes, it should work fine on 4.2.1.
 
  Il mer, 12 set, 2018 alle 19:15, Swaminathan, Arun<[hidden email]> ha scritto:   Hi all,
We have a project involving migration to java11.
Couple of questions: 
- Does camel 2.22.1 support running under Java11?  If not, when is the support planned?

- is camel 2.22.1 compatible with Apache Karaf 4.2.1 which was recently released.
 
Thx,
arun