[jira] Created: (CAMEL-388) Requestor doesn't honor JmsConfiguration.useVersion102

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

[jira] Created: (CAMEL-388) Requestor doesn't honor JmsConfiguration.useVersion102

JIRA jira@apache.org
Requestor doesn't honor JmsConfiguration.useVersion102
------------------------------------------------------

                 Key: CAMEL-388
                 URL: https://issues.apache.org/activemq/browse/CAMEL-388
             Project: Apache Camel
          Issue Type: Bug
          Components: camel-jms
    Affects Versions: 1.3.0
            Reporter: Mikhail Krivoshein


Requestor doesn't honor JmsConfiguration.useVersion102

Within createListenerContainer() it creates instance of SimpleMessageListenerContainer, however for 1.0.2 it have to create instance of SimpleMessageListenerContainer102 instead.

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

Reply | Threaded
Open this post in threaded view
|

[jira] Updated: (CAMEL-388) Requestor doesn't honor JmsConfiguration.useVersion102

JIRA jira@apache.org

     [ https://issues.apache.org/activemq/browse/CAMEL-388?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Gert Vanthienen updated CAMEL-388:
----------------------------------

    Attachment: CAMEL-388.diff

Like this?

> Requestor doesn't honor JmsConfiguration.useVersion102
> ------------------------------------------------------
>
>                 Key: CAMEL-388
>                 URL: https://issues.apache.org/activemq/browse/CAMEL-388
>             Project: Apache Camel
>          Issue Type: Bug
>          Components: camel-jms
>    Affects Versions: 1.3.0
>            Reporter: Mikhail Krivoshein
>         Attachments: CAMEL-388.diff
>
>
> Requestor doesn't honor JmsConfiguration.useVersion102
> Within createListenerContainer() it creates instance of SimpleMessageListenerContainer, however for 1.0.2 it have to create instance of SimpleMessageListenerContainer102 instead.

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

Reply | Threaded
Open this post in threaded view
|

[jira] Updated: (CAMEL-388) Requestor doesn't honor JmsConfiguration.useVersion102

JIRA jira@apache.org
In reply to this post by JIRA jira@apache.org

     [ https://issues.apache.org/activemq/browse/CAMEL-388?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Gert Vanthienen updated CAMEL-388:
----------------------------------

    Patch Info: [Patch Available]

> Requestor doesn't honor JmsConfiguration.useVersion102
> ------------------------------------------------------
>
>                 Key: CAMEL-388
>                 URL: https://issues.apache.org/activemq/browse/CAMEL-388
>             Project: Apache Camel
>          Issue Type: Bug
>          Components: camel-jms
>    Affects Versions: 1.3.0
>            Reporter: Mikhail Krivoshein
>         Attachments: CAMEL-388.diff
>
>
> Requestor doesn't honor JmsConfiguration.useVersion102
> Within createListenerContainer() it creates instance of SimpleMessageListenerContainer, however for 1.0.2 it have to create instance of SimpleMessageListenerContainer102 instead.

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

Reply | Threaded
Open this post in threaded view
|

[jira] Commented: (CAMEL-388) Requestor doesn't honor JmsConfiguration.useVersion102

JIRA jira@apache.org
In reply to this post by JIRA jira@apache.org

    [ https://issues.apache.org/activemq/browse/CAMEL-388?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=41711#action_41711 ]

Mikhail Krivoshein commented on CAMEL-388:
------------------------------------------

Looks fine! Though I don't need is it possible for configuration to be null or not.
I'm still struggling with setting up Camel project within my Eclipse - the reason why I didn't submit a patch myself.
Thanks!

> Requestor doesn't honor JmsConfiguration.useVersion102
> ------------------------------------------------------
>
>                 Key: CAMEL-388
>                 URL: https://issues.apache.org/activemq/browse/CAMEL-388
>             Project: Apache Camel
>          Issue Type: Bug
>          Components: camel-jms
>    Affects Versions: 1.3.0
>            Reporter: Mikhail Krivoshein
>         Attachments: CAMEL-388.diff
>
>
> Requestor doesn't honor JmsConfiguration.useVersion102
> Within createListenerContainer() it creates instance of SimpleMessageListenerContainer, however for 1.0.2 it have to create instance of SimpleMessageListenerContainer102 instead.

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

Reply | Threaded
Open this post in threaded view
|

[jira] Assigned: (CAMEL-388) Requestor doesn't honor JmsConfiguration.useVersion102

JIRA jira@apache.org
In reply to this post by JIRA jira@apache.org

     [ https://issues.apache.org/activemq/browse/CAMEL-388?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Willem Jiang reassigned CAMEL-388:
----------------------------------

    Assignee: Willem Jiang

> Requestor doesn't honor JmsConfiguration.useVersion102
> ------------------------------------------------------
>
>                 Key: CAMEL-388
>                 URL: https://issues.apache.org/activemq/browse/CAMEL-388
>             Project: Apache Camel
>          Issue Type: Bug
>          Components: camel-jms
>    Affects Versions: 1.3.0
>            Reporter: Mikhail Krivoshein
>            Assignee: Willem Jiang
>         Attachments: CAMEL-388.diff
>
>
> Requestor doesn't honor JmsConfiguration.useVersion102
> Within createListenerContainer() it creates instance of SimpleMessageListenerContainer, however for 1.0.2 it have to create instance of SimpleMessageListenerContainer102 instead.

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

Reply | Threaded
Open this post in threaded view
|

[jira] Resolved: (CAMEL-388) Requestor doesn't honor JmsConfiguration.useVersion102

JIRA jira@apache.org
In reply to this post by JIRA jira@apache.org

     [ https://issues.apache.org/activemq/browse/CAMEL-388?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Willem Jiang resolved CAMEL-388.
--------------------------------

    Fix Version/s: 1.3.0
       Resolution: Fixed

Patch applied with thanks. Please verify it when the new snapshot comes out.

> Requestor doesn't honor JmsConfiguration.useVersion102
> ------------------------------------------------------
>
>                 Key: CAMEL-388
>                 URL: https://issues.apache.org/activemq/browse/CAMEL-388
>             Project: Apache Camel
>          Issue Type: Bug
>          Components: camel-jms
>    Affects Versions: 1.3.0
>            Reporter: Mikhail Krivoshein
>            Assignee: Willem Jiang
>             Fix For: 1.3.0
>
>         Attachments: CAMEL-388.diff
>
>
> Requestor doesn't honor JmsConfiguration.useVersion102
> Within createListenerContainer() it creates instance of SimpleMessageListenerContainer, however for 1.0.2 it have to create instance of SimpleMessageListenerContainer102 instead.

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.