o.a.c.i.DefaultCamelBeanPostProcessor : No CamelContext defined yet so cannot inject into bean:

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

o.a.c.i.DefaultCamelBeanPostProcessor : No CamelContext defined yet so cannot inject into bean:

nono
Hello All,

I am running Apache Camel as SpringBoot application

Everything is ok. but when i start it, I saw a warning  No CamelContext
defined yet

but actually in my Route i could get it , and it is also initialized, i
used log to check and trace it

Then Version
       <camel.version>2.22.0</camel.version>
        <springboot.version>2.0.4.RELEASE</springboot.version>
           JDK i used is 1.8, it is the only different with example of
camel springboot

* o.a.c.i.DefaultCamelBeanPostProcessor    : No CamelContext defined yet so
cannot inject into bean:
org.apache.camel.converter.jaxb.FallbackTypeConverter*

*Then I add **CamelContext camelContext as below shown, but it does not
help, still have same warning message*

*Any idea or suggestion? *

*@SpringBootApplication*
*public class SpringbootCameApplication {*


* @Autowired*
* CamelContext camelContext;*
Reply | Threaded
Open this post in threaded view
|

: No CamelContext defined yet so cannot inject into bean: or

nono
This post was updated on .
Hello All,

I am running Apache Camel as SpringBoot application

Everything is ok. but when i start it, I saw a warning

Then Version
       <camel.version>2.22.0</camel.version>
        <springboot.version>2.0.4.RELEASE</springboot.version>

* o.a.c.i.DefaultCamelBeanPostProcessor    : No CamelContext defined yet so
cannot inject into bean:
org.apache.camel.converter.jaxb.FallbackTypeConverter*

*Then I add **CamelContext camelContext as below shown, but it does not
help, still have same warning message*

*Any idea or suggestion? *

*@SpringBootApplication*
*public class SpringbootCameApplication {*


* @Autowired*
* CamelContext camelContext;*
Reply | Threaded
Open this post in threaded view
|

Re: : No CamelContext defined yet so cannot inject into bean: or

Claus Ibsen-2
Hi

What version of Camel do you use? And what version of Spring Boot?

And a good idea is to look at the existing camel spring-boot examples
and see if they do something other than you.
https://github.com/apache/camel/tree/master/examples#examples
On Mon, Oct 8, 2018 at 11:43 AM Wang Yan <[hidden email]> wrote:

>
> Hello All,
>
> I am running Apache Camel as SpringBoot application
>
> Everything is ok. but when i start it, I saw a warning
>
> * o.a.c.i.DefaultCamelBeanPostProcessor    : No CamelContext defined yet so
> cannot inject into bean:
> org.apache.camel.converter.jaxb.FallbackTypeConverter*
>
> *Then I add **CamelContext camelContext as below shown, but it does not
> help, still have same warning message*
>
> *Any idea or suggestion? *
>
> *@SpringBootApplication*
> *public class SpringbootCameApplication {*
>
>
> * @Autowired*
> * CamelContext camelContext;*



--
Claus Ibsen
-----------------
http://davsclaus.com @davsclaus
Camel in Action 2: https://www.manning.com/ibsen2
Reply | Threaded
Open this post in threaded view
|

Re: o.a.c.i.DefaultCamelBeanPostProcessor : No CamelContext defined yet so cannot inject into bean:

Zoran Regvart-2
In reply to this post by nono
Hi,
this was recently fixed with CAMEL-12087[1]

zoran

[1] https://issues.apache.org/jira/browse/CAMEL-12087

On Wed, Oct 10, 2018 at 9:50 AM, Wang Yan <[hidden email]> wrote:

> Hello All,
>
> I am running Apache Camel as SpringBoot application
>
> Everything is ok. but when i start it, I saw a warning  No CamelContext
> defined yet
>
> but actually in my Route i could get it , and it is also initialized, i
> used log to check and trace it
>
> Then Version
>        <camel.version>2.22.0</camel.version>
>         <springboot.version>2.0.4.RELEASE</springboot.version>
>            JDK i used is 1.8, it is the only different with example of
> camel springboot
>
> * o.a.c.i.DefaultCamelBeanPostProcessor    : No CamelContext defined yet so
> cannot inject into bean:
> org.apache.camel.converter.jaxb.FallbackTypeConverter*
>
> *Then I add **CamelContext camelContext as below shown, but it does not
> help, still have same warning message*
>
> *Any idea or suggestion? *
>
> *@SpringBootApplication*
> *public class SpringbootCameApplication {*
>
>
> * @Autowired*
> * CamelContext camelContext;*



--
Zoran Regvart
Reply | Threaded
Open this post in threaded view
|

Fwd: o.a.c.i.DefaultCamelBeanPostProcessor : No CamelContext defined yet so cannot inject into bean:

nono
when i tried use to fixed version for example 2.22.2 i got below problem
also same problem with other version 2.23.0 . which maven repo should i use
to get but fix version

2.22.2, org.apache.camel:camel-test-spring:jar:2.22.2: Could not find
artifact org.apache.camel:camel-spring-boot-starter:jar:2.22.2 in central (
https://repo.maven.apache.org/maven2) -> [Help 1]
[ERROR]

On Thu, Oct 11, 2018 at 1:40 PM Zoran Regvart-2 [via Camel] <
[hidden email]> wrote:

> Hi,
> this was recently fixed with CAMEL-12087[1]
>
> zoran
>
> [1] https://issues.apache.org/jira/browse/CAMEL-12087
>
> On Wed, Oct 10, 2018 at 9:50 AM, Wang Yan <[hidden email]
> <http:///user/SendEmail.jtp?type=node&node=5824590&i=0>> wrote:
>
> > Hello All,
> >
> > I am running Apache Camel as SpringBoot application
> >
> > Everything is ok. but when i start it, I saw a warning  No CamelContext
> > defined yet
> >
> > but actually in my Route i could get it , and it is also initialized, i
> > used log to check and trace it
> >
> > Then Version
> >        <camel.version>2.22.0</camel.version>
> >         <springboot.version>2.0.4.RELEASE</springboot.version>
> >            JDK i used is 1.8, it is the only different with example of
> > camel springboot
> >
> > * o.a.c.i.DefaultCamelBeanPostProcessor    : No CamelContext defined yet
> so
> > cannot inject into bean:
> > org.apache.camel.converter.jaxb.FallbackTypeConverter*
> >
> > *Then I add **CamelContext camelContext as below shown, but it does not
> > help, still have same warning message*
> >
> > *Any idea or suggestion? *
> >
> > *@SpringBootApplication*
> > *public class SpringbootCameApplication {*
> >
> >
> > * @Autowired*
> > * CamelContext camelContext;*
>
>
>
> --
> Zoran Regvart
>
>
> ------------------------------
> If you reply to this email, your message will be added to the discussion
> below:
>
> http://camel.465427.n5.nabble.com/o-a-c-i-DefaultCamelBeanPostProcessor-No-CamelContext-defined-yet-so-cannot-inject-into-bean-tp5824553p5824590.html
> To unsubscribe from o.a.c.i.DefaultCamelBeanPostProcessor : No
> CamelContext defined yet so cannot inject into bean:, click here
> <
> .
> NAML
> <
http://camel.465427.n5.nabble.com/template/NamlServlet.jtp?macro=macro_viewer&id=instant_html%21nabble%3Aemail.naml&base=nabble.naml.namespaces.BasicNamespace-nabble.view.web.template.NabbleNamespace-nabble.view.web.template.NodeNamespace&breadcrumbs=notify_subscribers%21nabble%3Aemail.naml-instant_emails%21nabble%3Aemail.naml-send_instant_email%21nabble%3Aemail.naml>
>
Reply | Threaded
Open this post in threaded view
|

Re: o.a.c.i.DefaultCamelBeanPostProcessor : No CamelContext defined yet so cannot inject into bean:

Zoran Regvart-2
Hi,
none of those versions are released, you can grab a -SNAPSHOT version
from the Apache repository at:

https://repository.apache.org/content/groups/public/

zoran

On Thu, Oct 11, 2018 at 3:03 PM, Wang Yan <[hidden email]> wrote:
> when i tried use to fixed version for example 2.22.2 i got below problem
> also same problem with other version 2.23.0 . which maven repo should i use
> to get but fix version
>
> 2.22.2, org.apache.camel:camel-test-spring:jar:2.22.2: Could not find
> artifact org.apache.camel:camel-spring-boot-starter:jar:2.22.2 in central (
> https://repo.maven.apache.org/maven2) -> [Help 1]
> [ERROR]

--
Zoran Regvart
Reply | Threaded
Open this post in threaded view
|

Fwd: o.a.c.i.DefaultCamelBeanPostProcessor : No CamelContext defined yet so cannot inject into bean:

nono
Could you please suggest which release could fix this problem? i dont want
to use snapshot version.

thanks and rgds
nono

---------- Forwarded message ---------
From: Zoran Regvart-2 [via Camel] <[hidden email]>
Date: Thu, Oct 11, 2018 at 4:12 PM
Subject: Re: o.a.c.i.DefaultCamelBeanPostProcessor : No CamelContext
defined yet so cannot inject into bean:
To: nono <[hidden email]>


Hi,
none of those versions are released, you can grab a -SNAPSHOT version
from the Apache repository at:

https://repository.apache.org/content/groups/public/

zoran

On Thu, Oct 11, 2018 at 3:03 PM, Wang Yan <[hidden email]
<http:///user/SendEmail.jtp?type=node&node=5824592&i=0>> wrote:
> when i tried use to fixed version for example 2.22.2 i got below problem
> also same problem with other version 2.23.0 . which maven repo should i
use
> to get but fix version
>
> 2.22.2, org.apache.camel:camel-test-spring:jar:2.22.2: Could not find
> artifact org.apache.camel:camel-spring-boot-starter:jar:2.22.2 in central
(
> https://repo.maven.apache.org/maven2) -> [Help 1]
> [ERROR]

--
Zoran Regvart


------------------------------
If you reply to this email, your message will be added to the discussion
below:
http://camel.465427.n5.nabble.com/o-a-c-i-DefaultCamelBeanPostProcessor-No-CamelContext-defined-yet-so-cannot-inject-into-bean-tp5824553p5824592.html
To unsubscribe from o.a.c.i.DefaultCamelBeanPostProcessor : No CamelContext
defined yet so cannot inject into bean:, click here
<
.
NAML
<
http://camel.465427.n5.nabble.com/template/NamlServlet.jtp?macro=macro_viewer&id=instant_html%21nabble%3Aemail.naml&base=nabble.naml.namespaces.BasicNamespace-nabble.view.web.template.NabbleNamespace-nabble.view.web.template.NodeNamespace&breadcrumbs=notify_subscribers%21nabble%3Aemail.naml-instant_emails%21nabble%3Aemail.naml-send_instant_email%21nabble%3Aemail.naml>
Reply | Threaded
Open this post in threaded view
|

Fwd: o.a.c.i.DefaultCamelBeanPostProcessor : No CamelContext defined yet so cannot inject into bean:

nono
In reply to this post by Zoran Regvart-2
the wired thing is that i tried with 2.23.0 snapshot version and 2.22.2
snapshot version,same error still
but i tried some combition with 23.0 release and 2.22.2 release , then it
works

<camel.version>2.23.0</camel.version> <camel.bug.version>2.22.0</camel.bug.version>

<!-- Camel -->
<dependency>
    <groupId>org.apache.camel</groupId>
    <artifactId>camel-spring-boot-starter</artifactId>
    <version>${camel.bug.version}</version>
</dependency>
<dependency>
    <groupId>org.apache.camel</groupId>
    <artifactId>camel-stream-starter</artifactId>
    <version>${camel.bug.version}</version>
</dependency>
<dependency>
    <groupId>org.apache.camel</groupId>
    <artifactId>camel-cxf</artifactId>
    <version>${camel.bug.version}</version>
</dependency>
<dependency>
    <groupId>org.apache.camel</groupId>
    <artifactId>camel-cxf-transport</artifactId>
    <version>${camel.bug.version}</version>
</dependency>
<dependency>
    <groupId>org.apache.cxf</groupId>
    <artifactId>cxf-rt-transports-http-jetty</artifactId>
    <version>3.2.5</version>
</dependency>
<dependency>
    <groupId>javax.xml.ws</groupId>
    <artifactId>jaxws-api</artifactId>
    <version>2.1</version>
</dependency>
<dependency>
    <groupId>org.apache.camel</groupId>
    <artifactId>camel-saxon</artifactId>
    <version>${camel.bug.version}</version>
</dependency>
<dependency>
    <groupId>org.apache.camel</groupId>
    <artifactId>camel-jackson</artifactId>
    <version>${camel.bug.version}</version>
</dependency>
<dependency>
    <groupId>org.apache.camel</groupId>
    <artifactId>camel-jaxb</artifactId>
    <version>${camel.bug.version}</version>
</dependency>

---------- Forwarded message ---------
From: Zoran Regvart-2 [via Camel] <[hidden email]>
Date: Thu, Oct 11, 2018 at 1:40 PM
Subject: Re: o.a.c.i.DefaultCamelBeanPostProcessor : No CamelContext
defined yet so cannot inject into bean:
To: nono <[hidden email]>


Hi,
this was recently fixed with CAMEL-12087[1]

zoran

[1] https://issues.apache.org/jira/browse/CAMEL-12087

On Wed, Oct 10, 2018 at 9:50 AM, Wang Yan <[hidden email]
<http:///user/SendEmail.jtp?type=node&node=5824590&i=0>> wrote:

> Hello All,
>
> I am running Apache Camel as SpringBoot application
>
> Everything is ok. but when i start it, I saw a warning  No CamelContext
> defined yet
>
> but actually in my Route i could get it , and it is also initialized, i
> used log to check and trace it
>
> Then Version
>        <camel.version>2.22.0</camel.version>
>         <springboot.version>2.0.4.RELEASE</springboot.version>
>            JDK i used is 1.8, it is the only different with example of
> camel springboot
>
> * o.a.c.i.DefaultCamelBeanPostProcessor    : No CamelContext defined yet
so

> cannot inject into bean:
> org.apache.camel.converter.jaxb.FallbackTypeConverter*
>
> *Then I add **CamelContext camelContext as below shown, but it does not
> help, still have same warning message*
>
> *Any idea or suggestion? *
>
> *@SpringBootApplication*
> *public class SpringbootCameApplication {*
>
>
> * @Autowired*
> * CamelContext camelContext;*



--
Zoran Regvart


------------------------------
If you reply to this email, your message will be added to the discussion
below:
http://camel.465427.n5.nabble.com/o-a-c-i-DefaultCamelBeanPostProcessor-No-CamelContext-defined-yet-so-cannot-inject-into-bean-tp5824553p5824590.html
To unsubscribe from o.a.c.i.DefaultCamelBeanPostProcessor : No CamelContext
defined yet so cannot inject into bean:, click here
<
.
NAML
<
http://camel.465427.n5.nabble.com/template/NamlServlet.jtp?macro=macro_viewer&id=instant_html%21nabble%3Aemail.naml&base=nabble.naml.namespaces.BasicNamespace-nabble.view.web.template.NabbleNamespace-nabble.view.web.template.NodeNamespace&breadcrumbs=notify_subscribers%21nabble%3Aemail.naml-instant_emails%21nabble%3Aemail.naml-send_instant_email%21nabble%3Aemail.naml>
Reply | Threaded
Open this post in threaded view
|

Re: o.a.c.i.DefaultCamelBeanPostProcessor : No CamelContext defined yet so cannot inject into bean:

Zoran Regvart-2
In reply to this post by nono
Hello,
the versions are listed in the issue[1], until we release if you need
this fix the only way you can get it is if you use the snapshot
versions.

Mixing two different versions of Camel will probably lead to more issues.

zoran

On Fri, Oct 12, 2018 at 1:14 PM, Wang Yan <[hidden email]> wrote:
> Could you please suggest which release could fix this problem? i dont want
> to use snapshot version.

[1] https://issues.apache.org/jira/browse/CAMEL-12087
--
Zoran Regvart
Reply | Threaded
Open this post in threaded view
|

Re: o.a.c.i.DefaultCamelBeanPostProcessor : No CamelContext defined yet so cannot inject into bean:

lburgazzoli
Hello,

can you open a new issue with a reproducer ? There may be more
condition that lead to such warning.

---
Luca Burgazzoli

On Sun, Oct 14, 2018 at 5:11 PM Zoran Regvart <[hidden email]> wrote:

>
> Hello,
> the versions are listed in the issue[1], until we release if you need
> this fix the only way you can get it is if you use the snapshot
> versions.
>
> Mixing two different versions of Camel will probably lead to more issues.
>
> zoran
>
> On Fri, Oct 12, 2018 at 1:14 PM, Wang Yan <[hidden email]> wrote:
> > Could you please suggest which release could fix this problem? i dont want
> > to use snapshot version.
>
> [1] https://issues.apache.org/jira/browse/CAMEL-12087
> --
> Zoran Regvart
Reply | Threaded
Open this post in threaded view
|

Fwd: o.a.c.i.DefaultCamelBeanPostProcessor : No CamelContext defined yet so cannot inject into bean:

nono
sure the problem could be reproduce with project at this github
https://github.com/wangyan100/springboot-camel-esb

---------- Forwarded message ---------
From: lburgazzoli [via Camel] <[hidden email]>
Date: Mon, Oct 15, 2018 at 7:59 AM
Subject: Re: o.a.c.i.DefaultCamelBeanPostProcessor : No CamelContext
defined yet so cannot inject into bean:
To: nono <[hidden email]>


Hello,

can you open a new issue with a reproducer ? There may be more
condition that lead to such warning.

---
Luca Burgazzoli

On Sun, Oct 14, 2018 at 5:11 PM Zoran Regvart <[hidden email]
<http:///user/SendEmail.jtp?type=node&node=5824740&i=0>> wrote:

>
> Hello,
> the versions are listed in the issue[1], until we release if you need
> this fix the only way you can get it is if you use the snapshot
> versions.
>
> Mixing two different versions of Camel will probably lead to more issues.
>
> zoran
>
> On Fri, Oct 12, 2018 at 1:14 PM, Wang Yan <[hidden email]
<http:///user/SendEmail.jtp?type=node&node=5824740&i=1>> wrote:
> > Could you please suggest which release could fix this problem? i dont
want
> > to use snapshot version.
>
> [1] https://issues.apache.org/jira/browse/CAMEL-12087
> --
> Zoran Regvart


------------------------------
If you reply to this email, your message will be added to the discussion
below:
http://camel.465427.n5.nabble.com/o-a-c-i-DefaultCamelBeanPostProcessor-No-CamelContext-defined-yet-so-cannot-inject-into-bean-tp5824553p5824740.html
To unsubscribe from o.a.c.i.DefaultCamelBeanPostProcessor : No CamelContext
defined yet so cannot inject into bean:, click here
<
.
NAML
<
http://camel.465427.n5.nabble.com/template/NamlServlet.jtp?macro=macro_viewer&id=instant_html%21nabble%3Aemail.naml&base=nabble.naml.namespaces.BasicNamespace-nabble.view.web.template.NabbleNamespace-nabble.view.web.template.NodeNamespace&breadcrumbs=notify_subscribers%21nabble%3Aemail.naml-instant_emails%21nabble%3Aemail.naml-send_instant_email%21nabble%3Aemail.naml>