Broken feature dependencies in 3.2.0

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Broken feature dependencies in 3.2.0

kjchernov
Hi!

 

Tried to update to 3.2.0 on karaf-4.2.8, got following error:

        Caused by: java.io.IOException: Error resolving artifact org.apache.camel:camel-commands-core:jar:3.2.0: [Could not find artifact org.apache.camel:camel-commands-core:jar:3.2.0 in central (https://repo1.maven.org/maven2/)]

 

Looking at https://repo1.maven.org/maven2/org/apache/camel/karaf/apache-camel/3.2.0/apache-camel-3.2.0-features.xml there must be something wrong in the conditional in camel-core:

<conditional>

<condition>shell</condition>

<bundle>mvn:org.apache.camel/camel-commands-core/3.2.0</bundle>

<bundle>

mvn:org.apache.camel.karaf/camel-karaf-commands/3.2.0

</bundle>

</conditional>

 

Or maybe I’m doing something wrong?

 

Best regards,

Konstantin Chernov.

Reply | Threaded
Open this post in threaded view
|

Re: Broken feature dependencies in 3.2.0

jbonofre
Hi,

It moved to camel-karaf repo and the feature should be updated.

Can you please create a Jira ? I will fix that.

Sorry for the inconvenience.

Regards
JB

> Le 6 avr. 2020 à 14:42, Константин Чернов <[hidden email]> a écrit :
>
> Hi!
>
>
>
> Tried to update to 3.2.0 on karaf-4.2.8, got following error:
>
>         Caused by: java.io.IOException: Error resolving artifact org.apache.camel:camel-commands-core:jar:3.2.0: [Could not find artifact org.apache.camel:camel-commands-core:jar:3.2.0 in central (https://repo1.maven.org/maven2/)]
>
>
>
> Looking at https://repo1.maven.org/maven2/org/apache/camel/karaf/apache-camel/3.2.0/apache-camel-3.2.0-features.xml there must be something wrong in the conditional in camel-core:
>
> <conditional>
>
> <condition>shell</condition>
>
> <bundle>mvn:org.apache.camel/camel-commands-core/3.2.0</bundle>
>
> <bundle>
>
> mvn:org.apache.camel.karaf/camel-karaf-commands/3.2.0
>
> </bundle>
>
> </conditional>
>
>
>
> Or maybe I’m doing something wrong?
>
>
>
> Best regards,
>
> Konstantin Chernov.
>

Reply | Threaded
Open this post in threaded view
|

Re: Broken feature dependencies in 3.2.0

Andrea Cosentino-3
In reply to this post by kjchernov
No, it's a known bug.

We released it

You just need to update the feature

<bundle>mvn:org.apache.camel/camel-commands-core/3.2.0</bundle> to
<bundle>mvn:org.apache.camel.karaf/camel-commands-core/3.2.0</bundle>

It's already fixed for the next release.

Il giorno lun 6 apr 2020 alle ore 14:42 Константин Чернов <
[hidden email]> ha scritto:

> Hi!
>
>
>
> Tried to update to 3.2.0 on karaf-4.2.8, got following error:
>
>         Caused by: java.io.IOException: Error resolving artifact
> org.apache.camel:camel-commands-core:jar:3.2.0: [Could not find artifact
> org.apache.camel:camel-commands-core:jar:3.2.0 in central (
> https://repo1.maven.org/maven2/)]
>
>
>
> Looking at
> https://repo1.maven.org/maven2/org/apache/camel/karaf/apache-camel/3.2.0/apache-camel-3.2.0-features.xml
> there must be something wrong in the conditional in camel-core:
>
> <conditional>
>
> <condition>shell</condition>
>
> <bundle>mvn:org.apache.camel/camel-commands-core/3.2.0</bundle>
>
> <bundle>
>
> mvn:org.apache.camel.karaf/camel-karaf-commands/3.2.0
>
> </bundle>
>
> </conditional>
>
>
>
> Or maybe I’m doing something wrong?
>
>
>
> Best regards,
>
> Konstantin Chernov.
>
>
Reply | Threaded
Open this post in threaded view
|

Re: Broken feature dependencies in 3.2.0

kjchernov
Ah, okay.

I confirm it works with
    <bundleReplacements>
        <bundle mode="maven" originalUri="mvn:org.apache.camel/camel-commands-core/3.2.0" replacement="mvn:org.apache.camel.karaf/camel-commands-core/3.2.0"/>
    </bundleReplacements>
added to etc/org.apache.karaf.features.xml (just in case someone may find this workaround useful).

So no JIRA issue needed?

Best regards,
Konstantin Chernov.

06.04.2020, 19:46 пользователь "Andrea Cosentino" <[hidden email]> написал:

    No, it's a known bug.
   
    We released it
   
    You just need to update the feature
   
    <bundle>mvn:org.apache.camel/camel-commands-core/3.2.0</bundle> to
    <bundle>mvn:org.apache.camel.karaf/camel-commands-core/3.2.0</bundle>
   
    It's already fixed for the next release.
   
    Il giorno lun 6 apr 2020 alle ore 14:42 Константин Чернов <
    [hidden email]> ha scritto:
   
    > Hi!
    >
    >
    >
    > Tried to update to 3.2.0 on karaf-4.2.8, got following error:
    >
    >         Caused by: java.io.IOException: Error resolving artifact
    > org.apache.camel:camel-commands-core:jar:3.2.0: [Could not find artifact
    > org.apache.camel:camel-commands-core:jar:3.2.0 in central (
    > https://repo1.maven.org/maven2/)]
    >
    >
    >
    > Looking at
    > https://repo1.maven.org/maven2/org/apache/camel/karaf/apache-camel/3.2.0/apache-camel-3.2.0-features.xml
    > there must be something wrong in the conditional in camel-core:
    >
    > <conditional>
    >
    > <condition>shell</condition>
    >
    > <bundle>mvn:org.apache.camel/camel-commands-core/3.2.0</bundle>
    >
    > <bundle>
    >
    > mvn:org.apache.camel.karaf/camel-karaf-commands/3.2.0
    >
    > </bundle>
    >
    > </conditional>
    >
    >
    >
    > Or maybe I’m doing something wrong?
    >
    >
    >
    > Best regards,
    >
    > Konstantin Chernov.
    >
    >
   


Reply | Threaded
Open this post in threaded view
|

Re: Broken feature dependencies in 3.2.0

Andrea Cosentino-3
No, I fixed that days ago.

Il giorno lun 6 apr 2020 alle ore 14:49 Константин Чернов <
[hidden email]> ha scritto:

> Ah, okay.
>
> I confirm it works with
>     <bundleReplacements>
>         <bundle mode="maven"
> originalUri="mvn:org.apache.camel/camel-commands-core/3.2.0"
> replacement="mvn:org.apache.camel.karaf/camel-commands-core/3.2.0"/>
>     </bundleReplacements>
> added to etc/org.apache.karaf.features.xml (just in case someone may find
> this workaround useful).
>
> So no JIRA issue needed?
>
> Best regards,
> Konstantin Chernov.
>
> 06.04.2020, 19:46 пользователь "Andrea Cosentino" <[hidden email]>
> написал:
>
>     No, it's a known bug.
>
>     We released it
>
>     You just need to update the feature
>
>     <bundle>mvn:org.apache.camel/camel-commands-core/3.2.0</bundle> to
>     <bundle>mvn:org.apache.camel.karaf/camel-commands-core/3.2.0</bundle>
>
>     It's already fixed for the next release.
>
>     Il giorno lun 6 apr 2020 alle ore 14:42 Константин Чернов <
>     [hidden email]> ha scritto:
>
>     > Hi!
>     >
>     >
>     >
>     > Tried to update to 3.2.0 on karaf-4.2.8, got following error:
>     >
>     >         Caused by: java.io.IOException: Error resolving artifact
>     > org.apache.camel:camel-commands-core:jar:3.2.0: [Could not find
> artifact
>     > org.apache.camel:camel-commands-core:jar:3.2.0 in central (
>     > https://repo1.maven.org/maven2/)]
>     >
>     >
>     >
>     > Looking at
>     >
> https://repo1.maven.org/maven2/org/apache/camel/karaf/apache-camel/3.2.0/apache-camel-3.2.0-features.xml
>     > there must be something wrong in the conditional in camel-core:
>     >
>     > <conditional>
>     >
>     > <condition>shell</condition>
>     >
>     > <bundle>mvn:org.apache.camel/camel-commands-core/3.2.0</bundle>
>     >
>     > <bundle>
>     >
>     > mvn:org.apache.camel.karaf/camel-karaf-commands/3.2.0
>     >
>     > </bundle>
>     >
>     > </conditional>
>     >
>     >
>     >
>     > Or maybe I’m doing something wrong?
>     >
>     >
>     >
>     > Best regards,
>     >
>     > Konstantin Chernov.
>     >
>     >
>
>
>
>
Reply | Threaded
Open this post in threaded view
|

Re: Broken feature dependencies in 3.2.0

Andrea Cosentino-3
Thanks for spotting this by the way!

Il giorno lun 6 apr 2020 alle ore 14:50 Andrea Cosentino <[hidden email]>
ha scritto:

> No, I fixed that days ago.
>
> Il giorno lun 6 apr 2020 alle ore 14:49 Константин Чернов <
> [hidden email]> ha scritto:
>
>> Ah, okay.
>>
>> I confirm it works with
>>     <bundleReplacements>
>>         <bundle mode="maven"
>> originalUri="mvn:org.apache.camel/camel-commands-core/3.2.0"
>> replacement="mvn:org.apache.camel.karaf/camel-commands-core/3.2.0"/>
>>     </bundleReplacements>
>> added to etc/org.apache.karaf.features.xml (just in case someone may find
>> this workaround useful).
>>
>> So no JIRA issue needed?
>>
>> Best regards,
>> Konstantin Chernov.
>>
>> 06.04.2020, 19:46 пользователь "Andrea Cosentino" <[hidden email]>
>> написал:
>>
>>     No, it's a known bug.
>>
>>     We released it
>>
>>     You just need to update the feature
>>
>>     <bundle>mvn:org.apache.camel/camel-commands-core/3.2.0</bundle> to
>>     <bundle>mvn:org.apache.camel.karaf/camel-commands-core/3.2.0</bundle>
>>
>>     It's already fixed for the next release.
>>
>>     Il giorno lun 6 apr 2020 alle ore 14:42 Константин Чернов <
>>     [hidden email]> ha scritto:
>>
>>     > Hi!
>>     >
>>     >
>>     >
>>     > Tried to update to 3.2.0 on karaf-4.2.8, got following error:
>>     >
>>     >         Caused by: java.io.IOException: Error resolving artifact
>>     > org.apache.camel:camel-commands-core:jar:3.2.0: [Could not find
>> artifact
>>     > org.apache.camel:camel-commands-core:jar:3.2.0 in central (
>>     > https://repo1.maven.org/maven2/)]
>>     >
>>     >
>>     >
>>     > Looking at
>>     >
>> https://repo1.maven.org/maven2/org/apache/camel/karaf/apache-camel/3.2.0/apache-camel-3.2.0-features.xml
>>     > there must be something wrong in the conditional in camel-core:
>>     >
>>     > <conditional>
>>     >
>>     > <condition>shell</condition>
>>     >
>>     > <bundle>mvn:org.apache.camel/camel-commands-core/3.2.0</bundle>
>>     >
>>     > <bundle>
>>     >
>>     > mvn:org.apache.camel.karaf/camel-karaf-commands/3.2.0
>>     >
>>     > </bundle>
>>     >
>>     > </conditional>
>>     >
>>     >
>>     >
>>     > Or maybe I’m doing something wrong?
>>     >
>>     >
>>     >
>>     > Best regards,
>>     >
>>     > Konstantin Chernov.
>>     >
>>     >
>>
>>
>>
>>
Reply | Threaded
Open this post in threaded view
|

Re: Broken feature dependencies in 3.2.0

jbonofre
In reply to this post by Andrea Cosentino-3
Don’t we have to update the provided feature in camel-karat ?

It would be easier for users.

Regards
JB

> Le 6 avr. 2020 à 14:46, Andrea Cosentino <[hidden email]> a écrit :
>
> No, it's a known bug.
>
> We released it
>
> You just need to update the feature
>
> <bundle>mvn:org.apache.camel/camel-commands-core/3.2.0</bundle> to
> <bundle>mvn:org.apache.camel.karaf/camel-commands-core/3.2.0</bundle>
>
> It's already fixed for the next release.
>
> Il giorno lun 6 apr 2020 alle ore 14:42 Константин Чернов <
> [hidden email]> ha scritto:
>
>> Hi!
>>
>>
>>
>> Tried to update to 3.2.0 on karaf-4.2.8, got following error:
>>
>>        Caused by: java.io.IOException: Error resolving artifact
>> org.apache.camel:camel-commands-core:jar:3.2.0: [Could not find artifact
>> org.apache.camel:camel-commands-core:jar:3.2.0 in central (
>> https://repo1.maven.org/maven2/)]
>>
>>
>>
>> Looking at
>> https://repo1.maven.org/maven2/org/apache/camel/karaf/apache-camel/3.2.0/apache-camel-3.2.0-features.xml
>> there must be something wrong in the conditional in camel-core:
>>
>> <conditional>
>>
>> <condition>shell</condition>
>>
>> <bundle>mvn:org.apache.camel/camel-commands-core/3.2.0</bundle>
>>
>> <bundle>
>>
>> mvn:org.apache.camel.karaf/camel-karaf-commands/3.2.0
>>
>> </bundle>
>>
>> </conditional>
>>
>>
>>
>> Or maybe I’m doing something wrong?
>>
>>
>>
>> Best regards,
>>
>> Konstantin Chernov.
>>
>>

Reply | Threaded
Open this post in threaded view
|

Re: Broken feature dependencies in 3.2.0

jbonofre
In reply to this post by Andrea Cosentino-3
Ah yes, I just saw that. It’s already fixed but not released yet.

Regards
JB

> Le 6 avr. 2020 à 14:50, Andrea Cosentino <[hidden email]> a écrit :
>
> No, I fixed that days ago.
>
> Il giorno lun 6 apr 2020 alle ore 14:49 Константин Чернов <
> [hidden email]> ha scritto:
>
>> Ah, okay.
>>
>> I confirm it works with
>>    <bundleReplacements>
>>        <bundle mode="maven"
>> originalUri="mvn:org.apache.camel/camel-commands-core/3.2.0"
>> replacement="mvn:org.apache.camel.karaf/camel-commands-core/3.2.0"/>
>>    </bundleReplacements>
>> added to etc/org.apache.karaf.features.xml (just in case someone may find
>> this workaround useful).
>>
>> So no JIRA issue needed?
>>
>> Best regards,
>> Konstantin Chernov.
>>
>> 06.04.2020, 19:46 пользователь "Andrea Cosentino" <[hidden email]>
>> написал:
>>
>>    No, it's a known bug.
>>
>>    We released it
>>
>>    You just need to update the feature
>>
>>    <bundle>mvn:org.apache.camel/camel-commands-core/3.2.0</bundle> to
>>    <bundle>mvn:org.apache.camel.karaf/camel-commands-core/3.2.0</bundle>
>>
>>    It's already fixed for the next release.
>>
>>    Il giorno lun 6 apr 2020 alle ore 14:42 Константин Чернов <
>>    [hidden email]> ha scritto:
>>
>>> Hi!
>>>
>>>
>>>
>>> Tried to update to 3.2.0 on karaf-4.2.8, got following error:
>>>
>>>        Caused by: java.io.IOException: Error resolving artifact
>>> org.apache.camel:camel-commands-core:jar:3.2.0: [Could not find
>> artifact
>>> org.apache.camel:camel-commands-core:jar:3.2.0 in central (
>>> https://repo1.maven.org/maven2/)]
>>>
>>>
>>>
>>> Looking at
>>>
>> https://repo1.maven.org/maven2/org/apache/camel/karaf/apache-camel/3.2.0/apache-camel-3.2.0-features.xml
>>> there must be something wrong in the conditional in camel-core:
>>>
>>> <conditional>
>>>
>>> <condition>shell</condition>
>>>
>>> <bundle>mvn:org.apache.camel/camel-commands-core/3.2.0</bundle>
>>>
>>> <bundle>
>>>
>>> mvn:org.apache.camel.karaf/camel-karaf-commands/3.2.0
>>>
>>> </bundle>
>>>
>>> </conditional>
>>>
>>>
>>>
>>> Or maybe I’m doing something wrong?
>>>
>>>
>>>
>>> Best regards,
>>>
>>> Konstantin Chernov.
>>>
>>>
>>
>>
>>
>>