[Camel 2.0] thought for the day: rename multicast() to be wireTap()?

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

[Camel 2.0] thought for the day: rename multicast() to be wireTap()?

jstrachan
I've always disliked the 'multicast' in the DSL; its kinda ugly. I
wonder would using the word 'wireTap' be better? As its kinda a
wiretap - send the same message exchange to multiple places?

Thoughts?
--
James
-------
http://macstrac.blogspot.com/

Open Source Integration
http://open.iona.com
Reply | Threaded
Open this post in threaded view
|

Re: [Camel 2.0] thought for the day: rename multicast() to be wireTap()?

Oisin Hurley
> I've always disliked the 'multicast' in the DSL; its kinda ugly. I
> wonder would using the word 'wireTap' be better?

Looking at it from the Spring pov, this would mean

  <route>
    <from uri="seda:a"/>
       <wireTap>
          <to uri="seda:tap"/>
          <to uri="seda:b"/>
       </wireTap>
  </route>

which I think is a good change -- give us an id attribute
on the wireTap element and that would be cool ;)

Here's another suggestion - if you describe a little route
like:

  <route>
    <from uri="seda:a"/>
    <to uri="seda:tap"/>
    <to uri="seda:b"/>
  </route>

then that acts as a pipeline - which is the same as

  <route>
    <from uri="seda:a"/>
    <pipeline>
        <to uri="seda:tap"/>
        <to uri="seda:b"/>
    </pipeline>
  </route>

d'you think that we could *not* have the two of them,
for the sake of consistency?

 --oh
Reply | Threaded
Open this post in threaded view
|

Re: [Camel 2.0] thought for the day: rename multicast() to be wireTap()?

Guillaume Nodet
Administrator
In reply to this post by jstrachan
WireTap or Recipients as in a static recipient list pattern ?

On Thu, Oct 9, 2008 at 5:54 PM, James Strachan <[hidden email]> wrote:

> I've always disliked the 'multicast' in the DSL; its kinda ugly. I
> wonder would using the word 'wireTap' be better? As its kinda a
> wiretap - send the same message exchange to multiple places?
>
> Thoughts?
> --
> James
> -------
> http://macstrac.blogspot.com/
>
> Open Source Integration
> http://open.iona.com
>



--
Cheers,
Guillaume Nodet
------------------------
Blog: http://gnodet.blogspot.com/
------------------------
Open Source SOA
http://open.iona.com
Reply | Threaded
Open this post in threaded view
|

Re: [Camel 2.0] thought for the day: rename multicast() to be wireTap()?

Guillaume Nodet
Administrator
In reply to this post by Oisin Hurley
Agreed, it would be a bit more consistent and would make it more
difficult to mismatch the wiretap / recipient list with the pipeline.

On Thu, Oct 9, 2008 at 7:16 PM, Oisin Hurley <[hidden email]> wrote:

>> I've always disliked the 'multicast' in the DSL; its kinda ugly. I
>> wonder would using the word 'wireTap' be better?
>
> Looking at it from the Spring pov, this would mean
>
>  <route>
>    <from uri="seda:a"/>
>       <wireTap>
>          <to uri="seda:tap"/>
>          <to uri="seda:b"/>
>       </wireTap>
>  </route>
>
> which I think is a good change -- give us an id attribute
> on the wireTap element and that would be cool ;)
>
> Here's another suggestion - if you describe a little route
> like:
>
>  <route>
>    <from uri="seda:a"/>
>    <to uri="seda:tap"/>
>    <to uri="seda:b"/>
>  </route>
>
> then that acts as a pipeline - which is the same as
>
>  <route>
>    <from uri="seda:a"/>
>    <pipeline>
>        <to uri="seda:tap"/>
>        <to uri="seda:b"/>
>    </pipeline>
>  </route>
>
> d'you think that we could *not* have the two of them,
> for the sake of consistency?
>
>  --oh
>



--
Cheers,
Guillaume Nodet
------------------------
Blog: http://gnodet.blogspot.com/
------------------------
Open Source SOA
http://open.iona.com
Reply | Threaded
Open this post in threaded view
|

RE: [Camel 2.0] thought for the day: rename multicast() to be wireTap()?

Claus Ibsen
In reply to this post by Guillaume Nodet
-1 for wiretap

For me wireTap is still as if only you could tab the wire once, eg only add one extra endpoint, where as multicast I would know I can add more endpoints. Also the wiretap is categorized as a System Management pattern. Not the category I would at first for such a need.

+1 for recipentList
I do think we should support the existing <recipientList> to handle both dynamic and static lists of endpoints.



Med venlig hilsen
 
Claus Ibsen
......................................
Silverbullet
Skovsgårdsvænget 21
8362 Hørning
Tlf. +45 2962 7576
Web: www.silverbullet.dk
-----Original Message-----
From: Guillaume Nodet [mailto:[hidden email]]
Sent: 9. oktober 2008 19:26
To: [hidden email]
Subject: Re: [Camel 2.0] thought for the day: rename multicast() to be wireTap()?

WireTap or Recipients as in a static recipient list pattern ?

On Thu, Oct 9, 2008 at 5:54 PM, James Strachan <[hidden email]> wrote:

> I've always disliked the 'multicast' in the DSL; its kinda ugly. I
> wonder would using the word 'wireTap' be better? As its kinda a
> wiretap - send the same message exchange to multiple places?
>
> Thoughts?
> --
> James
> -------
> http://macstrac.blogspot.com/
>
> Open Source Integration
> http://open.iona.com
>



--
Cheers,
Guillaume Nodet
------------------------
Blog: http://gnodet.blogspot.com/
------------------------
Open Source SOA
http://open.iona.com
Reply | Threaded
Open this post in threaded view
|

Re: [Camel 2.0] thought for the day: rename multicast() to be wireTap()?

Oisin Hurley
> For me wireTap is still as if only you could tab the wire once, eg only add one extra endpoint, >where as multicast I would know I can add more endpoints. Also the wiretap is categorized as
> a System Management pattern. Not the category I would at first for such a need.
>
> +1 for recipentList
> I do think we should support the existing <recipientList> to handle both dynamic and static lists of endpoints.

Recipient list as a general solution would work,  but it would
be good if we could have some kind of indicator that the
developer intended an n-part static recipient list was to actually
to be a wire tap, with maybe multiple outputs (i.e. they were
specifically looking at a system management pattern).

From the perspective of the executable language DSLs, this
might be awkward to express, but in the JAXB serialization,
a <description/> element containing metadata about the intent
would be a useful container for some kind of convention.

My angle here is that I'm writing tools that express to the
user the intent of the route, and I'd like to be able to round
trip a visual model of the route through the XML configuration
and back without intent or visual annotation lossage :)

I'm not so  sure that this is important to the operation of the
runtime, which is more concerned about the execution than the
intent...

 --oh