Camel plugin no longer shows up in hawtio

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Camel plugin no longer shows up in hawtio

Jeremy Ross
Hey camel folks,

At some point the Camel plugin stopped showing up in hawtio. I can access
hawtio just fine, but Camel is not in the menu navigation. I don't recall
seeing anything in the upgrade guides about it. Did I miss something?

Thanks,

Jeremy
Reply | Threaded
Open this post in threaded view
|

Re: Camel plugin no longer shows up in hawtio

Mark Nuttall
Might be a version issue. I had the same problem and that is what it was.
Also, debugging is not there unless I drop back camel  versions.

On Thu, Jun 4, 2020, 7:38 PM Jeremy Ross <[hidden email]> wrote:

> Hey camel folks,
>
> At some point the Camel plugin stopped showing up in hawtio. I can access
> hawtio just fine, but Camel is not in the menu navigation. I don't recall
> seeing anything in the upgrade guides about it. Did I miss something?
>
> Thanks,
>
> Jeremy
>
Reply | Threaded
Open this post in threaded view
|

RE: Camel plugin no longer shows up in hawtio

kjchernov
Hi.

Maybe it is the same problem that I've had once?
https://camel.465427.n5.nabble.com/Debugging-and-tracing-camel-3-0-0-on-OSGi-td5849514.html

Best regards,
Konstantin J. Chernov.

-----Original Message-----
From: Mark Nuttall <[hidden email]>
Sent: Friday, June 5, 2020 8:37 AM
To: [hidden email]
Subject: Re: Camel plugin no longer shows up in hawtio

Might be a version issue. I had the same problem and that is what it was.
Also, debugging is not there unless I drop back camel  versions.

On Thu, Jun 4, 2020, 7:38 PM Jeremy Ross <[hidden email]> wrote:

> Hey camel folks,
>
> At some point the Camel plugin stopped showing up in hawtio. I can
> access hawtio just fine, but Camel is not in the menu navigation. I
> don't recall seeing anything in the upgrade guides about it. Did I miss something?
>
> Thanks,
>
> Jeremy
>

Reply | Threaded
Open this post in threaded view
|

Re: Camel plugin no longer shows up in hawtio

Jeremy Ross
Looks like you have to add camel-management now since JMX is disabled by
default.

https://camel.apache.org/manual/latest/camel-3-migration-guide.html#_jmx

On Fri, Jun 5, 2020 at 7:15 AM <[hidden email]> wrote:

> Hi.
>
> Maybe it is the same problem that I've had once?
>
> https://camel.465427.n5.nabble.com/Debugging-and-tracing-camel-3-0-0-on-OSGi-td5849514.html
>
> Best regards,
> Konstantin J. Chernov.
>
> -----Original Message-----
> From: Mark Nuttall <[hidden email]>
> Sent: Friday, June 5, 2020 8:37 AM
> To: [hidden email]
> Subject: Re: Camel plugin no longer shows up in hawtio
>
> Might be a version issue. I had the same problem and that is what it was.
> Also, debugging is not there unless I drop back camel  versions.
>
> On Thu, Jun 4, 2020, 7:38 PM Jeremy Ross <[hidden email]> wrote:
>
> > Hey camel folks,
> >
> > At some point the Camel plugin stopped showing up in hawtio. I can
> > access hawtio just fine, but Camel is not in the menu navigation. I
> > don't recall seeing anything in the upgrade guides about it. Did I miss
> something?
> >
> > Thanks,
> >
> > Jeremy
> >
>
>