Error in camel-http4 after update version from 2.20.2 to 2.25.1

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Error in camel-http4 after update version from 2.20.2 to 2.25.1

Mikhail Lukyanov
Hello, everyone

I updated the Camel version and ran into a problem with the http4 component. 

When I send a message using this component, I get the following error

image.png
An error occurs at this location.
image.png
full error in attached file.

Please tell me how I can deal with this error?
--
With best regards, Lukyanov Mikhail
Tel: +7-909-69-71-547

error.txt (4K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Error in camel-http4 after update version from 2.20.2 to 2.25.1

Claus Ibsen-2
Hi

That smells like you have mixed versions of Camel JARs on your classpath. Make sure your upgrade use only 1 version of Camel and its the same version.

On Thu, May 28, 2020 at 7:36 AM Mikhail Lukyanov <[hidden email]> wrote:
Hello, everyone

I updated the Camel version and ran into a problem with the http4 component. 

When I send a message using this component, I get the following error


An error occurs at this location.

full error in attached file.

Please tell me how I can deal with this error?
--
With best regards, Lukyanov Mikhail
Tel: +7-909-69-71-547


--
Claus Ibsen
-----------------
http://davsclaus.com @davsclaus
Camel in Action 2: https://www.manning.com/ibsen2
Reply | Threaded
Open this post in threaded view
|

Re: Error in camel-http4 after update version from 2.20.2 to 2.25.1

Mikhail Lukyanov
Hi, Claus. Yes, you are right, I found old Camel version in maven
dependensies.

пт, 3 июл. 2020 г., 22:03 Claus Ibsen <[hidden email]>:

> Hi
>
> That smells like you have mixed versions of Camel JARs on your classpath.
> Make sure your upgrade use only 1 version of Camel and its the same version.
>
> On Thu, May 28, 2020 at 7:36 AM Mikhail Lukyanov <[hidden email]>
> wrote:
>
>> Hello, everyone
>>
>> I updated the Camel version and ran into a problem with the *http4*
>> component.
>>
>> When I send a message using this component, I get the following error
>>
>> [image: image.png]
>> An error occurs at this location.
>> [image: image.png]
>> full error in attached file.
>>
>> Please tell me how I can deal with this error?
>> --
>> *With best regards, Lukyanov Mikhail*
>> *Tel: **+7-909-69-71-547*
>>
>
>
> --
> Claus Ibsen
> -----------------
> http://davsclaus.com @davsclaus
> Camel in Action 2: https://www.manning.com/ibsen2
>