Fwd: camel-kubernetes - issue retrieving config-map

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Fwd: camel-kubernetes - issue retrieving config-map

Narsi Nallamilli
Hi,

I am trying to run below camel app in minikube, however receiving below
error. any help?

JDK version: 8
camel-version 2.24.2
example : https://github.com/nicolaferraro/camel-leader-election
minikube version: v1.4.0

2019-10-07 11:48:29.229  WARN 1 --- [rshipController]
c.c.k.c.l.KubernetesLeadershipController :
Pod[camel-leader-election-c7d5bb4d9-fflc6] Unable to retrieve the current
ConfigMap leaders from Kubernetes
Reply | Threaded
Open this post in threaded view
|

Re: camel-kubernetes - issue retrieving config-map

Onder SEZGIN
you may need to disable these two.

camel.component.kubernetes.cluster.service.cluster-labels[group]=
${project.groupId}

camel.component.kubernetes.cluster.service.cluster-labels[app]=
${project.artifactId}


On Thu, Oct 10, 2019 at 12:55 PM Narsi Reddy Nallamilli <
[hidden email]> wrote:

> Hi,
>
> I am trying to run below camel app in minikube, however receiving below
> error. any help?
>
> JDK version: 8
> camel-version 2.24.2
> example : https://github.com/nicolaferraro/camel-leader-election
> minikube version: v1.4.0
>
> 2019-10-07 11:48:29.229  WARN 1 --- [rshipController]
> c.c.k.c.l.KubernetesLeadershipController :
> Pod[camel-leader-election-c7d5bb4d9-fflc6] Unable to retrieve the current
> ConfigMap leaders from Kubernetes
>
Reply | Threaded
Open this post in threaded view
|

Re: camel-kubernetes - issue retrieving config-map

Narsi Nallamilli
Nope, I tried but still get the same error.

On Mon, Oct 14, 2019 at 4:25 PM Onder SEZGIN <[hidden email]> wrote:

> you may need to disable these two.
>
> camel.component.kubernetes.cluster.service.cluster-labels[group]=
> ${project.groupId}
>
> camel.component.kubernetes.cluster.service.cluster-labels[app]=
> ${project.artifactId}
>
>
> On Thu, Oct 10, 2019 at 12:55 PM Narsi Reddy Nallamilli <
> [hidden email]> wrote:
>
> > Hi,
> >
> > I am trying to run below camel app in minikube, however receiving below
> > error. any help?
> >
> > JDK version: 8
> > camel-version 2.24.2
> > example : https://github.com/nicolaferraro/camel-leader-election
> > minikube version: v1.4.0
> >
> > 2019-10-07 11:48:29.229  WARN 1 --- [rshipController]
> > c.c.k.c.l.KubernetesLeadershipController :
> > Pod[camel-leader-election-c7d5bb4d9-fflc6] Unable to retrieve the current
> > ConfigMap leaders from Kubernetes
> >
>