[GitHub] [camel] fvaleri opened a new pull request #3851: [CAMEL-7810] Use OptimisticLockingException for version conflicts

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[GitHub] [camel] fvaleri opened a new pull request #3851: [CAMEL-7810] Use OptimisticLockingException for version conflicts

GitBox

fvaleri opened a new pull request #3851:
URL: https://github.com/apache/camel/pull/3851


   To trigger optimistic locking handling in case of version conflicts, we need to raise `OptimisticLockingException` not just `RuntimeCamelException`. With this change my test application works also on master. I'm going to open the same also on 2.25.x and contribute the app in the example repository with two other dedicated PR.
   


----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

For queries about this service, please contact Infrastructure at:
[hidden email]


Reply | Threaded
Open this post in threaded view
|

[GitHub] [camel] davsclaus merged pull request #3851: [CAMEL-7810] Use OptimisticLockingException for version conflicts

GitBox

davsclaus merged pull request #3851:
URL: https://github.com/apache/camel/pull/3851


   


----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

For queries about this service, please contact Infrastructure at:
[hidden email]