[GitHub] [camel-k] nicolaferraro commented on issue #1055: Release 1.0.0-M4

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[GitHub] [camel-k] nicolaferraro commented on issue #1055: Release 1.0.0-M4

GitBox
nicolaferraro commented on issue #1055: Release 1.0.0-M4
URL: https://github.com/apache/camel-k/issues/1055#issuecomment-553444985
 
 
   ## New Features
   
   - A Go client for interacting with Camel K Kubernetes resources is now available ([#1051](https://github.com/apache/camel-k/pull/1051), [@nicolaferraro](https://github.com/nicolaferraro))
   - Initial Quarkus support (JVM mode) ([#1013](https://github.com/apache/camel-k/pull/1013), [@astefanutti](https://github.com/astefanutti))
   
   
   ## Bug Fixes
   
   - Fixed "kamel" CLI to authenticate via user credentials, if available, in containerized IDEs ([#1054](https://github.com/apache/camel-k/pull/1054), [@nicolaferraro](https://github.com/nicolaferraro))
   
   
   ## Other Notable Changes
   
   - Remove support for loading compiled java classes ([#1052](https://github.com/apache/camel-k/pull/1052), [@lburgazzoli](https://github.com/lburgazzoli))
   - Upgrade Operator SDK to version 0.12.0 ([#1043](https://github.com/apache/camel-k/pull/1043), [@astefanutti](https://github.com/astefanutti))
   - Report runtime version from Camel catalog into integration and kit statuses ([#1044](https://github.com/apache/camel-k/pull/1044), [@astefanutti](https://github.com/astefanutti))
   - chore(dev): Require Go version 1.13 ([#1040](https://github.com/apache/camel-k/pull/1040), [@astefanutti](https://github.com/astefanutti))
   
   
   

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
[hidden email]


With regards,
Apache Git Services