[GitHub] [camel-quarkus] davsclaus commented on issue #412: Fixes #411 bean-validator extension

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[GitHub] [camel-quarkus] davsclaus commented on issue #412: Fixes #411 bean-validator extension

GitBox
davsclaus commented on issue #412: Fixes #411 bean-validator extension
URL: https://github.com/apache/camel-quarkus/pull/412#issuecomment-553732374
 
 
   Adding joda-time 1.4 makes the native image build, but at test/runtime you get this error
   
   Caused by: javax.validation.NoProviderFoundException: Unable to create a Configuration, because no Jakarta Bean Validation provider could be found. Add a provider like Hibernate Validator (RI) to your classpath.
    at javax.validation.Validation$GenericBootstrapImpl.configure(Validation.java:291)
    at org.apache.camel.component.bean.validator.ValidatorFactories.buildValidatorFactory(ValidatorFactories.java:49)
    at org.apache.camel.component.bean.validator.BeanValidatorEndpoint.createProducer(BeanValidatorEndpoint.java:69)
    at org.apache.camel.support.DefaultEndpoint.createAsyncProducer(DefaultEndpoint.java:196)
    at org.apache.camel.impl.engine.ServicePool$SinglePool.acquire(ServicePool.java:234)
    at org.apache.camel.impl.engine.ServicePool$SinglePool.acquire(ServicePool.java:221)
    at org.apache.camel.impl.engine.ServicePool.acquire(ServicePool.java:112)
    at org.apache.camel.impl.engine.DefaultProducerCache.acquireProducer(DefaultProducerCache.java:113)
    ... 38 more
   [ERROR] Tests run: 1, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 60.13 s <<< FAILURE! - in org.apache.camel.quarkus.component.bean.validator.it.BeanValidatorIT
   [ERROR] test  Time elapsed: 0.01 s  <<< ERROR!
   org.junit.jupiter.api.extension.TestInstantiationException: TestInstanceFactory [io.quarkus.test.junit.QuarkusTestExtension] failed to instantiate test class [org.apache.camel.quarkus.component.bean.validator.it.BeanValidatorIT]: Unable to start native image in 60s
   Caused by: java.lang.RuntimeException: Unable to start native image in 60s

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
[hidden email]


With regards,
Apache Git Services