Installation of activemq-camel with Camel 3.0.0 inside karaf 4.2.7 failed

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Installation of activemq-camel with Camel 3.0.0 inside karaf 4.2.7 failed

Gerald Kallas - mailbox.org
Dear community,

I'm trying to install the activemq-camel feature together with Camel 3.0.0. See following excerpt of commands

karaf@root()> feature:repo-add camel 3.0.0
Adding feature url mvn:org.apache.camel.karaf/apache-camel/3.0.0/xml/features
karaf@root()> feature:install camel
karaf@root()> feature:repo-add activemq 5.15.11
Adding feature url mvn:org.apache.activemq/activemq-karaf/5.15.11/xml/features
karaf@root()> feature:install activemq
karaf@root()> feature:install camel-jms
karaf@root()> feature:install activemq-camel
org.apache.felix.resolver.reason.ReasonException: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=activemq-camel; type=karaf.feature; version="[5.15.11,5.15.11]"; filter:="(&(osgi.identity=activemq-camel)(type=karaf.feature)(version>=5.15.11)(version<=5.15.11))" [caused by: Unable to resolve activemq-camel/5.15.11: missing requirement [activemq-camel/5.15.11] osgi.identity; osgi.identity=camel-jms; type=karaf.feature; version="[2.20.0,3.0.0)"]
at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
at org.apache.felix.resolver.ResolverImpl.doResolve(ResolverImpl.java:392)
at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:378)
at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:332)
at org.apache.karaf.features.internal.region.SubsystemResolver.resolve(SubsystemResolver.java:257)
at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:393)
at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1062)
at org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$doProvisionInThread$13(FeaturesServiceImpl.java:998)
at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
at java.base/java.lang.Thread.run(Thread.java:834)
Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to resolve activemq-camel/5.15.11: missing requirement [activemq-camel/5.15.11] osgi.identity; osgi.identity=camel-jms; type=karaf.feature; version="[2.20.0,3.0.0)"
at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
... 12 more
Error executing command: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=activemq-camel; type=karaf.feature; version="[5.15.11,5.15.11]"; filter:="(&(osgi.identity=activemq-camel)(type=karaf.feature)(version>=5.15.11)(version<=5.15.11))" [caused by: Unable to resolve activemq-camel/5.15.11: missing requirement [activemq-camel/5.15.11] osgi.identity; osgi.identity=camel-jms; type=karaf.feature; version="[2.20.0,3.0.0)"]

camel-jms is already installed and started.

karaf@root()> feature:list | grep camel-jms
camel-jms x 3.0.0 x x x Started x camel-3.0.0 x

With Camel 2.24.2 everything works fine.

I'd be happy about any hints and comments. Thanks.

- Gerald
Reply | Threaded
Open this post in threaded view
|

Re: Installation of activemq-camel with Camel 3.0.0 inside karaf 4.2.7 failed

Andrea Cosentino-3
You need to install camel-activemq and not activemq-camel

Il gio 2 gen 2020, 18:44 Gerald Kallas <[hidden email]> ha scritto:

> Dear community,
>
> I'm trying to install the activemq-camel feature together with Camel
> 3.0.0. See following excerpt of commands
>
> karaf@root()> feature:repo-add camel 3.0.0
> Adding feature url
> mvn:org.apache.camel.karaf/apache-camel/3.0.0/xml/features
> karaf@root()> feature:install camel
> karaf@root()> feature:repo-add activemq 5.15.11
> Adding feature url
> mvn:org.apache.activemq/activemq-karaf/5.15.11/xml/features
> karaf@root()> feature:install activemq
> karaf@root()> feature:install camel-jms
> karaf@root()> feature:install activemq-camel
> org.apache.felix.resolver.reason.ReasonException: Unable to resolve root:
> missing requirement [root] osgi.identity; osgi.identity=activemq-camel;
> type=karaf.feature; version="[5.15.11,5.15.11]";
> filter:="(&(osgi.identity=activemq-camel)(type=karaf.feature)(version>=5.15.11)(version<=5.15.11))"
> [caused by: Unable to resolve activemq-camel/5.15.11: missing requirement
> [activemq-camel/5.15.11] osgi.identity; osgi.identity=camel-jms;
> type=karaf.feature; version="[2.20.0,3.0.0)"]
> at
> org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
> at org.apache.felix.resolver.ResolverImpl.doResolve(ResolverImpl.java:392)
> at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:378)
> at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:332)
> at
> org.apache.karaf.features.internal.region.SubsystemResolver.resolve(SubsystemResolver.java:257)
> at
> org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:393)
> at
> org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1062)
> at
> org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$doProvisionInThread$13(FeaturesServiceImpl.java:998)
> at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
> at
> java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
> at
> java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
> at java.base/java.lang.Thread.run(Thread.java:834)
> Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to
> resolve activemq-camel/5.15.11: missing requirement
> [activemq-camel/5.15.11] osgi.identity; osgi.identity=camel-jms;
> type=karaf.feature; version="[2.20.0,3.0.0)"
> at
> org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
> ... 12 more
> Error executing command: Unable to resolve root: missing requirement
> [root] osgi.identity; osgi.identity=activemq-camel; type=karaf.feature;
> version="[5.15.11,5.15.11]";
> filter:="(&(osgi.identity=activemq-camel)(type=karaf.feature)(version>=5.15.11)(version<=5.15.11))"
> [caused by: Unable to resolve activemq-camel/5.15.11: missing requirement
> [activemq-camel/5.15.11] osgi.identity; osgi.identity=camel-jms;
> type=karaf.feature; version="[2.20.0,3.0.0)"]
>
> camel-jms is already installed and started.
>
> karaf@root()> feature:list | grep camel-jms
> camel-jms x 3.0.0 x x x Started x camel-3.0.0 x
>
> With Camel 2.24.2 everything works fine.
>
> I'd be happy about any hints and comments. Thanks.
>
> - Gerald
Reply | Threaded
Open this post in threaded view
|

Re: Installation of activemq-camel with Camel 3.0.0 inside karaf 4.2.7 failed

Andrea Cosentino-3
This was done for camel 3

Il gio 2 gen 2020, 18:48 Andrea Cosentino <[hidden email]> ha scritto:

> You need to install camel-activemq and not activemq-camel
>
> Il gio 2 gen 2020, 18:44 Gerald Kallas <[hidden email]> ha scritto:
>
>> Dear community,
>>
>> I'm trying to install the activemq-camel feature together with Camel
>> 3.0.0. See following excerpt of commands
>>
>> karaf@root()> feature:repo-add camel 3.0.0
>> Adding feature url
>> mvn:org.apache.camel.karaf/apache-camel/3.0.0/xml/features
>> karaf@root()> feature:install camel
>> karaf@root()> feature:repo-add activemq 5.15.11
>> Adding feature url
>> mvn:org.apache.activemq/activemq-karaf/5.15.11/xml/features
>> karaf@root()> feature:install activemq
>> karaf@root()> feature:install camel-jms
>> karaf@root()> feature:install activemq-camel
>> org.apache.felix.resolver.reason.ReasonException: Unable to resolve root:
>> missing requirement [root] osgi.identity; osgi.identity=activemq-camel;
>> type=karaf.feature; version="[5.15.11,5.15.11]";
>> filter:="(&(osgi.identity=activemq-camel)(type=karaf.feature)(version>=5.15.11)(version<=5.15.11))"
>> [caused by: Unable to resolve activemq-camel/5.15.11: missing requirement
>> [activemq-camel/5.15.11] osgi.identity; osgi.identity=camel-jms;
>> type=karaf.feature; version="[2.20.0,3.0.0)"]
>> at
>> org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
>> at org.apache.felix.resolver.ResolverImpl.doResolve(ResolverImpl.java:392)
>> at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:378)
>> at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:332)
>> at
>> org.apache.karaf.features.internal.region.SubsystemResolver.resolve(SubsystemResolver.java:257)
>> at
>> org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:393)
>> at
>> org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1062)
>> at
>> org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$doProvisionInThread$13(FeaturesServiceImpl.java:998)
>> at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
>> at
>> java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
>> at
>> java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
>> at java.base/java.lang.Thread.run(Thread.java:834)
>> Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to
>> resolve activemq-camel/5.15.11: missing requirement
>> [activemq-camel/5.15.11] osgi.identity; osgi.identity=camel-jms;
>> type=karaf.feature; version="[2.20.0,3.0.0)"
>> at
>> org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
>> ... 12 more
>> Error executing command: Unable to resolve root: missing requirement
>> [root] osgi.identity; osgi.identity=activemq-camel; type=karaf.feature;
>> version="[5.15.11,5.15.11]";
>> filter:="(&(osgi.identity=activemq-camel)(type=karaf.feature)(version>=5.15.11)(version<=5.15.11))"
>> [caused by: Unable to resolve activemq-camel/5.15.11: missing requirement
>> [activemq-camel/5.15.11] osgi.identity; osgi.identity=camel-jms;
>> type=karaf.feature; version="[2.20.0,3.0.0)"]
>>
>> camel-jms is already installed and started.
>>
>> karaf@root()> feature:list | grep camel-jms
>> camel-jms x 3.0.0 x x x Started x camel-3.0.0 x
>>
>> With Camel 2.24.2 everything works fine.
>>
>> I'd be happy about any hints and comments. Thanks.
>>
>> - Gerald
>
>
Reply | Threaded
Open this post in threaded view
|

Re: Installation of activemq-camel with Camel 3.0.0 inside karaf 4.2.7 failed

Gerald Kallas - mailbox.org
Many tx, it works.

Best
- Gerald

>     Andrea Cosentino < [hidden email] mailto:[hidden email] > hat am 2. Januar 2020 um 18:58 geschrieben:
>
>
>     This was done for camel 3
>
>     Il gio 2 gen 2020, 18:48 Andrea Cosentino < [hidden email] mailto:[hidden email] > ha scritto:
>
>
>         > >         You need to install camel-activemq and not activemq-camel
> >
> >     >
>         > >         Il gio 2 gen 2020, 18:44 Gerald Kallas < [hidden email] mailto:[hidden email] > ha scritto:
> >
> >     >     >> Dear community,
>     >>
>     >> I'm trying to install the activemq-camel feature together with Camel
>     >> 3.0.0. See following excerpt of commands
>     >>
>     >> karaf@root()> feature:repo-add camel 3.0.0
>     >> Adding feature url
>     >> mvn:org.apache.camel.karaf/apache-camel/3.0.0/xml/features
>     >> karaf@root()> feature:install camel
>     >> karaf@root()> feature:repo-add activemq 5.15.11
>     >> Adding feature url
>     >> mvn:org.apache.activemq/activemq-karaf/5.15.11/xml/features
>     >> karaf@root()> feature:install activemq
>     >> karaf@root()> feature:install camel-jms
>     >> karaf@root()> feature:install activemq-camel
>     >> org.apache.felix.resolver.reason.ReasonException: Unable to resolve root:
>     >> missing requirement [root] osgi.identity; osgi.identity=activemq-camel;
>     >> type=karaf.feature; version="[5.15.11,5.15.11]";
>     >> filter:="(&(osgi.identity=activemq-camel)(type=karaf.feature)(version>=5.15.11)(version<=5.15.11))"
>     >> [caused by: Unable to resolve activemq-camel/5.15.11: missing requirement
>     >> [activemq-camel/5.15.11] osgi.identity; osgi.identity=camel-jms;
>     >> type=karaf.feature; version="[2.20.0,3.0.0)"]
>     >> at
>     >> org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
>     >> at org.apache.felix.resolver.ResolverImpl.doResolve(ResolverImpl.java:392)
>     >> at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:378)
>     >> at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:332)
>     >> at
>     >> org.apache.karaf.features.internal.region.SubsystemResolver.resolve(SubsystemResolver.java:257)
>     >> at
>     >> org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:393)
>     >> at
>     >> org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1062)
>     >> at
>     >> org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$doProvisionInThread$13(FeaturesServiceImpl.java:998)
>     >> at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
>     >> at
>     >> java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
>     >> at
>     >> java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
>     >> at java.base/java.lang.Thread.run(Thread.java:834)
>     >> Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to
>     >> resolve activemq-camel/5.15.11: missing requirement
>     >> [activemq-camel/5.15.11] osgi.identity; osgi.identity=camel-jms;
>     >> type=karaf.feature; version="[2.20.0,3.0.0)"
>     >> at
>     >> org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
>     >> ... 12 more
>     >> Error executing command: Unable to resolve root: missing requirement
>     >> [root] osgi.identity; osgi.identity=activemq-camel; type=karaf.feature;
>     >> version="[5.15.11,5.15.11]";
>     >> filter:="(&(osgi.identity=activemq-camel)(type=karaf.feature)(version>=5.15.11)(version<=5.15.11))"
>     >> [caused by: Unable to resolve activemq-camel/5.15.11: missing requirement
>     >> [activemq-camel/5.15.11] osgi.identity; osgi.identity=camel-jms;
>     >> type=karaf.feature; version="[2.20.0,3.0.0)"]
>     >>
>     >> camel-jms is already installed and started.
>     >>
>     >> karaf@root()> feature:list | grep camel-jms
>     >> camel-jms x 3.0.0 x x x Started x camel-3.0.0 x
>     >>
>     >> With Camel 2.24.2 everything works fine.
>     >>
>     >> I'd be happy about any hints and comments. Thanks.
>     >>
>     >> - Gerald
>     >
>     >
>