JMS configuration seems to be lost after installation of camel-activemq feature

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

JMS configuration seems to be lost after installation of camel-activemq feature

Gerald Kallas - mailbox.org
Dear community,

I've executed following steps at a vanilla karaf 4.2.7

karaf@root()> feature:repo-add hawtio 2.8.0
Adding feature url mvn:io.hawt/hawtio-karaf/2.8.0/xml/features
karaf@root()> feature:repo-add activemq 5.15.11
Adding feature url mvn:org.apache.activemq/activemq-karaf/5.15.11/xml/features
karaf@root()> feature:repo-add camel 3.0.0
Adding feature url mvn:org.apache.camel.karaf/apache-camel/3.0.0/xml/features
karaf@root()> feature:install webconsole hawtio activemq-broker pax-jms-config pax-jms-activemq jms
karaf@root()> jms:create -t activemq --url tcp://localhost:61616 -u karaf -p karaf activemq
karaf@root()> jms:info -u karaf -p karaf activemq
Property │ Value
─────────┼─────────
product │ ActiveMQ
version │ 5.15.11
karaf@root()> feature:install camel
karaf@root()> jms:info -u karaf -p karaf activemq
Property │ Value
─────────┼─────────
product │ ActiveMQ
version │ 5.15.11
karaf@root()> feature:install camel-activemq
karaf@root()> jms:info -u karaf -p karaf activemq
Error executing command: No JMS connection factory found for activemq

The goal is to create a route like

<blueprint xmlns="http://www.osgi.org/xmlns/blueprint/v1.0.0">
<camelContext id="file.queue" xmlns="http://camel.apache.org/schema/blueprint">
<route id="file.queue">
<from uri="file:/tmp/in?include=.*\.xml" />
<log message="file.queue - Route started" />
<to uri="activemq:queue:IN" />
<log message="file.queue - Route finished" />
</route>
</camelContext>
</blueprint>

without any Connection Factory definition within this route (and every other route that uses activemq).

After installing the camel-activemq feature no further jms config is possible.

Any hints and tips what I made wrong here?

Best
- Gerald