Missing dependency in Camel 2.5

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Missing dependency in Camel 2.5

Stefan113453
Hi,
 
I tried to switch from 2.4 to 2.5.
We are using Camel in a OSGi Environment.
And now i have a missing dependency.
In the org.apache.camel.camel-spring bundle a package named org.springframework.osgi.context is missing.
I looked in the 2.4 libs and there is package is present, but not in the 2.5 libs...
 
What am I doing wrong?
 
 
 
 

Mit freundlichen Grüßen / kind regards

 

Stefan Lorenz

wissenschaftlicher Mitarbeiter

 

 

 

Hochschule Aalen / Aalen University
Fakultät Elektronik und Informatik
Anton-Huber-Strasse 25

73430 Aalen

E-Mail:  [hidden email]
Internet:       www.htw-aalen.de

 

smime.p7s (7K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Missing dependency in Camel 2.5

Stefan113453
ok,
i fixed it...

i had to add
com.springsource.org.aopalliance-1.0.0.jar
spring-osgi-core-1.2.1.jar
spring-osgi-io-1.2.1.jar

now its working...

is this the right way?

Regards,
Stefan