Moving to Apache Camel 2.24.0

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Moving to Apache Camel 2.24.0

ksprasad113
This post was updated on .
Hi,

Our platform currently using Apache Camel 2.17.2 and we are moving to camel
2.24.0.
There are many application built on this platform and many are not in our
control.

Is there a way to check which are all the incompatible changes from 2.17.x
to 2.24.0?
What are the deprecations in 2.24.0?
Is it possible to modify applications to run on both 2.24.0 and 2.17.2?

Also, is it possible to have a component working in 2.24 and not in 2.17?
I know there are lot of components and lot of changes between these two versions. So, please let me know if you have come across any incompatible changes.

Regards,
Shankar