Question about camel cxf & blueprint

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Question about camel cxf & blueprint

Charles Moulliard-2
Hi,

The following syntax is not supported

<?xml version="1.0" encoding="UTF-8"?>
<blueprint xmlns="http://www.osgi.org/xmlns/blueprint/v1.0.0"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xmlns:cxf="http://cxf.apache.org/blueprint/core"
    xmlns:camelcxf="http://camel.apache.org/schema/blueprint/cxf"
xsi:schemaLocation="
             http://www.osgi.org/xmlns/blueprint/v1.0.0
http://www.osgi.org/xmlns/blueprint/v1.0.0/blueprint.xsd
             http://cxf.apache.org/blueprint/core
http://cxf.apache.org/schemas/blueprint/core.xsd">

<camelcxf:cxfEndpoint id="WS"
address="http://localhost:9090/training/WebService"
        serviceClass="com.fusesource.training.CustomerService">

        <cxf:outInterceptors>
            <ref bean="loggingOutInterceptor"/>
        </cxf:outInterceptors>
        <cxf:inInterceptors>
            <ref bean="loggingInInterceptor"/>
        </cxf:inInterceptors>

</camelcxf:cxfEndpoint>

What is the the trick to be used to allow to use <cxf:outInterceptors> or
<cxf:inInterceptors> within tag <camelcxf:cxfEndpoint>

Regards,

--
Charles Moulliard
Apache Committer / Sr. Enterprise Architect (RedHat)
Twitter : @cmoulliard | Blog : http://cmoulliard.blogspot.com
Reply | Threaded
Open this post in threaded view
|

Re: Question about camel cxf & blueprint

Willem.Jiang
Administrator
Hi Charles,

You should be able to set up the outInterceptors and inInterceptors like this  

<camelcxf:cxfEndpoint id="WS"
address="http://localhost:9090/training/WebService"
serviceClass="com.fusesource.training.CustomerService">

<camelcxf:outInterceptors>
<ref component-id=""loggingOutInterceptor"/>
</camelcxf:outInterceptors>
<camelcxf:inInterceptors>
<ref component-id="loggingInInterceptor"/>
</camelcxf:inInterceptors>

</camelcxf:cxfEndpoint>  

--  
Willem Jiang

Red Hat, Inc.
FuseSource is now part of Red Hat
Web: http://www.fusesource.com | http://www.redhat.com
Blog: http://willemjiang.blogspot.com (http://willemjiang.blogspot.com/) (English)
          http://jnn.iteye.com (http://jnn.javaeye.com/) (Chinese)
Twitter: willemjiang  
Weibo: 姜宁willem





On Thursday, January 10, 2013 at 9:09 PM, Charles Moulliard wrote:

> Hi,
>  
> The following syntax is not supported
>  
> <?xml version="1.0" encoding="UTF-8"?>
> <blueprint xmlns="http://www.osgi.org/xmlns/blueprint/v1.0.0"
> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> xmlns:cxf="http://cxf.apache.org/blueprint/core"
> xmlns:camelcxf="http://camel.apache.org/schema/blueprint/cxf"
> xsi:schemaLocation="
> http://www.osgi.org/xmlns/blueprint/v1.0.0
> http://www.osgi.org/xmlns/blueprint/v1.0.0/blueprint.xsd
> http://cxf.apache.org/blueprint/core
> http://cxf.apache.org/schemas/blueprint/core.xsd">
>  
> <camelcxf:cxfEndpoint id="WS"
> address="http://localhost:9090/training/WebService"
> serviceClass="com.fusesource.training.CustomerService">
>  
> <cxf:outInterceptors>
> <ref bean="loggingOutInterceptor"/>
> </cxf:outInterceptors>
> <cxf:inInterceptors>
> <ref bean="loggingInInterceptor"/>
> </cxf:inInterceptors>
>  
> </camelcxf:cxfEndpoint>
>  
> What is the the trick to be used to allow to use <cxf:outInterceptors> or
> <cxf:inInterceptors> within tag <camelcxf:cxfEndpoint>
>  
> Regards,
>  
> --  
> Charles Moulliard
> Apache Committer / Sr. Enterprise Architect (RedHat)
> Twitter : @cmoulliard | Blog : http://cmoulliard.blogspot.com



Reply | Threaded
Open this post in threaded view
|

Re: Question about camel cxf & blueprint

Charles Moulliard-2
Your are right. I just discover my mistake a few minutes ago. Thx


On Thu, Jan 10, 2013 at 3:27 PM, Willem jiang <[hidden email]>wrote:

> Hi Charles,
>
> You should be able to set up the outInterceptors and inInterceptors like
> this
>
> <camelcxf:cxfEndpoint id="WS"
> address="http://localhost:9090/training/WebService"
> serviceClass="com.fusesource.training.CustomerService">
>
> <camelcxf:outInterceptors>
> <ref component-id=""loggingOutInterceptor"/>
> </camelcxf:outInterceptors>
> <camelcxf:inInterceptors>
> <ref component-id="loggingInInterceptor"/>
> </camelcxf:inInterceptors>
>
> </camelcxf:cxfEndpoint>
>
> --
> Willem Jiang
>
> Red Hat, Inc.
> FuseSource is now part of Red Hat
> Web: http://www.fusesource.com | http://www.redhat.com
> Blog: http://willemjiang.blogspot.com (http://willemjiang.blogspot.com/)
> (English)
>           http://jnn.iteye.com (http://jnn.javaeye.com/) (Chinese)
> Twitter: willemjiang
> Weibo: 姜宁willem
>
>
>
>
>
> On Thursday, January 10, 2013 at 9:09 PM, Charles Moulliard wrote:
>
> > Hi,
> >
> > The following syntax is not supported
> >
> > <?xml version="1.0" encoding="UTF-8"?>
> > <blueprint xmlns="http://www.osgi.org/xmlns/blueprint/v1.0.0"
> > xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> > xmlns:cxf="http://cxf.apache.org/blueprint/core"
> > xmlns:camelcxf="http://camel.apache.org/schema/blueprint/cxf"
> > xsi:schemaLocation="
> > http://www.osgi.org/xmlns/blueprint/v1.0.0
> > http://www.osgi.org/xmlns/blueprint/v1.0.0/blueprint.xsd
> > http://cxf.apache.org/blueprint/core
> > http://cxf.apache.org/schemas/blueprint/core.xsd">
> >
> > <camelcxf:cxfEndpoint id="WS"
> > address="http://localhost:9090/training/WebService"
> > serviceClass="com.fusesource.training.CustomerService">
> >
> > <cxf:outInterceptors>
> > <ref bean="loggingOutInterceptor"/>
> > </cxf:outInterceptors>
> > <cxf:inInterceptors>
> > <ref bean="loggingInInterceptor"/>
> > </cxf:inInterceptors>
> >
> > </camelcxf:cxfEndpoint>
> >
> > What is the the trick to be used to allow to use <cxf:outInterceptors> or
> > <cxf:inInterceptors> within tag <camelcxf:cxfEndpoint>
> >
> > Regards,
> >
> > --
> > Charles Moulliard
> > Apache Committer / Sr. Enterprise Architect (RedHat)
> > Twitter : @cmoulliard | Blog : http://cmoulliard.blogspot.com
>
>
>
>


--
Charles Moulliard
Apache Committer / Sr. Enterprise Architect (RedHat)
Twitter : @cmoulliard | Blog : http://cmoulliard.blogspot.com
Reply | Threaded
Open this post in threaded view
|

Re: Question about camel cxf & blueprint

Claus Ibsen-2
On Thu, Jan 10, 2013 at 3:39 PM, Charles Moulliard <[hidden email]> wrote:
> Your are right. I just discover my mistake a few minutes ago. Thx
>

Maybe we should add that to the camel-cxf docs as a little example how
to enable logging when using cxf blueprint.



>
> On Thu, Jan 10, 2013 at 3:27 PM, Willem jiang <[hidden email]>wrote:
>
>> Hi Charles,
>>
>> You should be able to set up the outInterceptors and inInterceptors like
>> this
>>
>> <camelcxf:cxfEndpoint id="WS"
>> address="http://localhost:9090/training/WebService"
>> serviceClass="com.fusesource.training.CustomerService">
>>
>> <camelcxf:outInterceptors>
>> <ref component-id=""loggingOutInterceptor"/>
>> </camelcxf:outInterceptors>
>> <camelcxf:inInterceptors>
>> <ref component-id="loggingInInterceptor"/>
>> </camelcxf:inInterceptors>
>>
>> </camelcxf:cxfEndpoint>
>>
>> --
>> Willem Jiang
>>
>> Red Hat, Inc.
>> FuseSource is now part of Red Hat
>> Web: http://www.fusesource.com | http://www.redhat.com
>> Blog: http://willemjiang.blogspot.com (http://willemjiang.blogspot.com/)
>> (English)
>>           http://jnn.iteye.com (http://jnn.javaeye.com/) (Chinese)
>> Twitter: willemjiang
>> Weibo: 姜宁willem
>>
>>
>>
>>
>>
>> On Thursday, January 10, 2013 at 9:09 PM, Charles Moulliard wrote:
>>
>> > Hi,
>> >
>> > The following syntax is not supported
>> >
>> > <?xml version="1.0" encoding="UTF-8"?>
>> > <blueprint xmlns="http://www.osgi.org/xmlns/blueprint/v1.0.0"
>> > xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>> > xmlns:cxf="http://cxf.apache.org/blueprint/core"
>> > xmlns:camelcxf="http://camel.apache.org/schema/blueprint/cxf"
>> > xsi:schemaLocation="
>> > http://www.osgi.org/xmlns/blueprint/v1.0.0
>> > http://www.osgi.org/xmlns/blueprint/v1.0.0/blueprint.xsd
>> > http://cxf.apache.org/blueprint/core
>> > http://cxf.apache.org/schemas/blueprint/core.xsd">
>> >
>> > <camelcxf:cxfEndpoint id="WS"
>> > address="http://localhost:9090/training/WebService"
>> > serviceClass="com.fusesource.training.CustomerService">
>> >
>> > <cxf:outInterceptors>
>> > <ref bean="loggingOutInterceptor"/>
>> > </cxf:outInterceptors>
>> > <cxf:inInterceptors>
>> > <ref bean="loggingInInterceptor"/>
>> > </cxf:inInterceptors>
>> >
>> > </camelcxf:cxfEndpoint>
>> >
>> > What is the the trick to be used to allow to use <cxf:outInterceptors> or
>> > <cxf:inInterceptors> within tag <camelcxf:cxfEndpoint>
>> >
>> > Regards,
>> >
>> > --
>> > Charles Moulliard
>> > Apache Committer / Sr. Enterprise Architect (RedHat)
>> > Twitter : @cmoulliard | Blog : http://cmoulliard.blogspot.com
>>
>>
>>
>>
>
>
> --
> Charles Moulliard
> Apache Committer / Sr. Enterprise Architect (RedHat)
> Twitter : @cmoulliard | Blog : http://cmoulliard.blogspot.com



--
Claus Ibsen
-----------------
Red Hat, Inc.
FuseSource is now part of Red Hat
Email: [hidden email]
Web: http://fusesource.com
Twitter: davsclaus
Blog: http://davsclaus.com
Author of Camel in Action: http://www.manning.com/ibsen