Re: [camel] 01/02: Remove the very outdated "Can I use Camel on Java 1.4" FAQ entry.

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: [camel] 01/02: Remove the very outdated "Can I use Camel on Java 1.4" FAQ entry.

Andrea Cosentino-3
Hello, when we remove/modify a link or a name, don't forget to always run
the docs module in the camel project. It will check for dead xref.

In this case it was broken. I fixed it.

Il giorno gio 12 set 2019 alle ore 11:50 <[hidden email]> ha
scritto:

> This is an automated email from the ASF dual-hosted git repository.
>
> pascalschumacher pushed a commit to branch master
> in repository https://gitbox.apache.org/repos/asf/camel.git
>
> commit d02e88989dcc30ccf4b5ae38e5db1735b65cb48e
> Author: Pascal Schumacher <[hidden email]>
> AuthorDate: Thu Sep 12 11:45:09 2019 +0200
>
>     Remove the very outdated "Can I use Camel on Java 1.4" FAQ entry.
> ---
>  docs/user-manual/modules/ROOT/pages/faq.adoc                     | 1 -
>  .../modules/ROOT/pages/faq/can-i-use-camel-on-java-14.adoc       | 9
> ---------
>  2 files changed, 10 deletions(-)
>
> diff --git a/docs/user-manual/modules/ROOT/pages/faq.adoc
> b/docs/user-manual/modules/ROOT/pages/faq.adoc
> index 691e0c2..0e6a101 100644
> --- a/docs/user-manual/modules/ROOT/pages/faq.adoc
> +++ b/docs/user-manual/modules/ROOT/pages/faq.adoc
> @@ -16,7 +16,6 @@ so please join in and help us make the documentation
> better!
>  General questions about Camel
>
>  * xref:faq/can-i-get-commercial-support.adoc[Can I get commercial
> support?]
> -* xref:faq/can-i-use-camel-on-java-14.adoc[Can I use Camel on Java 1.4?]
>  * xref:faq/does-camel-work-on-ibms-jdk.adoc[Does Camel work on IBM's JDK?]
>  * xref:support.adoc[How can I get help?]
>  * xref:faq/how-can-i-get-the-source-code.adoc[How can I get the source
> code?]
> diff --git
> a/docs/user-manual/modules/ROOT/pages/faq/can-i-use-camel-on-java-14.adoc
> b/docs/user-manual/modules/ROOT/pages/faq/can-i-use-camel-on-java-14.adoc
> deleted file mode 100644
> index 7dfe697..0000000
> ---
> a/docs/user-manual/modules/ROOT/pages/faq/can-i-use-camel-on-java-14.adoc
> +++ /dev/null
> @@ -1,9 +0,0 @@
> -[[CanIuseCamelonJava1.4-CanIuseCamelonJava1.4]]
> -= Can I use Camel on Java 1.4?
> -
> -Apache Camel was developed to run on Java 1.5 or later to take advantage
> -of the new language features like generics and annotations together with
> -using the Java 5 concurrency code. Starting with version 2.7.0, only
> -Java 1.6 is supported.
> -
> -Starting with version 2.10.0, Java 1.7 is supported, but not required.
>
>
Reply | Threaded
Open this post in threaded view
|

Re: [camel] 01/02: Remove the very outdated "Can I use Camel on Java 1.4" FAQ entry.

Pascal Schumacher
Sorry for breaking the navigation.

Thank you for fixing it!

- Pascal

Am 12.09.2019 um 13:06 schrieb Andrea Cosentino:

> Hello, when we remove/modify a link or a name, don't forget to always run
> the docs module in the camel project. It will check for dead xref.
>
> In this case it was broken. I fixed it.
>
> Il giorno gio 12 set 2019 alle ore 11:50 <[hidden email]> ha
> scritto:
>
>> This is an automated email from the ASF dual-hosted git repository.
>>
>> pascalschumacher pushed a commit to branch master
>> in repository https://gitbox.apache.org/repos/asf/camel.git
>>
>> commit d02e88989dcc30ccf4b5ae38e5db1735b65cb48e
>> Author: Pascal Schumacher <[hidden email]>
>> AuthorDate: Thu Sep 12 11:45:09 2019 +0200
>>
>>      Remove the very outdated "Can I use Camel on Java 1.4" FAQ entry.
>> ---
>>   docs/user-manual/modules/ROOT/pages/faq.adoc                     | 1 -
>>   .../modules/ROOT/pages/faq/can-i-use-camel-on-java-14.adoc       | 9
>> ---------
>>   2 files changed, 10 deletions(-)
>>
>> diff --git a/docs/user-manual/modules/ROOT/pages/faq.adoc
>> b/docs/user-manual/modules/ROOT/pages/faq.adoc
>> index 691e0c2..0e6a101 100644
>> --- a/docs/user-manual/modules/ROOT/pages/faq.adoc
>> +++ b/docs/user-manual/modules/ROOT/pages/faq.adoc
>> @@ -16,7 +16,6 @@ so please join in and help us make the documentation
>> better!
>>   General questions about Camel
>>
>>   * xref:faq/can-i-get-commercial-support.adoc[Can I get commercial
>> support?]
>> -* xref:faq/can-i-use-camel-on-java-14.adoc[Can I use Camel on Java 1.4?]
>>   * xref:faq/does-camel-work-on-ibms-jdk.adoc[Does Camel work on IBM's JDK?]
>>   * xref:support.adoc[How can I get help?]
>>   * xref:faq/how-can-i-get-the-source-code.adoc[How can I get the source
>> code?]
>> diff --git
>> a/docs/user-manual/modules/ROOT/pages/faq/can-i-use-camel-on-java-14.adoc
>> b/docs/user-manual/modules/ROOT/pages/faq/can-i-use-camel-on-java-14.adoc
>> deleted file mode 100644
>> index 7dfe697..0000000
>> ---
>> a/docs/user-manual/modules/ROOT/pages/faq/can-i-use-camel-on-java-14.adoc
>> +++ /dev/null
>> @@ -1,9 +0,0 @@
>> -[[CanIuseCamelonJava1.4-CanIuseCamelonJava1.4]]
>> -= Can I use Camel on Java 1.4?
>> -
>> -Apache Camel was developed to run on Java 1.5 or later to take advantage
>> -of the new language features like generics and annotations together with
>> -using the Java 5 concurrency code. Starting with version 2.7.0, only
>> -Java 1.6 is supported.
>> -
>> -Starting with version 2.10.0, Java 1.7 is supported, but not required.
>>
>>