[SECURITY] New security advisory CVE-2019-0194 released for Apache Camel

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[SECURITY] New security advisory CVE-2019-0194 released for Apache Camel

Andrea Cosentino-2
A new security advisory has been released for Apache Camel, that is fixed in
the recent 2.21.5, 2.22.3 and 2.23.1 releases:

CVE-2019-0194: Apache Camel's File is vulnerable to directory traversal

Severity: MEDIUM

Vendor: The Apache Software Foundation

Versions Affected: Camel 2.21.0 to 2.21.3, Camel 2.22.0 to 2.22.2 and Camel 2.23.0 The unsupported Camel 2.x (2.19 and earlier) versions may be also affected.

Description: Apache Camel's File is vulnerable to directory traversal

Mitigation: 2.21.x users should upgrade to 2.21.5, 2.22.x users should upgrade to 2.22.3 and Camel 2.23.x users should upgrade to 2.23.1 The JIRA tickets: https://issues.apache.org/jira/browse/CAMEL-13042 refers to the various commits that resovoled the issue, and have more details.

Credit: This issue was discovered by Colm O. HEigeartaigh <coheigea at apache dot org> from Apache Software Foundation

On behalf of the Apache Camel PMC

--
Andrea Cosentino 
----------------------------------
Apache Camel PMC Chair
Apache Karaf Committer
Apache Servicemix PMC Member
Email: [hidden email]
Twitter: @oscerd2
Github: oscerd