Strange Constraint on dependency Spring Boot Camel

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Strange Constraint on dependency Spring Boot Camel

hakuseki
What’s the issue here with Camel and Spring Boot?

M
Reply | Threaded
Open this post in threaded view
|

Re: Strange Constraint on dependency Spring Boot Camel

Andrea Cosentino-3
I don't know what version of camel is used there

Il ven 1 nov 2019, 09:49 Mikael Andersson Wigander <[hidden email]> ha scritto:
What’s the issue here with Camel and Spring Boot?

M
Reply | Threaded
Open this post in threaded view
|

Re: Strange Constraint on dependency Spring Boot Camel

hakuseki
If you choose 2.1.10 it will resolve to 2.24.0

M

> On 1 Nov 2019, at 09:50, Andrea Cosentino <[hidden email]> wrote:
>
> I don't know what version of camel is used there
>
> Il ven 1 nov 2019, 09:49 Mikael Andersson Wigander <[hidden email] <mailto:[hidden email]>> ha scritto:
> What’s the issue here with Camel and Spring Boot?
>
>
> M

Reply | Threaded
Open this post in threaded view
|

Re: Strange Constraint on dependency Spring Boot Camel

Claus Ibsen-2
In reply to this post by hakuseki
Camel 2.x is not officially supporting the new Spring Boot 2.2. For that you need the upcoming Camel 3.0 which goes GA later in November.
For Camel 2.x, then use Spring Boot 2.1.x.


On Fri, Nov 1, 2019 at 9:49 AM Mikael Andersson Wigander <[hidden email]> wrote:
What’s the issue here with Camel and Spring Boot?

M


--
Claus Ibsen
-----------------
http://davsclaus.com @davsclaus
Camel in Action 2: https://www.manning.com/ibsen2
Reply | Threaded
Open this post in threaded view
|

Re: Strange Constraint on dependency Spring Boot Camel

Andrea Cosentino-3
In reply to this post by hakuseki
2.2.0 Is supported only in camel 3 master. I'll have a look and double
check

Il ven 1 nov 2019, 10:11 Mikael Andersson Wigander <
[hidden email]> ha scritto:

> If you choose 2.1.10 it will resolve to 2.24.0
>
> M
>
> > On 1 Nov 2019, at 09:50, Andrea Cosentino <[hidden email]> wrote:
> >
> > I don't know what version of camel is used there
> >
> > Il ven 1 nov 2019, 09:49 Mikael Andersson Wigander <
> [hidden email] <mailto:[hidden email]>> ha scritto:
> > What’s the issue here with Camel and Spring Boot?
> >
> >
> > M
>
>