[camel] branch master updated (115b516 -> fce21aa)

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[camel] branch master updated (115b516 -> fce21aa)

acosentino
This is an automated email from the ASF dual-hosted git repository.

acosentino pushed a change to branch master
in repository https://gitbox.apache.org/repos/asf/camel.git.


    from 115b516  CAMEL-14161 - Remove default key from camel-shiro
     new c692aea  Revert "Camel-Optaplanner: Fixed Karaf feature"
     new 54d4fbd  Revert "Camel-Jpbm: Fixed Karaf feature"
     new fce21aa  Revert "[CAMEL-14140] Remove global dependency on outdated guava"

The 3 revisions listed above as "new" are entirely new to this
repository and will be described in separate emails.  The revisions
listed as "add" were already present in the repository and have only
been added to this reference.


Summary of changes:
 components/camel-grpc/pom.xml                        |  2 ++
 components/camel-jira/pom.xml                        |  2 +-
 components/camel-pubnub/pom.xml                      | 11 +++--------
 components/camel-swagger-java/pom.xml                |  2 +-
 .../hello-camel-grpc-client-kubernetes/pom.xml       |  2 ++
 .../hello-camel-grpc-server-kubernetes/pom.xml       |  2 ++
 examples/camel-example-grpc-kubernetes/pom.xml       |  2 ++
 .../hello-camel-grpc-client/pom.xml                  |  2 ++
 .../hello-camel-grpc-server/pom.xml                  |  2 ++
 parent/pom.xml                                       | 20 ++++++++++----------
 .../karaf/features/src/main/resources/features.xml   | 20 ++++++++++----------
 11 files changed, 37 insertions(+), 30 deletions(-)

Reply | Threaded
Open this post in threaded view
|

[camel] 01/03: Revert "Camel-Optaplanner: Fixed Karaf feature"

acosentino
This is an automated email from the ASF dual-hosted git repository.

acosentino pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/camel.git

commit c692aeabd302400ec732d896d484ddb1b83695e1
Author: Andrea Cosentino <[hidden email]>
AuthorDate: Fri Nov 8 13:39:40 2019 +0100

    Revert "Camel-Optaplanner: Fixed Karaf feature"
   
    This reverts commit a250a90878a8e47468e762eeb8c8148aee040d07.
---
 platforms/karaf/features/src/main/resources/features.xml | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/platforms/karaf/features/src/main/resources/features.xml b/platforms/karaf/features/src/main/resources/features.xml
index 4d4e34f..633a610 100644
--- a/platforms/karaf/features/src/main/resources/features.xml
+++ b/platforms/karaf/features/src/main/resources/features.xml
@@ -1980,7 +1980,7 @@
     <bundle dependency='true'>mvn:org.mvel/mvel2/${mvel-version}</bundle>
     <bundle dependency='true'>mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.xstream/${xstream-bundle-version}</bundle>
     <bundle dependency='true'>mvn:com.google.protobuf/protobuf-java/${protobuf-version}</bundle>
-    <bundle dependency='true'>mvn:com.google.guava/guava/${jbpm-guava-osgi-version}</bundle>
+    <bundle dependency='true'>mvn:com.google.guava/guava/${google-guava-version}</bundle>
     <bundle>mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.javax-inject/${javax-inject-bundle-version}</bundle>
     <bundle>mvn:org.apache.camel/camel-optaplanner/${project.version}</bundle>
   </feature>

Reply | Threaded
Open this post in threaded view
|

[camel] 02/03: Revert "Camel-Jpbm: Fixed Karaf feature"

acosentino
In reply to this post by acosentino
This is an automated email from the ASF dual-hosted git repository.

acosentino pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/camel.git

commit 54d4fbdf724b17d1252c51599c03ae172c969703
Author: Andrea Cosentino <[hidden email]>
AuthorDate: Fri Nov 8 13:39:49 2019 +0100

    Revert "Camel-Jpbm: Fixed Karaf feature"
   
    This reverts commit 5fdc2bc86b8904eae8f35b0000e1ef8e46902445.
---
 parent/pom.xml                                           | 1 -
 platforms/karaf/features/src/main/resources/features.xml | 2 +-
 2 files changed, 1 insertion(+), 2 deletions(-)

diff --git a/parent/pom.xml b/parent/pom.xml
index 573adde..b8d93ee 100644
--- a/parent/pom.xml
+++ b/parent/pom.xml
@@ -332,7 +332,6 @@
         <glassfish-jaxb-runtime-version>${jakarta-jaxb-version}</glassfish-jaxb-runtime-version>
         <jaxb2-maven-plugin-version>2.5.0</jaxb2-maven-plugin-version>
         <jbpm-version>7.29.0.Final</jbpm-version>
-        <jbpm-guava-osgi-version>25.0-jre</jbpm-guava-osgi-version>
         <jboss-logging-version>3.4.0.Final</jboss-logging-version>
         <jboss-marshalling-version>1.4.10.Final</jboss-marshalling-version>
         <jboss-transaction-spi.version>7.5.1.Final</jboss-transaction-spi.version>
diff --git a/platforms/karaf/features/src/main/resources/features.xml b/platforms/karaf/features/src/main/resources/features.xml
index 633a610..3e0c5ab 100644
--- a/platforms/karaf/features/src/main/resources/features.xml
+++ b/platforms/karaf/features/src/main/resources/features.xml
@@ -1441,7 +1441,7 @@
     <bundle dependency='true'>mvn:org.optaplanner/optaplanner-persistence-jackson/${jbpm-version}</bundle>
     <bundle dependency='true'>mvn:org.optaplanner/optaplanner-persistence-xstream/${jbpm-version}</bundle>
     <bundle dependency='true'>mvn:com.google.protobuf/protobuf-java/${protobuf-version}</bundle>
-    <bundle dependency='true'>mvn:com.google.guava/guava/${jbpm-guava-osgi-version}</bundle>
+    <bundle dependency='true'>mvn:com.google.guava/guava/${google-guava-version}</bundle>
     <bundle dependency='true'>mvn:org.apache.commons/commons-math3/${commons-math3-version}</bundle>
     <bundle dependency='true'>mvn:org.apache.commons/commons-lang3/${commons-lang3-version}</bundle>
     <bundle dependency='true'>mvn:commons-codec/commons-codec/${commons-codec-version}</bundle>

Reply | Threaded
Open this post in threaded view
|

[camel] 03/03: Revert "[CAMEL-14140] Remove global dependency on outdated guava"

acosentino
In reply to this post by acosentino
This is an automated email from the ASF dual-hosted git repository.

acosentino pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/camel.git

commit fce21aa6133df9590e64183ac4555921a8815b25
Author: Andrea Cosentino <[hidden email]>
AuthorDate: Fri Nov 8 13:40:14 2019 +0100

    Revert "[CAMEL-14140] Remove global dependency on outdated guava"
   
    This reverts commit 52a3bfb4280bff781eb366cfc0ae900316d901ba.
---
 components/camel-grpc/pom.xml                         |  2 ++
 components/camel-jira/pom.xml                         |  2 +-
 components/camel-pubnub/pom.xml                       | 11 +++--------
 components/camel-swagger-java/pom.xml                 |  2 +-
 .../hello-camel-grpc-client-kubernetes/pom.xml        |  2 ++
 .../hello-camel-grpc-server-kubernetes/pom.xml        |  2 ++
 examples/camel-example-grpc-kubernetes/pom.xml        |  2 ++
 .../hello-camel-grpc-client/pom.xml                   |  2 ++
 .../hello-camel-grpc-server/pom.xml                   |  2 ++
 parent/pom.xml                                        | 19 ++++++++++---------
 .../karaf/features/src/main/resources/features.xml    | 16 ++++++++--------
 11 files changed, 35 insertions(+), 27 deletions(-)

diff --git a/components/camel-grpc/pom.xml b/components/camel-grpc/pom.xml
index c8393df..db4545c 100644
--- a/components/camel-grpc/pom.xml
+++ b/components/camel-grpc/pom.xml
@@ -34,6 +34,8 @@
     <description>Camel component for gRPC (Remote Procedure Call) support</description>
 
     <properties>
+        <!-- gRPC requires strong own of the Google Guava version -->
+        <google-guava-version>${grpc-guava-version}</google-guava-version>
     </properties>
 
     <dependencies>
diff --git a/components/camel-jira/pom.xml b/components/camel-jira/pom.xml
index 2f3b747..d847b1f 100644
--- a/components/camel-jira/pom.xml
+++ b/components/camel-jira/pom.xml
@@ -49,7 +49,7 @@
         <dependency>
             <groupId>com.google.guava</groupId>
             <artifactId>guava</artifactId>
-            <version>${google-guava-version}</version>
+            <version>${jira-guava-version}</version>
         </dependency>
 
         <!-- Camel annotations in provided scope to avoid compile errors in IDEs -->
diff --git a/components/camel-pubnub/pom.xml b/components/camel-pubnub/pom.xml
index 0718036..8a9d0cd 100644
--- a/components/camel-pubnub/pom.xml
+++ b/components/camel-pubnub/pom.xml
@@ -48,14 +48,9 @@
             <version>${pubnub-version}</version>
         </dependency>
         <dependency>
-            <groupId>com.squareup.okhttp3</groupId>
-            <artifactId>okhttp</artifactId>
-            <version>${squareup-okhttp-version}</version>
-        </dependency>
-        <dependency>
-            <groupId>com.squareup.okio</groupId>
-            <artifactId>okio</artifactId>
-            <version>${squareup-okio-version}</version>
+         <groupId>com.squareup.okhttp3</groupId>
+         <artifactId>okhttp</artifactId>
+         <version>${squareup-okhttp-pubnub-version}</version>
         </dependency>
         <dependency>
             <groupId>com.google.code.gson</groupId>
diff --git a/components/camel-swagger-java/pom.xml b/components/camel-swagger-java/pom.xml
index e79bd09..931f556 100644
--- a/components/camel-swagger-java/pom.xml
+++ b/components/camel-swagger-java/pom.xml
@@ -78,7 +78,7 @@
         <dependency>
             <groupId>com.google.guava</groupId>
             <artifactId>guava</artifactId>
-            <version>${google-guava-version}</version>
+            <version>${swagger-java-guava-version}</version>
         </dependency>
         <dependency>
             <groupId>org.apache.commons</groupId>
diff --git a/examples/camel-example-grpc-kubernetes/hello-camel-grpc-client-kubernetes/pom.xml b/examples/camel-example-grpc-kubernetes/hello-camel-grpc-client-kubernetes/pom.xml
index 5fcf6a6..7e457a9 100644
--- a/examples/camel-example-grpc-kubernetes/hello-camel-grpc-client-kubernetes/pom.xml
+++ b/examples/camel-example-grpc-kubernetes/hello-camel-grpc-client-kubernetes/pom.xml
@@ -35,6 +35,8 @@
     <properties>
         <category>Cloud</category>
         <spring.boot-version>${spring-boot-version}</spring.boot-version>
+        <!-- gRPC requires strong own of the Google Guava version -->
+        <google-guava-version>${grpc-guava-version}</google-guava-version>
     </properties>
 
     <!-- Spring-Boot and Camel BOM -->
diff --git a/examples/camel-example-grpc-kubernetes/hello-camel-grpc-server-kubernetes/pom.xml b/examples/camel-example-grpc-kubernetes/hello-camel-grpc-server-kubernetes/pom.xml
index 9b6dc7e..fa36003 100644
--- a/examples/camel-example-grpc-kubernetes/hello-camel-grpc-server-kubernetes/pom.xml
+++ b/examples/camel-example-grpc-kubernetes/hello-camel-grpc-server-kubernetes/pom.xml
@@ -33,6 +33,8 @@
 
     <properties>
         <main.class>org.apache.camel.examples.grpc.HelloCamelServer</main.class>
+        <!-- gRPC requires strong own of the Google Guava version -->
+        <google-guava-version>${grpc-guava-version}</google-guava-version>
     </properties>
 
     <dependencies>
diff --git a/examples/camel-example-grpc-kubernetes/pom.xml b/examples/camel-example-grpc-kubernetes/pom.xml
index 6073c30..a27027e 100644
--- a/examples/camel-example-grpc-kubernetes/pom.xml
+++ b/examples/camel-example-grpc-kubernetes/pom.xml
@@ -36,6 +36,8 @@
     <properties>
         <category>Cloud</category>
         <title>gRPC Kubernetes</title>
+        <!-- gRPC requires strong own of the Google Guava version -->
+        <google-guava-version>${grpc-guava-version}</google-guava-version>
     </properties>
 
     <modules>
diff --git a/examples/camel-example-spring-boot-grpc/hello-camel-grpc-client/pom.xml b/examples/camel-example-spring-boot-grpc/hello-camel-grpc-client/pom.xml
index 849c2f6..bb0d80d 100644
--- a/examples/camel-example-spring-boot-grpc/hello-camel-grpc-client/pom.xml
+++ b/examples/camel-example-spring-boot-grpc/hello-camel-grpc-client/pom.xml
@@ -35,6 +35,8 @@
     <properties>
         <category>Cloud</category>
         <spring.boot-version>${spring-boot-version}</spring.boot-version>
+        <!-- gRPC requires strong own of the Google Guava version -->
+        <google-guava-version>${grpc-guava-version}</google-guava-version>
     </properties>
 
     <!-- Spring-Boot and Camel BOM -->
diff --git a/examples/camel-example-spring-boot-grpc/hello-camel-grpc-server/pom.xml b/examples/camel-example-spring-boot-grpc/hello-camel-grpc-server/pom.xml
index 734ab60..013688e 100644
--- a/examples/camel-example-spring-boot-grpc/hello-camel-grpc-server/pom.xml
+++ b/examples/camel-example-spring-boot-grpc/hello-camel-grpc-server/pom.xml
@@ -32,6 +32,8 @@
     <description>An example showing a simple gRPC server</description>
 
     <properties>
+        <!-- gRPC requires strong own of the Google Guava version -->
+        <google-guava-version>${grpc-guava-version}</google-guava-version>
     </properties>
 
     <dependencies>
diff --git a/parent/pom.xml b/parent/pom.xml
index b8d93ee..0e0c2f1 100644
--- a/parent/pom.xml
+++ b/parent/pom.xml
@@ -93,7 +93,7 @@
         <axiom-version>1.2.14</axiom-version>
         <azure-storage-java-sdk-version>8.4.0</azure-storage-java-sdk-version>
         <azure-storage-java-sdk-bundle-version>8.4.0_1</azure-storage-java-sdk-bundle-version>
-        <azure-guava-osgi-version>20.0</azure-guava-osgi-version>
+        <azure-guava-version>20.0</azure-guava-version>
         <backport-util-concurrent-version>3.1</backport-util-concurrent-version>
         <bcel-bundle-version>5.2_4</bcel-bundle-version>
         <beanio-version>2.1.0</beanio-version>
@@ -228,7 +228,7 @@
         <geronimo-jta-spec-version>1.1.1</geronimo-jta-spec-version>
         <geronimo-ws-metadata-spec-version>1.1.3</geronimo-ws-metadata-spec-version>
         <gmetric4j-version>1.0.10</gmetric4j-version>
-        <google-guava-version>27.1-jre</google-guava-version>
+        <google-guava-version>19.0</google-guava-version>
         <google-api-client-version>1.22.0</google-api-client-version>
         <google-api-services-drive-version>v2-rev297-1.22.0</google-api-services-drive-version>
         <google-api-services-calendar-version>v3-rev291-1.22.0</google-api-services-calendar-version>
@@ -242,7 +242,7 @@
         <grizzly-websockets-version>2.3.25</grizzly-websockets-version>
         <grpc-version>1.24.1</grpc-version>
         <grpc-google-auth-library-version>0.13.0</grpc-google-auth-library-version>
-        <grpc-guava-osgi-version>26.0-android</grpc-guava-osgi-version>
+        <grpc-guava-version>26.0-android</grpc-guava-version>
         <grpc-java-jwt-version>3.7.0</grpc-java-jwt-version>
         <grpc-netty-tcnative-boringssl-static-version>2.0.26.Final</grpc-netty-tcnative-boringssl-static-version>
         <grpc-bundle-version>1.24.1_1</grpc-bundle-version>
@@ -285,7 +285,7 @@
         <infinispan-spring-boot-version>2.1.7.Final</infinispan-spring-boot-version>
         <influx-java-driver-version>2.15</influx-java-driver-version>
         <influx-java-driver-bundle-version>2.15_1</influx-java-driver-bundle-version>
-        <influx-guava-osgi-version>20.0</influx-guava-osgi-version>
+        <influx-guava-version>20.0</influx-guava-version>
         <irclib-bundle-version>1.10_5</irclib-bundle-version>
         <irclib-version>1.10</irclib-version>
         <ironmq-version>3.0.5</ironmq-version>
@@ -357,6 +357,7 @@
         <jgroups-raft-version>0.5.0.Final</jgroups-raft-version>
         <jgroups-raft-leveldbjni-version>1.8</jgroups-raft-leveldbjni-version>
         <jgroups-raft-mapdb-version>1.0.8</jgroups-raft-mapdb-version>
+        <jira-guava-version>26.0-jre</jira-guava-version>
         <jira-rest-client-api-version>5.1.6</jira-rest-client-api-version>
         <libthrift-version>0.12.0</libthrift-version>
         <jing-bundle-version>20030619_5</jing-bundle-version>
@@ -408,7 +409,7 @@
         <leveldbjni-version>1.8</leveldbjni-version>
         <leveldb-api-version>0.10</leveldb-api-version>
         <leveldb-version>0.10</leveldb-version>
-        <leveldb-guava-osgi-version>21.0</leveldb-guava-osgi-version>
+        <leveldb-guava-version>21.0</leveldb-guava-version>
         <libphonenumber-version>8.10.21</libphonenumber-version>
         <libphonenumber-bundle-version>8.10.21_1</libphonenumber-bundle-version>
         <!-- virtual dependency only used by Eclipse m2e -->
@@ -467,7 +468,7 @@
         <mongo-hadoop-version>1.5.0</mongo-hadoop-version>
         <msv-version>2013.6.1</msv-version>
         <mustache-java-version>0.9.6</mustache-java-version>
-        <mustache-guava-osgi-version>20.0</mustache-guava-osgi-version>
+        <mustache-guava-version>20.0</mustache-guava-version>
         <mustache-bundle-version>0.9.6_1</mustache-bundle-version>
         <mvel-version>2.4.4.Final</mvel-version>
         <mybatis-version>3.5.3</mybatis-version>
@@ -519,7 +520,7 @@
         <pgjdbc-ng-driver-version>0.8.2</pgjdbc-ng-driver-version>
         <properties-maven-plugin-version>1.0-alpha-2</properties-maven-plugin-version>
         <protobuf-version>3.9.1</protobuf-version>
-        <protobuf-guava-osgi-version>26.0-android</protobuf-guava-osgi-version>
+        <protobuf-guava-version>26.0-android</protobuf-guava-version>
         <protobuf-javanano-version>3.1.0</protobuf-javanano-version>
         <protobuf-maven-plugin-version>0.6.1</protobuf-maven-plugin-version>
         <protonpack-version>1.8</protonpack-version>
@@ -605,8 +606,7 @@
         <spymemcached-bundle-version>2.5_2</spymemcached-bundle-version> <!-- FIXME cmueller: not in sync! -->
         <spymemcached-version>2.12.0</spymemcached-version>
         <sql-maven-plugin-version>1.5</sql-maven-plugin-version>
-        <squareup-okhttp-version>3.12.0</squareup-okhttp-version>
-        <squareup-okio-version>1.15.0</squareup-okio-version>
+        <squareup-okhttp-pubnub-version>3.12.0</squareup-okhttp-pubnub-version>
         <squareup-okhttp-bundle-version>2.7.5_1</squareup-okhttp-bundle-version>
         <squareup-okio-bundle-version>1.15.0_1</squareup-okio-bundle-version>
         <squareup-retrofit2-bundle-version>2.5.0_2</squareup-retrofit2-bundle-version>
@@ -614,6 +614,7 @@
         <stompjms-version>1.19</stompjms-version>
         <swagger-java-version>1.5.24</swagger-java-version>
         <swagger-java-parser-version>1.0.47</swagger-java-parser-version>
+        <swagger-java-guava-version>27.1-jre</swagger-java-guava-version>
         <stax-api-version>1.0.1</stax-api-version>
         <stax2-api-bundle-version>3.1.4</stax2-api-bundle-version>
         <stax2v4-api-bundle-version>4.2</stax2v4-api-bundle-version>
diff --git a/platforms/karaf/features/src/main/resources/features.xml b/platforms/karaf/features/src/main/resources/features.xml
index 3e0c5ab..de6642a 100644
--- a/platforms/karaf/features/src/main/resources/features.xml
+++ b/platforms/karaf/features/src/main/resources/features.xml
@@ -563,7 +563,7 @@
     <feature version='${project.version}'>camel-core</feature>
     <bundle dependency='true'>mvn:com.fasterxml.jackson.core/jackson-core/${jackson2-version}</bundle>
     <bundle dependency='true'>mvn:org.apache.commons/commons-lang3/${commons-lang3-version}</bundle>
-    <bundle dependency='true'>mvn:com.google.guava/guava/${azure-guava-osgi-version}</bundle>
+    <bundle dependency='true'>mvn:com.google.guava/guava/${azure-guava-version}</bundle>
     <bundle dependency='true'>mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.azure-storage/${azure-storage-java-sdk-bundle-version}</bundle>
     <bundle>mvn:org.apache.camel/camel-azure/${project.version}</bundle>
   </feature>
@@ -1195,7 +1195,7 @@
     <bundle dependency='true'>mvn:io.netty/netty-resolver/${netty-version}</bundle>
     <bundle dependency='true'>mvn:io.netty/netty-transport/${netty-version}</bundle>
     <bundle dependency='true'>mvn:io.netty/netty-tcnative-boringssl-static/${grpc-netty-tcnative-boringssl-static-version}</bundle>
-    <bundle dependency='true'>mvn:com.google.guava/guava/${grpc-guava-osgi-version}</bundle>
+    <bundle dependency='true'>mvn:com.google.guava/guava/${grpc-guava-version}</bundle>
     <bundle dependency='true'>wrap:mvn:com.google.errorprone/error_prone_annotations/${grpc-errorprone-version}</bundle>
     <!-- Third party dependencies -->
     <bundle dependency='true'>mvn:org.javassist/javassist/${javassist-version}</bundle>
@@ -1356,7 +1356,7 @@
   </feature>
   <feature name='camel-influxdb' version='${project.version}' start-level='50'>
     <bundle dependency='true'>mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.influxdb-java/${influx-java-driver-bundle-version}</bundle>
-    <bundle dependency='true'>mvn:com.google.guava/guava/${influx-guava-osgi-version}</bundle>
+    <bundle dependency='true'>mvn:com.google.guava/guava/${influx-guava-version}</bundle>
     <bundle dependency='true'>mvn:com.google.code.findbugs/jsr305/${google-findbugs-jsr305-version}</bundle>
     <bundle dependency='true'>mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.okhttp/${okclient-bundle-version}</bundle>
     <bundle dependency='true'>mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.retrofit/${squareup-retrofit2-bundle-version}</bundle>
@@ -1701,7 +1701,7 @@
   </feature>
   <feature name='camel-leveldb-java' version='${project.version}' start-level='50'>
     <feature version='${project.version}'>camel-core</feature>
-    <bundle dependency='true'>mvn:com.google.guava/guava/${leveldb-guava-osgi-version}</bundle>
+    <bundle dependency='true'>mvn:com.google.guava/guava/${leveldb-guava-version}</bundle>
     <bundle dependency='true'>wrap:mvn:org.iq80.leveldb/leveldb-api/${leveldb-api-version}$Bundle-Version=${leveldb-api-version}&amp;Export-Package=*;-noimport:=true;version="${leveldb-api-version}"</bundle>
     <bundle dependency='true'>wrap:mvn:org.iq80.leveldb/leveldb/${leveldb-version}$Bundle-Version=${leveldb-version}&amp;Export-Package=*;-noimport:=true;version="${leveldb-version}"</bundle>
     <bundle dependency='true'>mvn:org.fusesource.hawtbuf/hawtbuf/${hawtbuf-version}</bundle>
@@ -1826,7 +1826,7 @@
   <feature name='camel-mustache' version='${project.version}' start-level='50'>
     <feature version='${project.version}'>camel-core</feature>
     <bundle dependency='true'>mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.mustache-compiler/${mustache-bundle-version}</bundle>
-    <bundle dependency='true'>mvn:com.google.guava/guava/${mustache-guava-osgi-version}</bundle>
+    <bundle dependency='true'>mvn:com.google.guava/guava/${mustache-guava-version}</bundle>
     <bundle>mvn:org.apache.camel/camel-mustache/${project.version}</bundle>
   </feature>
   <feature name='camel-mvel' version='${project.version}' start-level='50'>
@@ -2056,7 +2056,7 @@
     <bundle dependency='true'>mvn:com.google.protobuf/protobuf-java/${protobuf-version}</bundle>
     <bundle dependency='true'>mvn:com.google.protobuf/protobuf-java-util/${protobuf-version}</bundle>
     <bundle dependency='true'>mvn:commons-io/commons-io/${commons-io-version}</bundle>
-    <bundle dependency='true'>mvn:com.google.guava/guava/${protobuf-guava-osgi-version}</bundle>
+    <bundle dependency='true'>mvn:com.google.guava/guava/${protobuf-guava-version}</bundle>
     <bundle dependency='true'>mvn:com.google.code.gson/gson/${gson-version}</bundle>
     <bundle>mvn:org.apache.camel/camel-protobuf/${project.version}</bundle>
   </feature>
@@ -2122,7 +2122,7 @@
     <bundle dependency='true'>mvn:com.fasterxml.jackson.module/jackson-module-jaxb-annotations/${jackson2-version}</bundle>
     <bundle dependency='true'>mvn:com.fasterxml.jackson.module/jackson-module-jsonSchema/${jackson2-version}</bundle>
     <bundle dependency='true'>mvn:org.apache.commons/commons-lang3/${commons-lang3-version}</bundle>
-    <bundle dependency='true'>mvn:com.google.guava/guava/${google-guava-version}</bundle>
+    <bundle dependency='true'>mvn:com.google.guava/guava/${swagger-java-guava-version}</bundle>
     <bundle dependency='true'>mvn:com.google.guava/failureaccess/1.0.1</bundle>
     <bundle dependency='true'>mvn:io.swagger/swagger-core/${swagger-java-version}</bundle>
     <bundle dependency='true'>mvn:io.swagger/swagger-annotations/${swagger-java-version}</bundle>
@@ -2454,7 +2454,7 @@
     <bundle dependency='true'>mvn:org.yaml/snakeyaml/${snakeyaml-version}</bundle>
     <bundle dependency='true'>mvn:javax.validation/validation-api/${validation-1-api-version}</bundle>
     <bundle dependency='true'>mvn:org.apache.commons/commons-lang3/${commons-lang3-version}</bundle>
-    <bundle dependency='true'>mvn:com.google.guava/guava/${google-guava-version}</bundle>
+    <bundle dependency='true'>mvn:com.google.guava/guava/${swagger-java-guava-version}</bundle>
     <bundle dependency='true'>mvn:com.google.guava/failureaccess/1.0.1</bundle>
     <bundle dependency='true'>mvn:io.swagger/swagger-core/${swagger-java-version}</bundle>
     <bundle dependency='true'>mvn:io.swagger/swagger-annotations/${swagger-java-version}</bundle>