[jira] Created: (CAMEL-561) some samples' poms are using apache-activemq module which will introduce some lower version of Spring and wstx-asl to the eclipse workspace

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

[jira] Created: (CAMEL-561) some samples' poms are using apache-activemq module which will introduce some lower version of Spring and wstx-asl to the eclipse workspace

JIRA jira@apache.org
some samples' poms are using apache-activemq module which will introduce some lower version of Spring and wstx-asl to the eclipse workspace
-------------------------------------------------------------------------------------------------------------------------------------------

                 Key: CAMEL-561
                 URL: https://issues.apache.org/activemq/browse/CAMEL-561
             Project: Apache Camel
          Issue Type: Bug
          Components: examples
    Affects Versions: 1.3.0
            Reporter: Willem Jiang
            Assignee: Willem Jiang
             Fix For: 1.4.0


When using mvn eclipse:eclipse to setup the workspace for camel example to run.
I found some camel-cxf related example can't work in eclipse which is caused by using the lower version of wstx-asl.

We can using the activemq-core instead of apache-activemq to fix this issue.

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

Reply | Threaded
Open this post in threaded view
|

[jira] Resolved: (CAMEL-561) some samples' poms are using apache-activemq module which will introduce some lower version of Spring and wstx-asl to the eclipse workspace

JIRA jira@apache.org

     [ https://issues.apache.org/activemq/browse/CAMEL-561?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Willem Jiang resolved CAMEL-561.
--------------------------------

    Resolution: Fixed

The patch is in the trunk now.

> some samples' poms are using apache-activemq module which will introduce some lower version of Spring and wstx-asl to the eclipse workspace
> -------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: CAMEL-561
>                 URL: https://issues.apache.org/activemq/browse/CAMEL-561
>             Project: Apache Camel
>          Issue Type: Bug
>          Components: examples
>    Affects Versions: 1.3.0
>            Reporter: Willem Jiang
>            Assignee: Willem Jiang
>             Fix For: 1.4.0
>
>
> When using mvn eclipse:eclipse to setup the workspace for camel example to run.
> I found some camel-cxf related example can't work in eclipse which is caused by using the lower version of wstx-asl.
> We can using the activemq-core instead of apache-activemq to fix this issue.

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

Reply | Threaded
Open this post in threaded view
|

[jira] Commented: (CAMEL-561) some samples' poms are using apache-activemq module which will introduce some lower version of Spring and wstx-asl to the eclipse workspace

JIRA jira@apache.org
In reply to this post by JIRA jira@apache.org

    [ https://issues.apache.org/activemq/browse/CAMEL-561?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=43128#action_43128 ]

Claus Ibsen commented on CAMEL-561:
-----------------------------------

camel-example-spring-xquery was using the big instead of the core so I am changing it to use activemq-core

> some samples' poms are using apache-activemq module which will introduce some lower version of Spring and wstx-asl to the eclipse workspace
> -------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: CAMEL-561
>                 URL: https://issues.apache.org/activemq/browse/CAMEL-561
>             Project: Apache Camel
>          Issue Type: Bug
>          Components: examples
>    Affects Versions: 1.3.0
>            Reporter: Willem Jiang
>            Assignee: Willem Jiang
>             Fix For: 1.4.0
>
>
> When using mvn eclipse:eclipse to setup the workspace for camel example to run.
> I found some camel-cxf related example can't work in eclipse which is caused by using the lower version of wstx-asl.
> We can using the activemq-core instead of apache-activemq to fix this issue.

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

Reply | Threaded
Open this post in threaded view
|

[jira] Commented: (CAMEL-561) some samples' poms are using apache-activemq module which will introduce some lower version of Spring and wstx-asl to the eclipse workspace

JIRA jira@apache.org
In reply to this post by JIRA jira@apache.org

    [ https://issues.apache.org/activemq/browse/CAMEL-561?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=43129#action_43129 ]

Claus Ibsen commented on CAMEL-561:
-----------------------------------

Hmm some of the ActiveMQ is dependent on Spring 1.2.8

Downloading: http://people.apache.org/repo/m2-ibiblio-rsync-repository/org/springframework/spring/1.2.8/spring-1.2.8.jar
Downloading: http://repo1.maven.org/maven2//org/springframework/spring/1.2.8/spring-1.2.8.jar
1887K downloaded

> some samples' poms are using apache-activemq module which will introduce some lower version of Spring and wstx-asl to the eclipse workspace
> -------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: CAMEL-561
>                 URL: https://issues.apache.org/activemq/browse/CAMEL-561
>             Project: Apache Camel
>          Issue Type: Bug
>          Components: examples
>    Affects Versions: 1.3.0
>            Reporter: Willem Jiang
>            Assignee: Willem Jiang
>             Fix For: 1.4.0
>
>
> When using mvn eclipse:eclipse to setup the workspace for camel example to run.
> I found some camel-cxf related example can't work in eclipse which is caused by using the lower version of wstx-asl.
> We can using the activemq-core instead of apache-activemq to fix this issue.

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

Reply | Threaded
Open this post in threaded view
|

[jira] Issue Comment Edited: (CAMEL-561) some samples' poms are using apache-activemq module which will introduce some lower version of Spring and wstx-asl to the eclipse workspace

JIRA jira@apache.org
In reply to this post by JIRA jira@apache.org

    [ https://issues.apache.org/activemq/browse/CAMEL-561?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=43129#action_43129 ]

davsclaus edited comment on CAMEL-561 at 5/31/08 12:30 AM:
-------------------------------------------------------------

Hmm some of the ActiveMQ is dependent on Spring 1.2.8

Downloading: http://people.apache.org/repo/m2-ibiblio-rsync-repository/org/springframework/spring/1.2.8/spring-1.2.8.jar
Downloading: http://repo1.maven.org/maven2//org/springframework/spring/1.2.8/spring-1.2.8.jar
1887K downloaded

This is with activemq-5.1.0 btw that I am trying to upgrade to in Camel.

      was (Author: davsclaus):
    Hmm some of the ActiveMQ is dependent on Spring 1.2.8

Downloading: http://people.apache.org/repo/m2-ibiblio-rsync-repository/org/springframework/spring/1.2.8/spring-1.2.8.jar
Downloading: http://repo1.maven.org/maven2//org/springframework/spring/1.2.8/spring-1.2.8.jar
1887K downloaded
 

> some samples' poms are using apache-activemq module which will introduce some lower version of Spring and wstx-asl to the eclipse workspace
> -------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: CAMEL-561
>                 URL: https://issues.apache.org/activemq/browse/CAMEL-561
>             Project: Apache Camel
>          Issue Type: Bug
>          Components: examples
>    Affects Versions: 1.3.0
>            Reporter: Willem Jiang
>            Assignee: Willem Jiang
>             Fix For: 1.4.0
>
>
> When using mvn eclipse:eclipse to setup the workspace for camel example to run.
> I found some camel-cxf related example can't work in eclipse which is caused by using the lower version of wstx-asl.
> We can using the activemq-core instead of apache-activemq to fix this issue.

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

Reply | Threaded
Open this post in threaded view
|

[jira] Closed: (CAMEL-561) some samples' poms are using apache-activemq module which will introduce some lower version of Spring and wstx-asl to the eclipse workspace

JIRA jira@apache.org
In reply to this post by JIRA jira@apache.org

     [ https://issues.apache.org/activemq/browse/CAMEL-561?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Willem Jiang closed CAMEL-561.
------------------------------


> some samples' poms are using apache-activemq module which will introduce some lower version of Spring and wstx-asl to the eclipse workspace
> -------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: CAMEL-561
>                 URL: https://issues.apache.org/activemq/browse/CAMEL-561
>             Project: Apache Camel
>          Issue Type: Bug
>          Components: examples
>    Affects Versions: 1.3.0
>            Reporter: Willem Jiang
>            Assignee: Willem Jiang
>             Fix For: 1.4.0
>
>
> When using mvn eclipse:eclipse to setup the workspace for camel example to run.
> I found some camel-cxf related example can't work in eclipse which is caused by using the lower version of wstx-asl.
> We can using the activemq-core instead of apache-activemq to fix this issue.

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.