problem running camel-example-etl from camel 1.3.0 unix/cygwin binary distro

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

problem running camel-example-etl from camel 1.3.0 unix/cygwin binary distro

volenin
Hi,

I'm trying to run some example apps from Camel distro, but it seems like
Maven config is a bit corrupted OR I'm doing smth wrong...

I've downloaded and setup all environment variables for the packages:
ActiveMQ 5.1.0 -- unix/cygwin distro, Camel 1.3.0 -- unix/cygwin distro. I'm
trying to run an ETL example from the camel distro from under Cygwin running
under Windows XP. I'm using the 'mvn camel:run' command.

I'm getting the following error:
-------
this realm = plexus.core
urls[0] = file:/c:/tools/apache-maven-2.0.8/lib/maven-2.0.8-uber.jar
Number of imports: 6
import: org.codehaus.classworlds.Entry@4891bb28
import: org.codehaus.classworlds.Entry@f8e44ca4
import: org.codehaus.classworlds.Entry@c51bc9e7
import: org.codehaus.classworlds.Entry@bece5185
import: org.codehaus.classworlds.Entry@3fee8e37
import: org.codehaus.classworlds.Entry@3fee19d8
-----------------------------------------------------
[INFO]
------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO]
------------------------------------------------------------------------
[INFO] Internal error in the plugin manager executing goal
'org.apache.camel:cam
el-maven-plugin:1.4.0.0-fuse:run': Unable to find the mojo
'org.apache.camel:cam
el-maven-plugin:1.4.0.0-fuse:run' in the plugin
'org.apache.camel:camel-maven-pl
ugin'
org/codehaus/mojo/exec/AbstractExecMojo
[INFO]
------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO]
------------------------------------------------------------------------
-------

Does anyone have idea what is wrong?

Thanks,

Vlad
Reply | Threaded
Open this post in threaded view
|

Re: problem running camel-example-etl from camel 1.3.0 unix/cygwin binary distro

Jon Anstey
This was an issue in the 1.3.0 release. It is fixed (see
https://issues.apache.org/activemq/browse/CAMEL-598) in the trunk. So, the
latest SNAPSHOT should be good-to-go.

Cheers,
Jon

On Wed, Jun 25, 2008 at 7:59 PM, Vlad Olenin <[hidden email]> wrote:

> Hi,
>
> I'm trying to run some example apps from Camel distro, but it seems like
> Maven config is a bit corrupted OR I'm doing smth wrong...
>
> I've downloaded and setup all environment variables for the packages:
> ActiveMQ 5.1.0 -- unix/cygwin distro, Camel 1.3.0 -- unix/cygwin distro.
> I'm
> trying to run an ETL example from the camel distro from under Cygwin
> running
> under Windows XP. I'm using the 'mvn camel:run' command.
>
> I'm getting the following error:
> -------
> this realm = plexus.core
> urls[0] = file:/c:/tools/apache-maven-2.0.8/lib/maven-2.0.8-uber.jar
> Number of imports: 6
> import: org.codehaus.classworlds.Entry@4891bb28
> import: org.codehaus.classworlds.Entry@f8e44ca4
> import: org.codehaus.classworlds.Entry@c51bc9e7
> import: org.codehaus.classworlds.Entry@bece5185
> import: org.codehaus.classworlds.Entry@3fee8e37
> import: org.codehaus.classworlds.Entry@3fee19d8
> -----------------------------------------------------
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Internal error in the plugin manager executing goal
> 'org.apache.camel:cam
> el-maven-plugin:1.4.0.0-fuse:run': Unable to find the mojo
> 'org.apache.camel:cam
> el-maven-plugin:1.4.0.0-fuse:run' in the plugin
> 'org.apache.camel:camel-maven-pl
> ugin'
> org/codehaus/mojo/exec/AbstractExecMojo
> [INFO]
> ------------------------------------------------------------------------
> [INFO] For more information, run Maven with the -e switch
> [INFO]
> ------------------------------------------------------------------------
> -------
>
> Does anyone have idea what is wrong?
>
> Thanks,
>
> Vlad
>
Reply | Threaded
Open this post in threaded view
|

Re: problem running camel-example-etl from camel 1.3.0 unix/cygwin binary distro

Willem.Jiang
Administrator
In reply to this post by volenin
If your using Camel 1.3.0 ,  it should not use

org.apache.camel:camel-maven-plugin:1.4.0.0-fuse:

Did you run the sample in Camel fuse version 1.4.0.0 ?

Willem

Vlad Olenin wrote:

> Hi,
>
> I'm trying to run some example apps from Camel distro, but it seems like
> Maven config is a bit corrupted OR I'm doing smth wrong...
>
> I've downloaded and setup all environment variables for the packages:
> ActiveMQ 5.1.0 -- unix/cygwin distro, Camel 1.3.0 -- unix/cygwin distro. I'm
> trying to run an ETL example from the camel distro from under Cygwin running
> under Windows XP. I'm using the 'mvn camel:run' command.
>
> I'm getting the following error:
> -------
> this realm = plexus.core
> urls[0] = file:/c:/tools/apache-maven-2.0.8/lib/maven-2.0.8-uber.jar
> Number of imports: 6
> import: org.codehaus.classworlds.Entry@4891bb28
> import: org.codehaus.classworlds.Entry@f8e44ca4
> import: org.codehaus.classworlds.Entry@c51bc9e7
> import: org.codehaus.classworlds.Entry@bece5185
> import: org.codehaus.classworlds.Entry@3fee8e37
> import: org.codehaus.classworlds.Entry@3fee19d8
> -----------------------------------------------------
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Internal error in the plugin manager executing goal
> 'org.apache.camel:cam
> el-maven-plugin:1.4.0.0-fuse:run': Unable to find the mojo
> 'org.apache.camel:cam
> el-maven-plugin:1.4.0.0-fuse:run' in the plugin
> 'org.apache.camel:camel-maven-pl
> ugin'
> org/codehaus/mojo/exec/AbstractExecMojo
> [INFO]
> ------------------------------------------------------------------------
> [INFO] For more information, run Maven with the -e switch
> [INFO]
> ------------------------------------------------------------------------
> -------
>
> Does anyone have idea what is wrong?
>
> Thanks,
>
> Vlad
>
>  

Reply | Threaded
Open this post in threaded view
|

Re: problem running camel-example-etl from camel 1.3.0 unix/cygwin binary distro

volenin
Nope, I'm not using Camel fuse. I downloaded and setup ActiveMQ 5.1.0,
setting env. var ACTIVEMQ_HOME to the directory the Jms broker is installed
at. I downloaded Camel 1.3.0 distro from Apache website, went to the
'examples/camel-example-etl' directory and exectuted the command. I'll try
the latest snapshot... Would the example work with Camel 1.3.0 binaries
though? If not, what's the ETA for the 1.4.0 'stable' release? Is there any
easy way to patch the maven config file to make the examples runnable from
the 1.3.0 distro?

Thanks,

Vlad


On Wed, Jun 25, 2008 at 9:22 PM, Willem Jiang <[hidden email]>
wrote:

> If your using Camel 1.3.0 ,  it should not use
> org.apache.camel:camel-maven-plugin:1.4.0.0-fuse:
>
> Did you run the sample in Camel fuse version 1.4.0.0 ?
>
> Willem
>
>
> Vlad Olenin wrote:
>
>> Hi,
>>
>> I'm trying to run some example apps from Camel distro, but it seems like
>> Maven config is a bit corrupted OR I'm doing smth wrong...
>>
>> I've downloaded and setup all environment variables for the packages:
>> ActiveMQ 5.1.0 -- unix/cygwin distro, Camel 1.3.0 -- unix/cygwin distro.
>> I'm
>> trying to run an ETL example from the camel distro from under Cygwin
>> running
>> under Windows XP. I'm using the 'mvn camel:run' command.
>>
>> I'm getting the following error:
>> -------
>> this realm = plexus.core
>> urls[0] = file:/c:/tools/apache-maven-2.0.8/lib/maven-2.0.8-uber.jar
>> Number of imports: 6
>> import: org.codehaus.classworlds.Entry@4891bb28
>> import: org.codehaus.classworlds.Entry@f8e44ca4
>> import: org.codehaus.classworlds.Entry@c51bc9e7
>> import: org.codehaus.classworlds.Entry@bece5185
>> import: org.codehaus.classworlds.Entry@3fee8e37
>> import: org.codehaus.classworlds.Entry@3fee19d8
>> -----------------------------------------------------
>> [INFO]
>> ------------------------------------------------------------------------
>> [ERROR] BUILD ERROR
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] Internal error in the plugin manager executing goal
>> 'org.apache.camel:cam
>> el-maven-plugin:1.4.0.0-fuse:run': Unable to find the mojo
>> 'org.apache.camel:cam
>> el-maven-plugin:1.4.0.0-fuse:run' in the plugin
>> 'org.apache.camel:camel-maven-pl
>> ugin'
>> org/codehaus/mojo/exec/AbstractExecMojo
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] For more information, run Maven with the -e switch
>> [INFO]
>> ------------------------------------------------------------------------
>> -------
>>
>> Does anyone have idea what is wrong?
>>
>> Thanks,
>>
>> Vlad
>>
>>
>>
>
>
Reply | Threaded
Open this post in threaded view
|

Re: problem running camel-example-etl from camel 1.3.0 unix/cygwin binary distro

Jon Anstey
In reply to this post by Willem.Jiang
Willem,

Before CAMEL-598 was fixed I got a similar error with the 1.4.0 release
candidate... I believe in my case it was downloading the 1.3.6.0-fuse
version though. It scared me a bit, to say the least :) My best guess is
that maven got sufficiently confused and started downloading a plugin from
here (defined in camel-parent):

<pluginRepository>
<id>open.iona.m2</id>
<name>IONA Open Source Community Dependency Repository</name>
<url>http://repo.open.iona.com/maven2</url>
...

Cheers,
Jon


On Wed, Jun 25, 2008 at 10:52 PM, Willem Jiang <[hidden email]>
wrote:

> If your using Camel 1.3.0 ,  it should not use
> org.apache.camel:camel-maven-plugin:1.4.0.0-fuse:
>
> Did you run the sample in Camel fuse version 1.4.0.0 ?
>
> Willem
>
>
> Vlad Olenin wrote:
>
>> Hi,
>>
>> I'm trying to run some example apps from Camel distro, but it seems like
>> Maven config is a bit corrupted OR I'm doing smth wrong...
>>
>> I've downloaded and setup all environment variables for the packages:
>> ActiveMQ 5.1.0 -- unix/cygwin distro, Camel 1.3.0 -- unix/cygwin distro.
>> I'm
>> trying to run an ETL example from the camel distro from under Cygwin
>> running
>> under Windows XP. I'm using the 'mvn camel:run' command.
>>
>> I'm getting the following error:
>> -------
>> this realm = plexus.core
>> urls[0] = file:/c:/tools/apache-maven-2.0.8/lib/maven-2.0.8-uber.jar
>> Number of imports: 6
>> import: org.codehaus.classworlds.Entry@4891bb28
>> import: org.codehaus.classworlds.Entry@f8e44ca4
>> import: org.codehaus.classworlds.Entry@c51bc9e7
>> import: org.codehaus.classworlds.Entry@bece5185
>> import: org.codehaus.classworlds.Entry@3fee8e37
>> import: org.codehaus.classworlds.Entry@3fee19d8
>> -----------------------------------------------------
>> [INFO]
>> ------------------------------------------------------------------------
>> [ERROR] BUILD ERROR
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] Internal error in the plugin manager executing goal
>> 'org.apache.camel:cam
>> el-maven-plugin:1.4.0.0-fuse:run': Unable to find the mojo
>> 'org.apache.camel:cam
>> el-maven-plugin:1.4.0.0-fuse:run' in the plugin
>> 'org.apache.camel:camel-maven-pl
>> ugin'
>> org/codehaus/mojo/exec/AbstractExecMojo
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] For more information, run Maven with the -e switch
>> [INFO]
>> ------------------------------------------------------------------------
>> -------
>>
>> Does anyone have idea what is wrong?
>>
>> Thanks,
>>
>> Vlad
>>
>>
>>
>
>
Reply | Threaded
Open this post in threaded view
|

Re: problem running camel-example-etl from camel 1.3.0 unix/cygwin binary distro

Jon Anstey
In reply to this post by volenin
AFAIK there is not much left to do for the 1.4.0 release... I would expect a
release candidate to go out within a week.

Cheers,
Jon

On Wed, Jun 25, 2008 at 11:02 PM, Vlad Olenin <[hidden email]> wrote:

> Nope, I'm not using Camel fuse. I downloaded and setup ActiveMQ 5.1.0,
> setting env. var ACTIVEMQ_HOME to the directory the Jms broker is installed
> at. I downloaded Camel 1.3.0 distro from Apache website, went to the
> 'examples/camel-example-etl' directory and exectuted the command. I'll try
> the latest snapshot... Would the example work with Camel 1.3.0 binaries
> though? If not, what's the ETA for the 1.4.0 'stable' release? Is there any
> easy way to patch the maven config file to make the examples runnable from
> the 1.3.0 distro?
>
> Thanks,
>
> Vlad
>
>
> On Wed, Jun 25, 2008 at 9:22 PM, Willem Jiang <[hidden email]>
> wrote:
>
> > If your using Camel 1.3.0 ,  it should not use
> > org.apache.camel:camel-maven-plugin:1.4.0.0-fuse:
> >
> > Did you run the sample in Camel fuse version 1.4.0.0 ?
> >
> > Willem
> >
> >
> > Vlad Olenin wrote:
> >
> >> Hi,
> >>
> >> I'm trying to run some example apps from Camel distro, but it seems like
> >> Maven config is a bit corrupted OR I'm doing smth wrong...
> >>
> >> I've downloaded and setup all environment variables for the packages:
> >> ActiveMQ 5.1.0 -- unix/cygwin distro, Camel 1.3.0 -- unix/cygwin distro.
> >> I'm
> >> trying to run an ETL example from the camel distro from under Cygwin
> >> running
> >> under Windows XP. I'm using the 'mvn camel:run' command.
> >>
> >> I'm getting the following error:
> >> -------
> >> this realm = plexus.core
> >> urls[0] = file:/c:/tools/apache-maven-2.0.8/lib/maven-2.0.8-uber.jar
> >> Number of imports: 6
> >> import: org.codehaus.classworlds.Entry@4891bb28
> >> import: org.codehaus.classworlds.Entry@f8e44ca4
> >> import: org.codehaus.classworlds.Entry@c51bc9e7
> >> import: org.codehaus.classworlds.Entry@bece5185
> >> import: org.codehaus.classworlds.Entry@3fee8e37
> >> import: org.codehaus.classworlds.Entry@3fee19d8
> >> -----------------------------------------------------
> >> [INFO]
> >> ------------------------------------------------------------------------
> >> [ERROR] BUILD ERROR
> >> [INFO]
> >> ------------------------------------------------------------------------
> >> [INFO] Internal error in the plugin manager executing goal
> >> 'org.apache.camel:cam
> >> el-maven-plugin:1.4.0.0-fuse:run': Unable to find the mojo
> >> 'org.apache.camel:cam
> >> el-maven-plugin:1.4.0.0-fuse:run' in the plugin
> >> 'org.apache.camel:camel-maven-pl
> >> ugin'
> >> org/codehaus/mojo/exec/AbstractExecMojo
> >> [INFO]
> >> ------------------------------------------------------------------------
> >> [INFO] For more information, run Maven with the -e switch
> >> [INFO]
> >> ------------------------------------------------------------------------
> >> -------
> >>
> >> Does anyone have idea what is wrong?
> >>
> >> Thanks,
> >>
> >> Vlad
> >>
> >>
> >>
> >
> >
>
Reply | Threaded
Open this post in threaded view
|

Re: problem running camel-example-etl from camel 1.3.0 unix/cygwin binary distro

Willem.Jiang
Administrator
In reply to this post by Jon Anstey
I got it, maven will download the latest released plugin from plugin
repository if the plugin is no version specified.

Willem

Jon Anstey wrote:

> Willem,
>
> Before CAMEL-598 was fixed I got a similar error with the 1.4.0 release
> candidate... I believe in my case it was downloading the 1.3.6.0-fuse
> version though. It scared me a bit, to say the least :) My best guess is
> that maven got sufficiently confused and started downloading a plugin from
> here (defined in camel-parent):
>
> <pluginRepository>
> <id>open.iona.m2</id>
> <name>IONA Open Source Community Dependency Repository</name>
> <url>http://repo.open.iona.com/maven2</url>
> ...
>
> Cheers,
> Jon
>
>
> On Wed, Jun 25, 2008 at 10:52 PM, Willem Jiang <[hidden email]>
> wrote:
>
>  
>> If your using Camel 1.3.0 ,  it should not use
>> org.apache.camel:camel-maven-plugin:1.4.0.0-fuse:
>>
>> Did you run the sample in Camel fuse version 1.4.0.0 ?
>>
>> Willem
>>
>>
>> Vlad Olenin wrote:
>>
>>    
>>> Hi,
>>>
>>> I'm trying to run some example apps from Camel distro, but it seems like
>>> Maven config is a bit corrupted OR I'm doing smth wrong...
>>>
>>> I've downloaded and setup all environment variables for the packages:
>>> ActiveMQ 5.1.0 -- unix/cygwin distro, Camel 1.3.0 -- unix/cygwin distro.
>>> I'm
>>> trying to run an ETL example from the camel distro from under Cygwin
>>> running
>>> under Windows XP. I'm using the 'mvn camel:run' command.
>>>
>>> I'm getting the following error:
>>> -------
>>> this realm = plexus.core
>>> urls[0] = file:/c:/tools/apache-maven-2.0.8/lib/maven-2.0.8-uber.jar
>>> Number of imports: 6
>>> import: org.codehaus.classworlds.Entry@4891bb28
>>> import: org.codehaus.classworlds.Entry@f8e44ca4
>>> import: org.codehaus.classworlds.Entry@c51bc9e7
>>> import: org.codehaus.classworlds.Entry@bece5185
>>> import: org.codehaus.classworlds.Entry@3fee8e37
>>> import: org.codehaus.classworlds.Entry@3fee19d8
>>> -----------------------------------------------------
>>> [INFO]
>>> ------------------------------------------------------------------------
>>> [ERROR] BUILD ERROR
>>> [INFO]
>>> ------------------------------------------------------------------------
>>> [INFO] Internal error in the plugin manager executing goal
>>> 'org.apache.camel:cam
>>> el-maven-plugin:1.4.0.0-fuse:run': Unable to find the mojo
>>> 'org.apache.camel:cam
>>> el-maven-plugin:1.4.0.0-fuse:run' in the plugin
>>> 'org.apache.camel:camel-maven-pl
>>> ugin'
>>> org/codehaus/mojo/exec/AbstractExecMojo
>>> [INFO]
>>> ------------------------------------------------------------------------
>>> [INFO] For more information, run Maven with the -e switch
>>> [INFO]
>>> ------------------------------------------------------------------------
>>> -------
>>>
>>> Does anyone have idea what is wrong?
>>>
>>> Thanks,
>>>
>>> Vlad
>>>
>>>
>>>
>>>      
>>    
>
>